Announcement

Collapse
No announcement yet.

Bluetooth Connector V2.45.2.2 + Bluetooth Client posted

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Timeout processing ASPX page

    Comment


      #17
      OK. This means Bluetooth device discovery is so slow, that internet explorer times out before discovery is done !

      1- Do you know approximatively how long does it take before timing-out ?

      2- Did you change a timeout parameter within Internet explorer ?

      3- If you come back to the plugin web configuration interface 2 minutes after the error message, can you see any device added in the Bluetooth device page ?

      4- What is your bluetooth stack version ? Can you copy/paste the first few lines of HomeSeer log when the plugin is starting ? The bluetooth stack version should be printed in the log.

      5- When you do a normal bluetooth discovery from Windows, how long does it take ?
      --
      stipus

      Comment


        #18
        See attached
        Attached Files

        Comment


          #19
          The plugin cannot be stopped and restarted. This is a limitation of the Bluetooth library. You need to restart homeseer.
          --
          stipus

          Comment


            #20
            12/2/2007 1:43:21 PM Info Interface BT Connector is running as a trial, 25 days remaining.
            12/2/2007 1:43:21 PM BT Connector BT Connector 2.44.2.2 Copyright 2006 stipus@stipus.com
            12/2/2007 1:43:21 PM Info Initializing Plug-in: BT Connector
            12/2/2007 1:43:21 PM BT Debug BT Connector : Debug Mode activated. Waiting 10 secs...
            12/2/2007 1:43:31 PM Info Finished initializing plug-in BT Connector
            12/2/2007 1:43:31 PM BT Debug BT Connector : Network0: Microsoft Bluetooth Stack 5.1.0.2600 Enabled= True AutoDiscovery=True AutoDiscoveryInterval=15
            12/2/2007 1:43:31 PM BT Debug BT Connector : 0 Bluetooth device(s) configured

            Comment


              #21
              The Bluetooth library author just released a new version 1.21 yesterday.

              You can:
              - shutdown HomeSeer
              - Copy all dlls in the ZIP to your HomeSeer 2 directory
              - Restart HomeSeer and try again.


              [EDIT] Attachement removed, as it's not compatible anymore with the latest plugin version available from the updater.
              Last edited by stipus; January 16, 2008, 11:15 AM.
              --
              stipus

              Comment


                #22
                I now have the device listed but I have not configured somthing correct necause I can power off the phone I am using and do not see a status change or get it to activate x10. is there any kind of manual for this?

                Comment


                  #23
                  That's very good news !
                  This means the old library really had a problem with your Bluetooth stack, and this has just been fixed !!!

                  For your new problem, the phone must not be bonded to windows, otherwise it's always seen as "found" with auto-discovery.

                  You have to go to the Windows Bluetooth Neighborhood, and remove your phone from the bound devices.
                  --
                  stipus

                  Comment


                    #24
                    12/2/2007 4:57:37 PM X10 Received H3 ( Basement Stairs Light) H On
                    12/2/2007 4:57:40 PM BT Debug Polling Motorola Phone (Method=AutoDiscovery) on Network0 returned signal strength=0
                    12/2/2007 4:57:51 PM BT Debug Polling Motorola Phone (Method=AutoDiscovery) on Network0 returned signal strength=0
                    12/2/2007 4:57:51 PM BT Debug AutoDiscovery found 1 device(s)
                    12/2/2007 4:58:01 PM BT Debug Polling Motorola Phone (Method=AutoDiscovery) on Network0 returned signal strength=0
                    12/2/2007 4:58:02 PM BT Debug AutoDiscovery found 0 device(s)
                    12/2/2007 4:58:12 PM BT Debug Polling Motorola Phone (Method=AutoDiscovery) on Network0 returned signal strength=-2147483648
                    12/2/2007 4:58:12 PM BT Debug Bluetooth Device Motorola Phone value changed to 0
                    12/2/2007 4:58:14 PM BT Debug AutoDiscovery found 0 device(s)
                    12/2/2007 4:58:22 PM BT Debug Polling Motorola Phone (Method=AutoDiscovery) on Network0 returned signal strength=-2147483648
                    12/2/2007 4:58:25 PM BT Debug AutoDiscovery found 0 device(s)
                    12/2/2007 4:58:33 PM BT Debug Polling Motorola Phone (Method=AutoDiscovery) on Network0 returned signal strength=-2147483648
                    12/2/2007 4:58:37 PM BT Debug AutoDiscovery found 0 device(s)



                    here is a copy of the log it looks like it is now responding but I do not understand what it is telling me . I am not getting triggers on n16 which is what I set it to

                    Comment


                      #25
                      You have to create a trigger on device value change. The plugin doesn't change the device status, and if you created a trigger on device status change, it's normal that it does not trigger.
                      --
                      stipus

                      Comment


                        #26
                        I have 2 events that I setu p as x10 trigger 1 turns on a few things and the other turns of the same devices is it possible to use your plug in to trigger events?

                        Comment


                          #27
                          You cannot use a "X10 Trigger" for bluetooth devices.
                          You need to use a "Value Change Trigger".

                          --> HomeSeer Events Window
                          --> Add event
                          --> Trigger Tab
                          --> In the "Current Trigger Type" combo-box, select "Device Value Change"

                          Then in the Action tab, you can choose a Device Action to switch on/off X10 devices.
                          --
                          stipus

                          Comment


                            #28
                            OK I am making baby steps here. should this when configured see the bluetooth all od the time when in range? my goal is to turn on stuff in my home office when I am in or near with my phone or maybe a bluetooth earpiece is this possible?

                            Comment


                              #29
                              Originally posted by tteer View Post
                              OK I am making baby steps here. should this when configured see the bluetooth all od the time when in range? my goal is to turn on stuff in my home office when I am in or near with my phone or maybe a bluetooth earpiece is this possible?
                              Yes, this is what I do to test the plugin. I create 2 events on device value changed.

                              Changed to "Away" --> I switch off a X10 light
                              Changed to "Found" --> I switch the X10 light on.
                              --
                              stipus

                              Comment


                                #30
                                That is what is happening but it only detects when I put it in find me and then a minute or so later it loses it and then turns everthing off while I am still tring to work. I do not understand it only thinks my razar phone is there in the findme or right after bluetooth is turnned on.

                                Comment

                                Working...
                                X