Announcement

Collapse
No announcement yet.

Microsoft Bluetooth stack can't be found

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Microsoft Bluetooth stack can't be found

    Detection of my other phone (Motorola Q) worked fine last time I tested this, but suddenly stopped. I try a scan for new devices (for the heck of it to test the system) and I get the error below. Last time I had that error, I tested the Microsoft scan, and saw that it had problems, but this time Microsoft can find the device, no problem.

    Any ideas?



    Server Error in '/' Application.
    --------------------------------------------------------------------------------

    Bluetooth is disabled. The MS Bluetooth stack cannot be found (first device).
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.Exception: Bluetooth is disabled. The MS Bluetooth stack cannot be found (first device).

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:


    [Exception: Bluetooth is disabled. The MS Bluetooth stack cannot be found (first device).]
    System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessag e(IMessage reqMsg, IMessage retMsg) +1734594
    System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(Mess ageData& msgData, Int32 type) +826
    HSPI_BT.BtScanner.ScanForNewDevices() +0
    hspi_bt_web.DeviceList.scanButton_Click(Object sender, EventArgs e) +24
    System.Web.UI.WebControls.Button.OnClick(EventArgs e) +75
    System.Web.UI.WebControls.Button.RaisePostBackEvent(String eventArgument) +97
    System.Web.UI.WebControls.Button.System.Web.UI.IPostBackEven tHandler.RaisePostBackEvent(String eventArgument) +7
    System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument) +11
    System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData) +33
    System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +4921




    --------------------------------------------------------------------------------
    Version Information: Microsoft .NET Framework Version:2.0.50727.832; ASP.NET Version:2.0.50727.832

    #2
    This is a message from the Bluetooth library...

    If you are 100% sure you didn't deactivate bluetooth on your computer, you may want to try the updated version of the bluetooth library I just posted here:

    http://board.homeseer.com/showthread...=124811&page=2
    --
    stipus

    Comment


      #3
      I fixed this particular problem by uninstalling all bluetooth and rebooting the PC. then I updated the bluetooth tools.

      With that problem gone, now I think I have found a bug. Scan for new devices only seems to work once, the second time it hangs for me every time.

      Comment


        #4
        OK. I'll have a look at this problem.

        With some BT stacks, I may need to pause current discoveries before I start scanning, as I have done in the Bluetooth client for last release.
        --
        stipus

        Comment


          #5
          Not critical of course, I reboot Homeseer and then it works fine.

          thanks

          Comment


            #6
            Ok, now all my devices are away and stay away. If I run bluetooth discovery on the computer (I am careful not to add them) it finds all three devices just fine. However the plugin does not.

            I did a scan, and got this error, not sure if related:

            12/2/2007 5:03:10 PM - BT Debug - Error while polling MYPC: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.

            Comment


              #7
              Ok, to help figure out the problem.

              1. Rebooting doesn't help.
              2. Changing network to "AutoDiscovery" then finds my laptop, but not the two phones.

              ?

              Comment

              Working...
              X