Announcement

Collapse
No announcement yet.

iPhone Compatibility

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    i have to check this out as my wife now has an iPhone 4s and I have an Android...
    HW - i5 4570T @2.9ghz runs @11w | 8gb ram | 128gb ssd OS - Win10 x64

    HS - HS3 Pro Edition 3.0.0.435

    Plugins - BLRF 2.0.94.0 | Concord 4 3.1.13.10 | HSBuddy 3.9.605.5 | HSTouch Server 3.0.0.68 | RFXCOM 30.0.0.36 | X10 3.0.0.36 | Z-Wave 3.0.1.190

    Hardware - EdgePort/4 DB9 Serial | RFXCOM 433MHz USB Transceiver | Superbus 2000 for Concord 4 | TI103 X-10 Interface | WGL Designs W800 RF | Z-Net Z-Wave Interface

    Comment


      #17
      As far as I know, it works, but it's not perfect.

      The problem is within the iPhone Bluetooth stack, ... if it gets too repetitive queries, after a while it stops answering to reduce battery drain.

      Saving battery life is a good feature for the iPhone, but it's not for a reliable Bluetooth detector such as the BT Connector plugin.

      This is based on tests with an iPhone 4 with IOS4.0, something like 18 months ago. It's possible this has changed since then... IOS5 ... etc.

      If anyone has a good working solution, it would be nice to share your IOS version, your plugin settings (polling method, interval...), and maybe details about your computer (Windows version, windows BT stack or specific stack, the dongle model you are using).

      Best regards,

      stipus
      --
      stipus

      Comment


        #18
        I have just installed the BT connector and have seen a couple of problems. This is one.

        When my iPhone (4S, latest ios5) goes away i assumed it was asleep. when i get into my car, however, without touching the phone it will immediately and automatically resume its communication with the car.

        This must mean that the car does something which causes the iPhone to cheer up and get sociable again.

        If I could find out I'd try to use a similar setting in the connector.

        Comment


          #19
          Just installed the client software on my PC as well as having it running on the HS PC.

          on the remote PC i got the message

          22:54:50 Error while polling SJOG iPhone4: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.

          suggests some kind of program error?

          Comment


            #20
            On the client I had this message in its regular polling:

            10:34:40 Service discovery finished for device SJOG iPhone4

            Yet the HS status on the device is only sometimes updated - at the moment the status is still showing Away.

            surely if service discovery happened, the phone is within range? in which case why is the device status not updated?

            Comment


              #21
              Originally posted by simonog View Post
              I have just installed the BT connector and have seen a couple of problems. This is one.

              When my iPhone (4S, latest ios5) goes away i assumed it was asleep. when i get into my car, however, without touching the phone it will immediately and automatically resume its communication with the car.

              This must mean that the car does something which causes the iPhone to cheer up and get sociable again.

              If I could find out I'd try to use a similar setting in the connector.
              The car uses the "Connect Service" method to connect to the iPhone. This one always work even if the phone is in a deep sleep.
              After a connect service, the phone wakes-up and "Auto Discovery" discovers the phone.
              --
              stipus

              Comment


                #22
                thank you - good to have the sequence explained.

                So how do i get the BT Connector to simulate the same behaviour?

                I tried Connect Service (1) and it finds the phone less often than Discover Service.

                It seems so near that it's a bit frustrating!

                Phone is paired to both the HS pc and the client pc.

                Comment


                  #23
                  The remote client is getting this message after about 10 minutes of a connected client:

                  17:03:45 Error while polling Kates iPhone4: Service lookup timed out

                  The phone is right next to the PC. Any idea what causes the timeout?

                  Comment


                    #24
                    I have now worked out why my client PCs were sometimes losing connection with the BT devices.

                    I had to DISABLE allowing the operating system to turn off the BT adaptor to manage power (device manager, bluetooth device, power management), and I had to DISABLE power management of the USB hubs in power management control panel (if I didn't, the BT adaptor stayed on but its internal PC hub eventually turned off).

                    Comment


                      #25
                      That catches a lot of people out including me.

                      Thanks for the reminder as I am about to transfer HS and it's entourage to a brand new PC. I had forgotten about that small but.
                      sigpic
                      A founder member of "The HA Pioneer Group" otherwise known as the "Old farts club!"
                      HomeSeer 3 V 3.0.0.318 with ALEXA (AKA Amazon Echo)
                      BL Radar V2.0.217; BLRF V2.0.85.0; HS Touch V3.0.0.1034 X10 V3.0.0.42; PHLocation V3.0.0.38; Zwave V3.0.1.110; X10 V3.0.0.42
                      BLBackup V2.0.39;ImperiHome3.0.0.20 All on Windows XP Pro

                      Comment

                      Working...
                      X