Announcement

Collapse
No announcement yet.

plugin install failed

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    plugin install failed

    hi there i get the following error
    10/02/2009 21:31:59 - Error - Accessing registration property of .NET plugin: Error looking-up SID: 1788
    and then
    10/02/2009 21:31:59 - Error - Cannot access plug-in (may need to be re-installed): HSPI_BT.HSPI ->


    i have tried re installing the plugin but cant get this to work..

    anyone got any ideas?

    Cheers
    Chris

    #2
    i also get an error with the SIP plugin

    10/02/2009 21:32:15 - Warning - VB Net scripting, could not add assembly referenced from settings.ini: C:\Program Files (x86)\HomeSeer 2\hspi_sip.dll


    have I missed something?

    Comment


      #3
      Hello I have really no clue. You are the first one writting on the board with such problems over years...

      Do you have a special operating system ?
      Do you have a virus that could have deleted files ?
      Do you have UAC active on your system ?
      --
      stipus

      Comment


        #4
        hi there ,

        its windows 2003 , nothing special in terms or UAC ... and i have turned my AV off to check,.

        All other plugins I have seem to work , Skype, RFXCOM etc

        very strange ... it does require a certain .net version does it ?

        Cheers
        Chris

        Comment


          #5
          ok i have fixed the SIP issue .. I had a typo i the settings.ini file for homeseer... not sure how I managed to do that

          i cant see anything in settings.ini for the bluetooth plugin , do you have anything in yours? could you screen shot it ?

          cheers
          chris

          Comment


            #6
            I noticed that my homeseer folder is

            C:\Program Files (86)\HomeSeer 2

            I must have made a typo when I installed it... SIP wanted to connect to C:\Program Files (x86)\HomeSeer 2 in the settings.ini. I changed ito the correct path and it works again.

            Where does the bluetooth plugin keep all its settings / paths etc ?

            Chris

            Comment


              #7
              Do you have a 64-bit edition of Windows 2003 server ?

              Do you have the following files in the HomeSeer 2 directory:

              - hspi_bt.dll
              - Franson.BlueTools.200.dll
              - BlueTools.dll
              - BlueToolsMS.dll
              - BlueToolsWC.dll
              - BlueToolsWC150.dll
              - BluetoothClient.exe

              If any of those files is missing, the plugin won't start. I'm also going to check the Bluetools support forum if the Bluetools library is compatible with Windows 2003 Server 64-bit edition.

              By the way, which Bluetooth stack do you have on your server ? As far as I know the Microsoft stack is not available on Windows 2003 Server (32 and 64 bit editions), and the Widcomm stack doesn't have a 64-bit version...
              --
              stipus

              Comment


                #8
                thanks stipus

                its actually 32bt windows 2003 .. my 64bit broke so i transferred it to this 32 bit server and kept the same folder structure. apart from the typo i made with X86 being just 86

                all the files are there in the homeseer folder.

                Perhaps I need to reinstall and put everything back to where homeseer should be on a 32bit OS... just that i have everything working apart form bluetooth ...

                thanks for your help.. do you have anything in the settings.ini ? how does homeseer call the plugin?

                cheers
                Chris

                Comment


                  #9
                  i purchased this
                  ASUS WL-BTD-201M

                  and installed the ASUS software that comes with it. I can see all the bluetooth devices in my house from with the Bluetooth software (ASUS)

                  cheers
                  Chris

                  Comment


                    #10
                    Originally posted by laserchris View Post
                    thanks stipus

                    its actually 32bt windows 2003 .. my 64bit broke so i transferred it to this 32 bit server and kept the same folder structure. apart from the typo i made with X86 being just 86

                    all the files are there in the homeseer folder.

                    Perhaps I need to reinstall and put everything back to where homeseer should be on a 32bit OS... just that i have everything working apart form bluetooth ...

                    thanks for your help.. do you have anything in the settings.ini ? how does homeseer call the plugin?

                    cheers
                    Chris
                    HomeSeer enumerates all dll named hspi_xxxxx.dll in the HomeSeer folder, and calls a function in each dll found with such a name.
                    --
                    stipus

                    Comment


                      #11
                      i uninstalled Homeseer and reinstalled on the same machine and i still get the same error.

                      any ideas how I can fix this?

                      Cheers
                      chris

                      Comment

                      Working...
                      X