Announcement

Collapse
No announcement yet.

Weather module problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Weather module problem

    I have downloaded the weather module and am having a problem with the installation. The recurring event for the weather update is looking for the script - hac_weather.txt. I do not have that script. Also, when I go to the weather page, there is a setup button. When I click on it, all I see is Setup for HAC_Weather in bold leters and nothing else.
    Thanks for any ideas you might have,
    Dave

    #2
    Hi,
    Please download the zip file again, all files should be there this time.

    I also modified the setup file, hopefully this will fix the problem there.

    Let me know how it goes.

    Thanks,
    Bryan
    Bryan
    Software/Hardware: Win10 Pro, HS 3 Pro, HS Touch, Echo, Edgeport/4, Z-Net w/88 Devices, Insteon PLM w/19 Devices, Nest, GC-100-6, W800RF32A, WS-2080 Weather Station (KMADRACU10)
    Plug-in/Scripts: Alexa API, BLBackup, BLGData, BLLED, BLLock, BLRF, BLTVGuide, Blue Iris, BLUPS, Current Cost 3P, DirectTV, FitbitSeer, Insteon, Nest, Pushover 3P, Random, Restart, Tasker, UltraGCIR3, UltraWeatherWU, Z-Wave

    Comment


      #3
      Closer, but not quite! The script does now run and the devices do show the correct location, temp, humidity etc. in the Homeseer devices. However, in the HA Control weather window, all I see is 2 boxes and the weather underground logo at the top of the window. The first box shows the zip code (the one I entered in setup) and the 2nd box shows the word "setup". When I click on the logo, it takes me to the weather underground web site. The "setup" box takes me to the area to enter the zip codes and PWstation info ( I did enter the data there). When I click on the box with my zip code, nothing happens.

      Comment


        #4
        Well, at least we are making progress!

        So let's try again, go ahead and redownload the module.

        Again, please let me know how it goes.

        Thanks.
        Bryan
        Software/Hardware: Win10 Pro, HS 3 Pro, HS Touch, Echo, Edgeport/4, Z-Net w/88 Devices, Insteon PLM w/19 Devices, Nest, GC-100-6, W800RF32A, WS-2080 Weather Station (KMADRACU10)
        Plug-in/Scripts: Alexa API, BLBackup, BLGData, BLLED, BLLock, BLRF, BLTVGuide, Blue Iris, BLUPS, Current Cost 3P, DirectTV, FitbitSeer, Insteon, Nest, Pushover 3P, Random, Restart, Tasker, UltraGCIR3, UltraWeatherWU, Z-Wave

        Comment


          #5
          Downloaded the new version. I do have the zip code/setup/wunderground icons at the bottom of the window now. The weather images with the correct data (temp/cloudy/rain etc). Unfortunately, the weather.text script does error when run, so i do not have the correct data at the top and no data populates in the Homeseer device view. The error that appears when the script is run is ---

          3/26/2009 8:33:47 PM - Error - Running script, script run or compile error in file: hac_weather.txt76:Path not found in line 10 More info: Path not found

          3/26/2009 8:37:48 PM - Error - Web Server Error 404, cannot serve file: C:\Program Files\HomeSeer 2\html/HAControl/hac_weather/images/.gif

          Thanks,
          Dave

          Comment


            #6
            Originally posted by infrared photoman View Post
            3/26/2009 8:37:48 PM - Error - Web Server Error 404, cannot serve file: C:\Program Files\HomeSeer 2\html/HAControl/hac_weather/images/.gif
            Curious: In what directory did you install HAC_Weather?
            It should be in HomeSeer 2\html\HAC_Weather not in HomeSeer 2\html\HAControl\hac_weather.
            Bryan
            Software/Hardware: Win10 Pro, HS 3 Pro, HS Touch, Echo, Edgeport/4, Z-Net w/88 Devices, Insteon PLM w/19 Devices, Nest, GC-100-6, W800RF32A, WS-2080 Weather Station (KMADRACU10)
            Plug-in/Scripts: Alexa API, BLBackup, BLGData, BLLED, BLLock, BLRF, BLTVGuide, Blue Iris, BLUPS, Current Cost 3P, DirectTV, FitbitSeer, Insteon, Nest, Pushover 3P, Random, Restart, Tasker, UltraGCIR3, UltraWeatherWU, Z-Wave

            Comment


              #7
              I did put it in the HAControl folder. When I have it in the html folder, the button on the homepage will not work. I get an error that says --
              Script Error:
              File not found: C:\Program Files\HomeSeer 2\html\HAControl/HAC_Weather/hac_weather.ash

              In the main menu setup, I have
              Name- Weather
              Content- HAC_Weather\hac_weather.ash
              Page- fullscreen

              When I put the weather folder in the hacontrol folder, the button does take me to the correct screen.

              Comment


                #8
                Now we are getting somewhere.

                The module must be located in the html directory. The other problem is the way you are launching the weather module. It needs to be launched just like the original weather module that came with HAControl. Remember this replaces the original weather module.

                Main Menu Setup:
                Name: Weather
                Content:
                PageType: 3

                Give this a go and see what happens.

                I'll add the Main Menu Setup info to the Doc too. It is a little fague in that area.

                Thanks.
                Bryan
                Software/Hardware: Win10 Pro, HS 3 Pro, HS Touch, Echo, Edgeport/4, Z-Net w/88 Devices, Insteon PLM w/19 Devices, Nest, GC-100-6, W800RF32A, WS-2080 Weather Station (KMADRACU10)
                Plug-in/Scripts: Alexa API, BLBackup, BLGData, BLLED, BLLock, BLRF, BLTVGuide, Blue Iris, BLUPS, Current Cost 3P, DirectTV, FitbitSeer, Insteon, Nest, Pushover 3P, Random, Restart, Tasker, UltraGCIR3, UltraWeatherWU, Z-Wave

                Comment


                  #9
                  Changed the main menu setup to
                  weather
                  hac_weather\hac_weather.ash
                  3

                  hacontrol weather is in the html folder by itself, not in the hacontrol folder.

                  I get the following errors--

                  3/26/2009 10:47:43 PM - Web Server Erro - Cannot serve file: C:\Program Files\HomeSeer 2\html\HAControl/hac_weather.ash
                  3/26/2009 10:47:43 PM - Error - Reading script: C:\Program Files\HomeSeer 2\html\HAControl/hac_weather.ash Argument 'Number' must be greater or equal to zero.
                  3/26/2009 10:47:43 PM - Error - Running script: File not found: C:\Program Files\HomeSeer 2\html\HAControl/hac_weather.ash

                  Comment


                    #10
                    Originally posted by infrared photoman View Post
                    Changed the main menu setup to
                    weather
                    hac_weather\hac_weather.ash
                    3

                    hacontrol weather is in the html folder by itself, not in the hacontrol folder.

                    I get the following errors--

                    3/26/2009 10:47:43 PM - Web Server Erro - Cannot serve file: C:\Program Files\HomeSeer 2\html\HAControl/hac_weather.ash
                    3/26/2009 10:47:43 PM - Error - Reading script: C:\Program Files\HomeSeer 2\html\HAControl/hac_weather.ash Argument 'Number' must be greater or equal to zero.
                    3/26/2009 10:47:43 PM - Error - Running script: File not found: C:\Program Files\HomeSeer 2\html\HAControl/hac_weather.ash
                    Please read my previous post.

                    Main Menu Setup is the SAME as it was before you installed HAC_Weather.

                    Main Menu Setup:
                    Name: Weather
                    Content:
                    PageType: 3

                    Notice the Content is blank and the PageType is 3.
                    Bryan
                    Software/Hardware: Win10 Pro, HS 3 Pro, HS Touch, Echo, Edgeport/4, Z-Net w/88 Devices, Insteon PLM w/19 Devices, Nest, GC-100-6, W800RF32A, WS-2080 Weather Station (KMADRACU10)
                    Plug-in/Scripts: Alexa API, BLBackup, BLGData, BLLED, BLLock, BLRF, BLTVGuide, Blue Iris, BLUPS, Current Cost 3P, DirectTV, FitbitSeer, Insteon, Nest, Pushover 3P, Random, Restart, Tasker, UltraGCIR3, UltraWeatherWU, Z-Wave

                    Comment


                      #11
                      Yipee, works great. I guess I should not be working on this stuff after a long day at work! Thanks for your help. Love the program (and the WAF just went up again).
                      Dave

                      Comment


                        #12
                        lol, no problem. Glad to hear you got it working!
                        Bryan
                        Software/Hardware: Win10 Pro, HS 3 Pro, HS Touch, Echo, Edgeport/4, Z-Net w/88 Devices, Insteon PLM w/19 Devices, Nest, GC-100-6, W800RF32A, WS-2080 Weather Station (KMADRACU10)
                        Plug-in/Scripts: Alexa API, BLBackup, BLGData, BLLED, BLLock, BLRF, BLTVGuide, Blue Iris, BLUPS, Current Cost 3P, DirectTV, FitbitSeer, Insteon, Nest, Pushover 3P, Random, Restart, Tasker, UltraGCIR3, UltraWeatherWU, Z-Wave

                        Comment

                        Working...
                        X