Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

Please help with 'An unexpected error occured in the Check_Motion(0)'

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Please help with 'An unexpected error occured in the Check_Motion(0)'

    I've just upgraded to 3.1.5 and I'm getting this error;

    Hauppauge Capture Error~!~An unexpected error occured in the Check_Motion(0) function/subroutine: [91 - Object variable or With block variable not set]

    When I run the script which used to work with the previous version. No pictures are snapped :-(

    sub main()
    on error resume next
    hs.plugin("Hauppauge Capture").MotionDetected("Inside Hells Kitchen PIR")
    if err then err.clear
    end sub

    Cap Preview and the web interface work a treat.

    I'm using a Hauppauge USB device in the UK fed via composite video.

    I see no Errors when Homeseer initialises.

    Have I missed something?

    Thanks

    Giles


    Giles

  • #2
    Giles,

    I had this same problem and switched over to using TakePicture and bypassed all the motion stuff entirely. I never got around to reporting the problem, since I decided to do it another way.

    Bill

    Comment


    • #3
      Thanks for the steer Bill

      It works that way for me too now using Take Picture

      Giles

      Comment


      • #4
        I just looked at the code and to me it appears the only way this error could be generated is if there was no motion sensors found based on the "MS Identifier" in the General tab of the config screen.

        If you go into "Security Zones" in the config screen - do you see any active security zones? If not check the "MS Identifier" entry in the General tab and make sure it is correct.
        Bryan
        (Config is in my profile)

        Comment


        • #5
          Yes there are Active Security Zones and they are armed.

          One thing I did notice on one of the versions was that it gave a warning that the house code that was being used for the 'Security Control' devices it was using was [ rather than ]. This is because my Ocelot was already using ] for its variables.

          Version 3 did not give the warning and indeed during the set-up did seem to have spotted this.

          As you can see above I have worked around this but 'for the good of the code' it would be nice to see it fixed.

          Giles

          Comment


          • #6
            I have added extra error checking in 3.1.6 to determine exactly what is causing this error. Will your email accept a zip attachment of 240k?

            If so, send me an email to bstein@accesscomm.ca and I'll send it to you along with installation instructions.
            Bryan
            (Config is in my profile)

            Comment

            Working...
            X