Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

An unexpected error occured.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • An unexpected error occured.

    I am having some trouble. My Hauppauge D card with some xcams wouldn't work at all. I have a USB webcam that is trying to work. When I try to select it in the capture cappreview it won't select and I am getting the error
    an unexpected error occured in the ResetCameraConfig(820)function / Subroutine [9 - Subscript out of range]
    Can anyone help me get past this?
    thanks.

  • #2
    Mike

    Do you have both the Hauppauge D card and the USB webcam active at once? If so, go into the General tab of the config screen and select the Hauppauge D card for the primary capture card - ckick OK. Restart Homeseer and give it a try again.

    Only one capture device can be used by the plugin at once. It should support multiple devices but will only use one of them. The other should be free to use for whatever purpose you want.
    Bryan
    (Config is in my profile)

    Comment


    • #3
      Hi, I did that and it won't let me select the camera. I select it (and its the only one in the list) I do set and OK but when I go beck in it says default camera settings still. When I try to select it in cappreview I get the unexpected error in the log and it will not select. Maybe I should rip out the Hauppauge card and see what happens.

      Comment


      • #4
        Can your email accept 250K attachments? I can email you version 3.1.6 that has extra debugging and error checking. It will tell me what is happening with 2 capture devices installed in a machine.

        Send me an email to bstein@accesscomm.ca and I'll send it to you.
        Bryan
        (Config is in my profile)

        Comment


        • #5
          OK, the new version got me much further. My problems now:
          When I exit homeseer and restart I loose all of my configs. No ms identifier, camera device type, all cleared out. If I exit and restart capconfig without resterting homeseer the configs stay.
          When I try to stream I get:
          An unexpected error occured in the tmActivateStream_timer(50)function/subroutine: [-2147417848 - Automation error The object invoked has disconnected from its clients. ]

          I have a crazy x-girlfriend who is going to wreck up my place and would like to have some pictures. I'll post them for amusement if I can.

          Comment


          • #6
            Can you set the logging level to debug level 1 and restart HS - select the video capture device and restart HS.

            email me the ah.log file in the main HS folder

            Thanks
            Bryan
            (Config is in my profile)

            Comment


            • #7
              Well, I gess my system is not compatable. How do I uninstall the plugin?

              Comment


              • #8
                To uninstall the plugin go into the HomeSeer menu item View->Options and select the plugin and click the remove button. Delete the files that are in the plugin's zip file.
                Bryan
                (Config is in my profile)

                Comment

                Working...
                X