Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

Problems with thumbs pages after update

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems with thumbs pages after update

    Found problem I was using a Bata build of HS 2.2063 went back to 2052 no problem now.


    I updated to version 4.1 and I am now getting the following error on the thumb and AVI thumbs pages:

    Script error: Object required: 'hsMakeThumb'


    option explicit
    Set fso = Nothing
    'hs.writelog "ListThumb", "VPath='" & VPath & "' | sCapFolder='" & sCapFolder & "' | fromDate='" & fromDate & "'"
    'hs.writelog "ListThumb", "fromHour= '" & fromHour & "' | Columns='" & Columns & "' | PageSize='" & PageSize & "' | ShowFilenames='" & _
    'ShowFilenames & "' | nNameLoc='" & nNameLoc & "' | nDateLoc='" & nDateLoc & "' | nTimeLoc='" & nTimeLoc & "'"
    Call ListThumbs(VPath,sCapFolder,sCapFile,fromDate,fromHour,Colum ns,PageSize,ShowFilenames,nNameLoc,nDateLoc,nTimeLoc,nFontSi ze)
    sTemp = hs.GetAppPath & "/html/tail.htm"
    sTemp = filecontents(sTemp)
    If sTemp <> "No File" Then
    sTemp = replace(sTemp,"powered","/powered")
    response.write stemp
    End If


    option explicit
    Set fso = Nothing
    'hs.writelog "ListThumb", "VPath='" & VPath & "' | sCapFolder='" & sCapFolder & "' | fromDate='" & fromDate & "'"
    'hs.writelog "ListThumb", "fromHour= '" & fromHour & "' | Columns='" & Columns & "' | PageSize='" & PageSize & "' | ShowFilenames='" & _
    'ShowFilenames & "' | nNameLoc='" & nNameLoc & "' | nDateLoc='" & nDateLoc & "' | nTimeLoc='" & nTimeLoc & "'"
    Call ListThumbs(VPath,sCapFolder,sCapFile,fromDate,fromHour,Colum ns,PageSize,ShowFilenames,nNameLoc,nDateLoc,nTimeLoc,nFontSi ze)
    sTemp = hs.GetAppPath & "/html/tail.htm"
    sTemp = filecontents(sTemp)
    If sTemp <> "No File" Then
    sTemp = replace(sTemp,"powered","/powered")
    response.write stemp
    End If


    All other pages and the capture are working with no problems.

    Any ideals?
    Last edited by jsandlin; February 11th, 2006, 05:09 PM.

  • #2
    Were the thumbs working under 2052? Did you upgrade both the version of HS and the plugin at the same time? If you did, my advice is to never upgrade more than one thing at a time. My practice is to only upgrade one thing at a time so that if something breaks you know what caused the break.

    The error you described occurs in the ListThumbsInc.asp and ListThumbsIncAVI.asp include files and actually the error doesn't make sence. I enumerate through the available plugin's in HS until I find the Hauppauge Capture plugin and then simply use that reference to call the makethumb method of the plugin. If it couldn't find the plugin it will write the error "Can not connect to Hauppauge Capture" to the HS log. Can you check the HS log for that error.
    Bryan
    (Config is in my profile)

    Comment


    • #3
      I upgraded to HS 2063 a couple days ago with no problems, but I did not look at the thumbs pages so I thought that everything was ok. Then I upgraded the plugin and in checking all the functions that is when I noticed the errors on the thumbs pages. At the times of the errors there were no errors in the HS log. I then reinstalled version 4.0 of the plugin and had the same errors. At that time the only thing that I could think of was that I had upgraded HS so I went back to 2052 which I knew that everything was working and version 4.0 worked. I then upgraded to version 4.1 of the plugin and it is working great.

      I would put in a help desk ticket but from reading the other forums it seems that the HS team dose not want to know of problem until they release a version.

      Jim

      Comment

      Working...
      X