Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

Identifier Trouble

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Identifier Trouble

    Hello

    Using HS 2.2.0.11 and Hauppauge 4.1.2 and I cannot get past setting up devices and cameras. I've read all I can find, gone through the threads and no matter what I do I can't get Hauppauge plug-in to see them.

    I'm assuming I have to create a new device TYPES under setup so I created Motion MS and Camera MS. I then created 2 new devices called Computer Motion with device type set to Motion MS and Computer Camera with device type set to Camera MS.

    I have tried many variations of the identifier in the plug-in, such as spaceMS, " MS" etc. with no luck.

    What am I doing wrong here?

    Thanks

    Randy

  • #2
    More Info

    Still working on this.

    When I start HS the plug-in seems to install correctly according to the log. When I open the config window HS logs this:

    7/7/2007 4:06:11 PM - Hauppauge Captu - An unexpected error occured in the SSTab1_Click() function/subroutine: [429 - ActiveX component can't create object]
    7/7/2007 4:06:52 PM - Hauppauge Captu - An unexpected error occured in the GetDevices(40) function/subroutine: [429 - ActiveX component can't create object]
    7/7/2007 4:06:52 PM - Hauppauge Captu - An unexpected error occured in the MSDevType_LostFocus() function/subroutine: [429 - ActiveX component can't create object]
    7/7/2007 4:06:52 PM - Hauppauge Captu - An unexpected error occured in the UpdateCameraZoneAssignments(1120) function/subroutine: [3021 - Either BOF or EOF is True, or the current record has been deleted. Requested operation requires a current record.]

    I have also noticed that in the interface tab of HS the plug-in has X10 enable/disable and other enable/disable. Does the X10 have to be enabled? If I do HS disables my TI103 X10 interface.

    Thanks

    Comment


    • #3
      Again, More Info

      Been at this since 9:30 this morning, getting cranky!!!

      I think my main problem is that I can't get the plug-in to see a camera.

      On the general tab there is nothing in the drop down for Camera Device Type and I can't figure out how to get it there.

      There must be someone out there that can help me.

      Comment


      • #4
        Lets start at the top to track down what the problem is. First do you have VB6 SP5 runtime installed? If you don't you need to install it - you can get it here http://www.microsoft.com/downloads/d...displaylang=en
        Bryan
        (Config is in my profile)

        Comment


        • #5
          I Do Now

          Hi Bryan

          I've loaded VB6 SP5 files.

          When I start HS the log shows no errors with the plug-in load up, it found my Hauppauge card etc etc.

          I can open the Config window and as soon as I do that this error pops up.

          7/8/2007 7:00:53 PM - Hauppauge Captu - An unexpected error occured in the Form_Load(1600) function/subroutine: [429 - ActiveX component can't create object]

          Clicking assigment tab and securtiy tab shows nothing loaded but no errors. When I open AVI tab this error happens.

          7/8/2007 7:01:20 PM - Hauppauge Captu - An unexpected error occured in the SSTab1_Click() function/subroutine: [380 - Invalid property value]

          That's all I can tell you now. Thanks for the help.

          Randy

          Comment


          • #6
            The plugin is failing when it attempts to access the dictionary object which is located in the Microsoft Scripting Library. It is either missing or corrupted. Can you check to see if you have a file called "scrrun.dll" registered on your system - usually it is in the Windows\system32 folder.

            Information on how it can be downloaded is at http://support.microsoft.com/kb/254166

            p.s. if you already have this file on your system, please make a backup copy of it before installing a new one
            Bryan
            (Config is in my profile)

            Comment


            • #7
              Oh-Oh

              Well........

              I did have a scrrun.dll file, I did make a backup copy, I followed Microsoft's instructions for loading the new files and I did have a computer that worked.

              Killed 'er real good! Hangs at the log in screen and all attempts at resucitation failed, DOA.

              Can start in safe mode, replaced new scrrun with old scrrun, no good. Did system restore, no good. Hello clean install?

              I Ghost my work laptop on a regular basis I should learn to do it with my home computer.

              Oh well!

              Comment


              • #8
                Did you start it in command prompt mode and register the original DLL? I can't beleive it killed your whole system. The stupid restore should have brought back the original DLL also. Welcome to the wonderfull world of Microsoft

                Sorry about that Randy - I had no idea it blow it up that bad - sorry.
                Bryan
                (Config is in my profile)

                Comment


                • #9
                  Just a Bump in the Road

                  Hey Bryan

                  Been around these things long enough to know just because it happened after the file update doesn't mean that's what caused it.

                  Started in this when I thought a 40 pin MC6802 chip was huge and I coded it in machine code.

                  A search of the Web shows this problem is out there and causes are anywhere from bad memory, PSU problems, bad video card to it was lightening at that moment!

                  Event log shows disk errors of bad block. Trying to run recovery console but it is asking for Admin's password which I can't find, hec I write everything down in a note book as I do these things, maybe I forgot. Want to run Chkdsk but since it runs OK in safe mode can't see why it would be bad harddrive. Something else is going wonky here, I think.

                  If I can't resucitate by Friday I will do a clean install so I can get HS up and running again and get your plug-in fired up. My god, life is so hard, I have to turn a light on with a switch!

                  Keep you posted.

                  Randy

                  Comment


                  • #10
                    Getting Ready

                    Bryan
                    Here's my plan.
                    I can boot into safe mode easily. I've found out if I leave normal boot into XP long enough it will eventually get there, long time, 3/4 hour or more. I'm thinking maybe a wonky HD with very fragged files.
                    So my plan is a new HD with a fresh install of XP Pro, not Home. From there update XP, install video, anti-virus, network drivers, install Hauppauge card & drivers. From there I will install the latest HS program and install the TI103 X10 plug-in.
                    From here I need your help, what to do before I install your plug-in. We have a clean slate to start with.
                    Randy

                    Comment


                    • #11
                      The plugin install should have the majority of what you need. This is from the help file for the requirments.
                      Requirements
                      • This plugin requires that a capture device with WDM/DirectX drivers be installed in your PC.
                      • If streaming operation is desired, Microsoft Windows Media Encoder Version 9 is required and available from the Microsoft web site. Please note system requirements for the Microsoft Windows Media Encoder. Clients connecting to the stream must have Windows Media Player version 9 installed on the PC.
                      • HomeSeer version 1.5.43 or later is also required.
                      • The Jeff Farmer asp includes are required for asp pages to properly display headings to give the HomeSeer web appearance.
                      I have WMP 11 on my system and it works fine. If you don't have the ASP includes, I can send them to you.
                      Bryan
                      (Config is in my profile)

                      Comment


                      • #12
                        Here We Go

                        Ready.

                        Will load Media Encoder V9 first, already upped Media Player to 11.
                        Then the VB6 SP5 runtime files.
                        I don't have Jeff's files, are they on HS2's site?
                        Then install Hauppauge card, have latest files for it.
                        Then HS2, then the plug-in.

                        Cover me, I'm going in.

                        Comment


                        • #13
                          Much Better

                          Bryan

                          Things are up and running pretty good. Getting a couple errors, probably from my lack of knowledge in setting things up.

                          Can see my test camera in the preview.

                          What are the proper settings for the AVI codecs?

                          Thanks for your help.

                          Randy

                          Comment


                          • #14
                            I have the inculde scripts (old stuff) attached as a zip file. Now the codec's - That depends on what codec's you have installed on your PC. I'm using DivX 6.2.2 Codec for video and GSM 6.10 for audio. Seams to work not too bad.
                            Attached Files
                            Bryan
                            (Config is in my profile)

                            Comment


                            • #15
                              Includes Files

                              Bryan

                              Excuse my not knowing, but not sure what to do with these files.

                              My main goal now is to be able to use any computer on my home network and be able to see any camera channel on my Hauppauge.

                              Codecs that were auto picked by the plug-in are WMVideo8 Encoder DMO and WMA Voice Encoder DMO. Seems to work OK.

                              Randy

                              Comment

                              Working...
                              X