Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

HouseLinc keeps locking up

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HouseLinc keeps locking up

    Hi,

    I keep getting this error from Homeseer about HouseLinc not responding. In fact, I have to unplug the power for HouseLinc almost everyday or else it will lockup itself.

    This is the error I get from Homeseer, and when I get something like this, I have to power down HouseLinc and restart.

    ~!~Error~!~HouseLinc interface received improper response to STX in fSend_X10 ()

    Any insights would be greatly appreciated.

    P.S. I downloaded the HouseLinc plug-in from Homeseer but I couldn't find the other IR file but I'm not using IR at this point. Could it be the problem?

    Thanks

  • #2
    I've never used my HouseLink with HomeSeer, but I occasionally have the same problem. I use the HouseLink with a jukebox program and when I see this error, I exit the jukebox program and fire up the old Plato Software that came with it. I sometimes have to actually "tell" it to connect to the appropriate comm port, but this solves the problem better than 90% of the time. Saves a lot of time versus unplugging and removing the battery. I know this doesn't solve your problem, but I hope it helps a little until there is (hopefully) a solution.

    Jim

    Comment


    • #3
      ht,

      Make a copy of your irlbl.cfg and HLirlbl.cfg, then you rename the file HLirlbl.cfg to irlbl.cfg. They are in the HS directory. Also, you may want to install the newest hspi_HouseLinc.ocx file. I could not find it on the ftp site. Email me i can send you back a copy. I did have a little trouble in the begining with th ir and HouseLinc, but never the problem you stated.

      Rick

      1.5 GHz P4 256MB RAM
      Windows 98SE IE6
      HouseLinc for Ir & X10
      HL ocx Ver 1.1.8
      MR26a Ver 1.1.13
      SAPI 5 VR & TTS
      HomeSeer 1.5.2 b37
      HS Phone Ver 1.0.2 b8
      2 modems - USR 5965 & PN567V

      Comment


      • #4
        The latest version of the plug-in (1.1.12) should resolve this problem. I've e-mailed it to the 3 of you above. It should be posted shortly, but if anyone else needs it right away, let me know. It also resolves problems with preset-dims and status requests.
        Geoff

        P.S.
        htsource, your e-mail address bounced. If you email me, I'll send it to you.
        -Geoff

        Comment


        • #5
          Hi Geoff,

          Thank you for sending me the file, I didn't receive it but I've updated my profile for my e-mail address, it's: htsource@cgoeco.ca

          I registerd htsource.com and I guess the e-mail forwarding is flaky.

          I also need to thank you Rick for sending me the file, he sent me the version 1.1.0.8. Seems to be better now but I have problem getting status request for my SwitchLinc. It keeps telling me it's 6% dim when it's completely off.

          I don't know what to say but you guys have been extremely helpful, thanks again.

          Simon

          Comment


          • #6
            I believe you mean cogeco.ca; E-mail is on it's way.
            -Geoff

            Comment


            • #7
              Thanks again, ouch, can't even spell my cable company. Doh!!!

              Comment


              • #8
                Simon,

                I've tried to foward it to you twice now at "Simon Ngan [simon-ngan@cogeco.ca]" It came back both times.

                I will let Geoff send it to you.

                And you are welcome,

                Rick

                1.5 GHz P4 256MB RAM
                Windows 98SE IE6
                HouseLinc for Ir & X10
                hspi_HouseLinc.ocx Ver 1.1.12
                MR26a Ver 1.1.13
                SAPI 5 VR & TTS
                HomeSeer 1.5.2 b37
                HS Phone Ver 1.0.2 b8
                2 modems - USR 5965 & PN567V

                [This message was edited by HiTech on Friday, 22 March 2002 at 12:01 AM.]

                Comment


                • #9
                  Sorry still rejecting:

                  htsource@cogeco.ca: 216.221.81.25 failed after I sent the message. Remote host said: 552 Error: Message content rejected

                  The file is attached to this message. This forum didn't used to allow attachments, I guess it does now.
                  -Geoff

                  Comment


                  • #10
                    Geoff,

                    What is new / different in this latest version?

                    Thanks


                    -------------
                    GenevaDude

                    Comment


                    • #11
                      Hi guys,

                      I got the latest .12 version off this forum and I'll see what happen in the next day or so. I'm sorry for the troubles you guys had to go through with me. Couldn't say enough Thank You!!!

                      I sent a few test messages to myself from work and they all came through (both htsource@cogeco.ca and simon-ngan@cogeco.ca). Is it possible our cable company is blocking ocx attachments for possible viruses?

                      Anyway, thanks for the help and I think I'm up and running now.

                      Simon

                      Comment


                      • #12
                        Here's the read-me file for version 1.1.12. It contains the cumulative revisions & features since 1.0.0.
                        -Geoff

                        Comment

                        Working...
                        X