Announcement

Collapse
No announcement yet.

IR Set-up Problems and Questions

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • IR Set-up Problems and Questions

    Hopefully Geoff will see this one......

    I'm not sure where to post this one...in here or in the Touch Pad plugin area, but here goes.

    Within Plato, I have all my IR devices (TV, VCR, Cable Box, etc) set up and functioning properly. Absolutely, positively! Tested multiple times. I have reset them IR config and retested. Everything works. But now, with the new Touch Pad plugin, I want to be able to use my CF-01 or Point 510 and configure the IR setup in HS. A couple of questions relating to the IR set up as the manual and on-line helps are NOT much help.

    (1). What is the purpose of putting the IR device code in the IR config? Won't HS (thru the HL plugin) use the codes in the HL?

    (2). What is the purpose of the "download" button? Does this override the HL set up? Example: If I change the IR device code in HS and push the download button, does this get downloaded to the HL box and change what's already defined there?

    Now for the problem: I have three IR devices defined in HS (so far); TV, DVD player, and Receiver. Each has it's own unique IR device code. Each is controlled with it's own IR emitter on a seperate emitter port on the HL box. As previously stated, I can control each without problem thru Plato. The "remote control" shows up for each on the HS web page. Thru HS however, I can only control the TV and the receiver. I cannot get HS to control the DVD player! If I click on the "download" button in the HS Ir config for the DVD player, I can then control the DVD player, but then I lose control over the TV!!
    Only after quitting HS and going back into plato and resetting the IR config there can I again control all. Any help will be appreciated. If I need to move this somewhere else, let me know.

    Chuck

  • #2
    Chuck,

    If you moved this anywhere else, they'd have absolutely no idea what you are talking about. This is definitely the right place.

    OK, some basics about Plato, HS and HL device slots. The HouseLinc has 8 device "slots". You can assign device codes to these 8 device slots either in HS or Plato. In HS, you can explicitly put a certain device code in a certain device slot. So, if you put TV code 123 in the first device in HS, then hit "download", it will configure the first slot in the HouseLinc as TV 123. In Plato, when you configure a new device code, unfortunately, you do not have control over which device slot it goes into in the HouseLinc. So, the first device in Plato, may not be in the first slot in the HouseLinc.

    There's where the confusion comes in, if you configure devices in Plato, it's very difficult to know which slot it's in, and therefore difficult to configure HomeSeer with the same devices in the same slots. If you play round and can figure it out, it will work fine.

    If you don't have the same devices in Plato as in HomeSeer, you're going to have problems. If you hit TV Volume Up in HS, who knows, it'll do a Volume Up, but it might be on the CD Player.

    Are you following, or did I lose you?

    Geoff
    -Geoff

    Comment


    • #3
      Geoff,

      Thanks for the reply. Nope. not lost, at least not yet. If I delete all the IR devices in Plato and then set them up in HS and download them to the the HL box, will that work?

      I really think what you described is the problem. What's the easiest way to solve it?

      Chuck

      Comment


      • #4
        You don't actually have to delete the devices, although you can if you want. You can simply configure and download them all in HomeSeer and you should be all set.

        You should be sure to delete all IR sending macros in Plato because they'll continue to trigger, but they won't send the IR codes to the proper IR device any more. Plato downloaded X10 sending macros will continue to work fine.
        -Geoff

        Comment


        • #5
          Geoff,

          Thanks. I'm going to try and delete all the devices set up in Plato, then download the set up from HS. I think (too many different things tried to remember) I tried to download from HS already and it didn't work. Also, there is one device that errors out when downloading from HS to the HL; the device is my cable box and the code is 877. It sets up fine in Plato but will not set up in HS. The error says something about an invalid code that is not in the HL box. But I know it sets up in Plato. I upgraded the chip in the HL box several months ago as some of my newer devices didn't have a setup code. So, tonight I'll clear out Plato and try again. I'll let you know if it was successful or not.

          Chuck

          Comment


          • #6
            If the cable box doesn't work, try it in a different device slot in HS. Not all of the slots accept all of the device codes for some strange reason.
            -Geoff

            Comment


            • #7
              Geoff,

              Well, so far so good. I now can control 5 of 6 devices. The remaining device, the cable box, is giving me trouble.

              I defined the box in HS with the code with no trouble and uploaded it to the HL box. But I still can't control it. I cleared the device from the HS IR config, closed HS, opened Plato, set up the cable box and have no trouble at all controlling it. I left the device in Plato, quit Plato, opened HS and tried again. Still no go.

              Any ideas?


              Chuck

              Comment


              • #8
                Chuck,

                Try the cable box in another device slot in HS. If the code works in Plato, then it will work in HS.

                Actually what you can do is configure it in Plato, then use HS to figure out which device slot Plato configured it into, then enter the code into that slot in HS. Basically go into HS and hit the test button for each of the 8 devices until the cable box responds. Then you'll know which slot it's in.

                Wish there was an easier way, but the HouseLinc has some wierd quirks. It works great once it's configured, but getting it there isn't easy.

                Geoff
                -Geoff

                Comment


                • #9
                  Geoff. Thanks again. I'll try that tonight.

                  Chuck

                  Comment


                  • #10
                    Geoff,

                    Just to loet you know I now have everything working. I'm slowly adding buttons and functions.

                    What I did was delete everything from the IR set up in both Plato and HS. Then I configured just my cable box (the only problem child!) in Plato. Confirmed all was working. Then quit Plato, loaded HS and went into the IR config. Defined just the device. Did not input any IR code for the device, just pushed the test button in each of the 8 IR slots in HS. Found the cable box in slot 4. Then configured the rest of the devices in HS, entered the IR code and downloaded each individually to the HL box. SUCCESS!!!!

                    Now another question......

                    My receiver needs to be switched between modes depending on the source of the AV signal (Cable, VCR, DVD). But so far, I cannot find a predefined button (you know....pause, play, etc) that will do this. I haven't tested them all yet. Is there an easier way other than trial and error? Is this a problem with a limitation inthe HL box. As I said previously, I have the most current codes from HouseLinc. Suggestions? Hints? HELP!


                    Chuck

                    Comment

                    Working...
                    X