Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

Server Access Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Server Access Error

    Downloaded HSDroid application on EVO HTC from market.

    Followed directions and receive the following:

    Error within Homeseer:
    Web Server Error 404, cannot serve file: C:\Program Files\HomeSeer HS2\html/hsdroid2?cmd=GetCaps

    Error within EVO HTC:
    Server access failed with: Server validation failed.

    Both phone and server configured using port 8076. Established a new user account within Homeseer for mobile.

    Any suggestions?

  • #2
    This means that the HSDroid plug-in is not running in Homeseer. Did you go to interfaces and enable it?

    Dan

    Comment


    • #3
      Dan,

      I'm getting the exact same error om my Samsung Galaxy Note, but I'm not seeing the HS error. It worked shortly after I installed it, but then it stopped being able to connect to the server.

      I'm using TZO dynamic DSN with port forwarding to my HSPro machine, and I configured the client to server IP address to http://*****.tzo.com.

      It changed the address to just *****.TZO.COM. I'm not sure if that has anything to do with it, but HSDroid doesn't seem to support DNS.

      If it doesn't support dynamic DNS, I won't be able to use it, and will have to go back to fiddling with HSTouch.

      Edit: OK it's trying, sometimes I get the device or location screen, sometimes I get "Server Validation failed", sometimes I get "Server Access failed with broken pipe". But it's unreliable at best.

      Right now I'm at a remote computer (at work) and can access HS through the internet to check status of things, but if I didn't have a PC with an internet connection, there is no way I'd be able to tell what's going on. Unless HSDroid can provide a reliable STATUS of my home, I'll have to pass.
      Last edited by wodin; April 5th, 2012, 03:48 PM.

      Comment


      • #4
        So it works some of the time but not others? What port are you trying to use (I use 81 because there was some problem with using the default 80). If it works some of the time, but not others, then there's something squirrely with the network access. The only thing I could suggest is maybe trying some different port numbers to see if that helps.

        Dan

        Comment


        • #5
          Originally posted by wodin View Post
          If it doesn't support dynamic DNS, I won't be able to use it, and will have to go back to fiddling with HSTouch.
          I'm using HSDROID with dynamic DNS on my Samsung Galaxy Player with no problems. I use no-ip.com to define a host name (me.hopto.org) that points to the IP address of my router. In HSDROID I have the "Server IP Address" set to me.hopto.org and the "Server Port Number" is set to the HomeSeer port as defined in HS > Setup > Web Server > Server Port. I use a nonstandard port such as 9995. This configuration is 100% reliable.

          Comment


          • #6
            I just set up with no-ip.com and it works for me as well. Sounds like there's something wrong with the dynamic dns you're using.

            Dan

            Comment

            Working...
            X