Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

Current temp -1.0 with Aprilaire thermostat

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Current temp -1.0 with Aprilaire thermostat

    Dan,

    I'm running an Aprilaire 8870 thermostat and its associated HS plug-in that displays and controls all thermostat functions correctly within HomeSeer. In HSDroid, the current temperature shows "-1.0" (Brrrr!) All other fields display and update correctly including the set point temp.

    Let me know if I can provide any data or logs should you try to resolve the issue.

    Excellent plug-in!

    Thanks

  • #2
    Can you set the loggging on the plugin to verbose and then view the therm and send me the homeseer log?

    Dan

    Comment


    • #3
      Here ya go...

      Accessed the therm in the lower section, changed setpoint to 66 deg in upper section.



      12/10/2012 9:40:32 AM Web Server Web Server authorized login successful from: *.*.*.* User: steve
      12/10/2012 9:40:24 AM HSDroid Cool set = 79 Heat Set = 66
      12/10/2012 9:40:24 AM HSDroid Temp(1) = -1
      12/10/2012 9:40:24 AM HSDroid Number of Temps = 1
      12/10/2012 9:40:24 AM HSDroid Aux enabled: False
      12/10/2012 9:40:24 AM HSDroid Plugin name = Aprilaire Thermostats
      12/10/2012 9:40:24 AM HSDroid Number of Thermostats = 1, ThermNum = 1
      12/10/2012 9:40:24 AM HSDroid cmd = Number value = 1
      12/10/2012 9:40:24 AM HSDroid cmd = Plugin value = Aprilaire Thermostats
      12/10/2012 9:40:24 AM HSDroid cmd = cmd value = GetThermostatDetail
      12/10/2012 9:40:24 AM HSDroid link = /hsdroid2?cmd=GetThermostatDetail&Plugin=Aprilaire+Thermostat s&Number=1
      12/10/2012 9:40:23 AM HSDroid Therm name: Main, address = 0
      12/10/2012 9:40:23 AM HSDroid cmd = cmd value = GetThermostats
      12/10/2012 9:40:23 AM HSDroid link = /hsdroid2?cmd=GetThermostats
      12/10/2012 9:40:19 AM HSDroid Therm: Set Setpt to 66
      12/10/2012 9:40:19 AM HSDroid Therm: Set FanMode to 0
      12/10/2012 9:40:19 AM HSDroid Therm: Set Mode to 1
      12/10/2012 9:40:19 AM HSDroid cmd = SetPt value = 66
      12/10/2012 9:40:19 AM HSDroid cmd = FanMode value = 0
      12/10/2012 9:40:19 AM HSDroid cmd = Mode value = 1
      12/10/2012 9:40:19 AM HSDroid cmd = Number value = 1
      12/10/2012 9:40:19 AM HSDroid cmd = Name value = Aprilaire Thermostats
      12/10/2012 9:40:19 AM HSDroid cmd = cmd value = SetThermostat
      12/10/2012 9:40:19 AM HSDroid link = /hsdroid2?cmd=SetThermostat&Name=Aprilaire+Thermostats&Number =1&Mode=1&FanMode=0&SetPt=66
      12/10/2012 9:40:19 AM Web Server Web Server authorized login successful from: *.*.*.* User: steve
      12/10/2012 9:37:45 AM Web Server Web Server authorized login successful from: *.*.*.* User: steve
      12/10/2012 9:37:34 AM HSDroid Cool set = 79 Heat Set = 67
      12/10/2012 9:37:34 AM HSDroid Temp(1) = -1
      12/10/2012 9:37:34 AM HSDroid Number of Temps = 1
      12/10/2012 9:37:34 AM HSDroid Aux enabled: False
      12/10/2012 9:37:34 AM HSDroid Plugin name = Aprilaire Thermostats
      12/10/2012 9:37:34 AM HSDroid Number of Thermostats = 1, ThermNum = 1
      12/10/2012 9:37:34 AM HSDroid cmd = Number value = 1
      12/10/2012 9:37:34 AM HSDroid cmd = Plugin value = Aprilaire Thermostats
      12/10/2012 9:37:34 AM HSDroid cmd = cmd value = GetThermostatDetail
      12/10/2012 9:37:34 AM HSDroid link = /hsdroid2?cmd=GetThermostatDetail&Plugin=Aprilaire+Thermostat s&Number=1
      12/10/2012 9:37:33 AM HSDroid Therm name: Main, address = 0
      12/10/2012 9:37:33 AM HSDroid cmd = cmd value = GetThermostats
      12/10/2012 9:37:33 AM HSDroid link = /hsdroid2?cmd=GetThermostats
      12/10/2012 9:37:33 AM Web Server Web Server authorized login successful from: *.*.*.* User: steve

      Comment


      • #4
        Perhaps this will help. I set the Aprilaire plug-in to debug logging then accessed the thermostat in HS...


        12/10/2012 10:52:02 AM Aprilaire Thermostats DEBUG In ProcessCMD, Property= HOLD
        12/10/2012 10:52:02 AM Aprilaire Thermostats DEBUG Entering ProcessCMD, CMD=SN1 HOLD=OFF
        12/10/2012 10:52:02 AM Aprilaire Thermostats DEBUG In ProcessCMD, Property= F
        12/10/2012 10:52:02 AM Aprilaire Thermostats DEBUG Entering ProcessCMD, CMD=SN1 F=AUTO
        12/10/2012 10:52:02 AM Aprilaire Thermostats DEBUG In ProcessCMD, Property= HVAC
        12/10/2012 10:52:02 AM Aprilaire Thermostats DEBUG Entering ProcessCMD, CMD=SN1 HVAC=G-Y1-W1-Y2-W2-B+O-
        12/10/2012 10:52:02 AM Aprilaire Thermostats DEBUG In ProcessCMD, Property= M
        12/10/2012 10:52:02 AM Aprilaire Thermostats DEBUG Entering ProcessCMD, CMD=SN1 M=HEAT
        12/10/2012 10:52:02 AM Aprilaire Thermostats DEBUG In ProcessCMD, Property= SH
        12/10/2012 10:52:02 AM Aprilaire Thermostats DEBUG Entering ProcessCMD, CMD=SN1 SH=66F
        12/10/2012 10:52:02 AM Aprilaire Thermostats DEBUG In ProcessCMD, Property= SC
        12/10/2012 10:52:02 AM Aprilaire Thermostats DEBUG Entering ProcessCMD, CMD=SN1 SC=79F
        12/10/2012 10:52:02 AM Aprilaire Thermostats DEBUG In ProcessCMD, Property= T
        12/10/2012 10:52:02 AM Aprilaire Thermostats DEBUG Entering ProcessCMD, CMD=SN1 T=67F
        12/10/2012 10:52:02 AM Aprilaire Thermostats DEBUG SN1 T=67FSN1 SC=79FSN1 SH=66FSN1 M=HEATSN1 HVAC=G-Y1-W1-Y2-W2-B+O-SN1 F=AUTOSN1 HOLD=OFF
        12/10/2012 10:52:00 AM Aprilaire Thermostats DEBUG In Poll: Time: 12/10/2012 10:52:00 AM
        12/10/2012 10:52:00 AM Aprilaire Thermostats DEBUG Polling stat number: 1
        12/10/2012 10:52:00 AM Aprilaire Thermostats DEBUG Poll Thread Loop Starting: 12/10/2012 10:52:00 AM
        12/10/2012 10:51:33 AM Aprilaire Thermostats DEBUG Exiting StatObj, returning stat with name: Main
        12/10/2012 10:51:33 AM Aprilaire Thermostats DEBUG Entering StatObj: 1

        Comment


        • #5
          The Aprilaire plugin isn't returning a valid value to the GetTemp API. Is there some support for this plugin?

          Comment


          • #6
            The free plug-in was developed by HomeSeer back when the Aprilaire 8870 was just about the only choice for a communicating thermostat.

            Perhaps HST would release the source?

            Comment


            • #7
              Originally posted by Xtension View Post
              Perhaps HST would release the source?
              Put in a help desk ticket and I'll assign it to Rich to get you this information using the blue support link above.
              -Rupp
              sigpic

              Comment


              • #8
                Since I don't have the plugin, would be best for Xtension to open this ticket. The text should be that the plugin returns -1 to the GetTemp API.

                Dan

                Comment


                • #9
                  Help Desk Ticket Submitted

                  Between work and the holidays I finally got around to submitting a help desk ticket.

                  Comment

                  Working...
                  X