Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

Anyone using Message Server to "push" pages to IE?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Anyone using Message Server to "push" pages to IE?

    I'm interested to find out whether anyone is successfully using Message Server to open web pages on the client PC that are "pushed" to it from the Message Server. I'm not talking about images in a Message Server popup. Given a trigger in HS, can you have a web browser pop open an ASP page (URL) on the Client?

    I was not successful in getting this to work before my trial ran out, and that's the basic reason I would purchase a license.

    Thanks.
    |
    | - Gordon

    "I'm a Man, but I can change, if I have to, I guess." - Man's Prayer, Possum Lodge, The Red Green Show
    http://HiddenGemTech.com - http://MaineMusiciansExchange.org - http://www.WJZF.org


  • #2
    Gordon,

    You can use the message function in the event or by script, if the message is a link the page will be display:
    hs.Plugin("Message Server").MessageToClient "http://homeseer_server:theport/stat",,,1

    Or this function will use the default internet browser.
    hs.Plugin("Message Server").MessageLink "http://homeseer_server:theport/stat", "client"

    Regards,
    Christian

    Comment


    • #3
      Thanks, Christian, I sprang for the license, got the latest version of the plugin, and it is working as advertised. Thank you very much!
      |
      | - Gordon

      "I'm a Man, but I can change, if I have to, I guess." - Man's Prayer, Possum Lodge, The Red Green Show
      http://HiddenGemTech.com - http://MaineMusiciansExchange.org - http://www.WJZF.org

      Comment


      • #4
        Hrmmm.. I used the example given, replacing the "web page" witht he page I want to open and the client was set to a client I know is online and I could NOT get it to open the page ... any suggestions?

        Edited to further explain: I want to force the client to open a web page of my self-updating web cam - but looking at your examples I tried several permutations of this and could not get it to work at all - not even attempt to open a web page on the remote client.

        Comment


        • #5
          Don't know - it's working here under HS 1.7.0 and the plugin version 1.4.6. You on the same versions?
          |
          | - Gordon

          "I'm a Man, but I can change, if I have to, I guess." - Man's Prayer, Possum Lodge, The Red Green Show
          http://HiddenGemTech.com - http://MaineMusiciansExchange.org - http://www.WJZF.org

          Comment


          • #6
            Dirk,

            Are you using the MessageToClient or the MessageLink function?
            Are you getting the 404 internet error page cannot be found or nothing popup?

            Thanks,
            Christian

            Comment


            • #7
              Christian,

              I used both examples that you gave to Gordon - and neither one worked. No pop-ups, no errors - nothing. I created them as a manual script function in HS and then executed it from the web page control. My MS_Client server and client are the latest builds.

              Dunno?
              <System Halted - Operator Stupid>

              Comment


              • #8
                Christian,

                I used both examples that you gave to Gordon - and neither one worked. No pop-ups, no errors - nothing. I created them as a manual script function in HS and then executed it from the web page control. My MS_Client server and client are the latest builds.

                Dunno?
                <System Halted - Operator Stupid>


                P.S. Dang this Avatar system - why isn't my avatar showing up anymore? If I put the URL into a separate IE window address bar it works fine! <grumble - grumble!>

                Comment


                • #9
                  Re: avatar probs - it's because there is some sort of redirect... the board won't follow it.
                  |
                  | - Gordon

                  "I'm a Man, but I can change, if I have to, I guess." - Man's Prayer, Possum Lodge, The Red Green Show
                  http://HiddenGemTech.com - http://MaineMusiciansExchange.org - http://www.WJZF.org

                  Comment


                  • #10
                    Dirk,

                    Can you get any messages to this client?
                    What security type are you using in Message Server?

                    I suspect you are not getting the message because the functions work as suppose with all the tests I made.

                    For quick test you can send the command from the custom command (F6) in MS_Client.
                    Try sending this:
                    hs.Plugin("Message Server").MessageToClient "this is a test",,,1

                    And if you don’t have the message popup looks at the client log to see if you get the message. If it woks that one should work too:
                    hs.Plugin("Message Server").MessageToClient "http://www.homeseer.com",,,1

                    Regards,
                    Christian

                    Comment


                    • #11
                      Christian,

                      It was ME... DOH! I was forgetting to include the '&' before the command. Amazing if you don't do something for a while you forget things. It's now opening up a web window with my web cameras every time a motion event occurs. Thanks so much for helping diagnose this.

                      And Gordon - Thanks for the help with the Avatar - it won't let me change it no matter what I do... unggg.

                      -Dirk

                      Comment


                      • #12
                        I would like to do this too but am alittle lost here. Where do you put these scripts you guys are talking about? Went to the webgui and sent a message with this script in it and nothing, made an event and put the script line above in the scripts place for the event, and nothing either. Could I get alittle more detailed instruction please?
                        TIA
                        Tim
                        FB Page - https://www.facebook.com/pages/Capt-Tim/209398425902188

                        HSTouch Layouts - https://www.facebook.com/media/set/?...5902188&type=3

                        No, Im from Iowa. I only work in outer space. Captain Kirk

                        Comment


                        • #13
                          Tim,

                          To have a web page push to a client you just have to put a link (http://anything) in the message instead of text.

                          Thanks,
                          Christian

                          Comment

                          Working...
                          X