Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

MS client at my office

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MS client at my office

    I have a MS_Client (2.4.186) set up at my office and it connects to hspi_Message_Server (1.4.182)at home evervthing works great.

    Execpt I setup a script I found on this bd (custom_cnn_notify_message_server) it sends Alert popup to clients of CNN Breaking news. It works fine on all clients located at home on the local lan but not at office. At the office a alert window pops up but its a 404 internet page. The script sends a URL to a asp page located in the HS html/CNNAlert folder.

    Here is the address its pointing to : http://reliant:81/CNNAlert/MS_CNNAlert.asp

    should this work out side the local LAN? I have thought of changing the computer name to the IP address but not sure if this will fix it because its an internal address on the local LAN.

    what ever it is it needs to work for local & internet clients.

    Any Ideas?
    HS2 Environment
    Zotac 1.83 GHz Quadcore
    HomeSeer Way2Call
    Netiom-Xap board
    opnode 1-wire 1.2.7
    Plug-In's
    WeatherXML 1.0.0.32
    Pwr Link USB 1.0.0.13
    mcsTemp V6.2.0.14
    mcsXap V3.0.0.0/3.0.0.20
    IM Connector 4.87.2.5
    Sip Connector 2.56.2.4
    RFXCOM 15.0.0.22
    Odroid X2
    Asterisk 11.5.1
    FreePBX 2.11.0.42
    WebMin 1.720
    Xap Switchboard by Mi4

    There is no place Like 127.0.0.1

  • #2
    There is a variable built into Message Server to handle this.

    Use this:

    a href=http://%HS_SERVER%:81/CNNAlert/MS_CNNAlert.asp
    --
    Jeff Farmer
    HS 3, HSPhone
    My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
    Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

    Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

    Comment


    • #3
      Originally posted by HomeTech

      Here is the address its pointing to : http://reliant:81/CNNAlert/MS_CNNAlert.asp
      Hey, 'reliant' can't be seen from the internet.

      Use your cable modem/DSL 'internet' IP address (http://xxx.xxx.xxx.xxx:81/CNNAlert/MS_CNNAlert.asp) , make sure you forward port 81 on your router to the LAN IP address of 'reliant'.

      Do I detect a Star Trek 2 - Wrath of Khan geek?


      ~Bill

      Comment


      • #4
        Originally posted by HomeTech
        Win2K 2800mhz/1.5m memory
        You're other problem is 1.5 Meg of memory just won't cut it, ya cheapskate.


        ~Bill

        Comment


        • #5
          Yep star trek nut, thanks for pointing out my memory (M) should be G for Gig.
          Port forward all ready set up Office client works great just not the CNN Breaking News Pop up

          Back to my problem. I put in the local address like this:

          MS_AlertPageURL=http://192.168.0.7:81/CNNAlert/MS_CNNAlert.asp

          This works localy but did not get to try it at the office today because my Verizon DSL went down at home . Perfect timing.

          I will see if it works tomorrow. If it does not I will put the public address of my home DSL in to the address and see if that does it. But I think then the local clients will then have a problems.

          I have included the script I am using. This works along with the custom_cnn.txt script
          Attached Files
          HS2 Environment
          Zotac 1.83 GHz Quadcore
          HomeSeer Way2Call
          Netiom-Xap board
          opnode 1-wire 1.2.7
          Plug-In's
          WeatherXML 1.0.0.32
          Pwr Link USB 1.0.0.13
          mcsTemp V6.2.0.14
          mcsXap V3.0.0.0/3.0.0.20
          IM Connector 4.87.2.5
          Sip Connector 2.56.2.4
          RFXCOM 15.0.0.22
          Odroid X2
          Asterisk 11.5.1
          FreePBX 2.11.0.42
          WebMin 1.720
          Xap Switchboard by Mi4

          There is no place Like 127.0.0.1

          Comment


          • #6
            Jeff had the good answer.
            So this line to have the script working for local & internet clients.

            MS_AlertPageURL=http://%HS_SERVER%:81/CNNAlert/MS_CNNAlert.asp

            Regards,
            Christian

            Comment


            • #7
              I Just tried that localy and it worked! I will see if it works at the office tomorrow. bet it does.

              For some reason when I tried this before I replaced this %HS_SERVER% with the HomeSeer's ip address Dum me.... should have left it as is.

              Thanks
              HS2 Environment
              Zotac 1.83 GHz Quadcore
              HomeSeer Way2Call
              Netiom-Xap board
              opnode 1-wire 1.2.7
              Plug-In's
              WeatherXML 1.0.0.32
              Pwr Link USB 1.0.0.13
              mcsTemp V6.2.0.14
              mcsXap V3.0.0.0/3.0.0.20
              IM Connector 4.87.2.5
              Sip Connector 2.56.2.4
              RFXCOM 15.0.0.22
              Odroid X2
              Asterisk 11.5.1
              FreePBX 2.11.0.42
              WebMin 1.720
              Xap Switchboard by Mi4

              There is no place Like 127.0.0.1

              Comment


              • #8
                MS_AlertPageURL=http://%HS_SERVER%:81/CNNAlert/MS_CNNAlert.asp

                This worked from the office but before it displays the asp page in the window it pops up a window asking for a user name and password if I put guest guest in it displays the page. Is there a way not to require a user name and password?
                HS2 Environment
                Zotac 1.83 GHz Quadcore
                HomeSeer Way2Call
                Netiom-Xap board
                opnode 1-wire 1.2.7
                Plug-In's
                WeatherXML 1.0.0.32
                Pwr Link USB 1.0.0.13
                mcsTemp V6.2.0.14
                mcsXap V3.0.0.0/3.0.0.20
                IM Connector 4.87.2.5
                Sip Connector 2.56.2.4
                RFXCOM 15.0.0.22
                Odroid X2
                Asterisk 11.5.1
                FreePBX 2.11.0.42
                WebMin 1.720
                Xap Switchboard by Mi4

                There is no place Like 127.0.0.1

                Comment


                • #9

                  Comment


                  • #10
                    Yep that's what I did Added the subnet to HS.
                    Works Great

                    Thanks
                    HS2 Environment
                    Zotac 1.83 GHz Quadcore
                    HomeSeer Way2Call
                    Netiom-Xap board
                    opnode 1-wire 1.2.7
                    Plug-In's
                    WeatherXML 1.0.0.32
                    Pwr Link USB 1.0.0.13
                    mcsTemp V6.2.0.14
                    mcsXap V3.0.0.0/3.0.0.20
                    IM Connector 4.87.2.5
                    Sip Connector 2.56.2.4
                    RFXCOM 15.0.0.22
                    Odroid X2
                    Asterisk 11.5.1
                    FreePBX 2.11.0.42
                    WebMin 1.720
                    Xap Switchboard by Mi4

                    There is no place Like 127.0.0.1

                    Comment

                    Working...
                    X