Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

Message Server BETA 3.0.1.31 is available in the HS updater

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Message Server BETA 3.0.1.31 is available in the HS updater

    Fixed an issue with W2K that could not connect and the server will be bind to the same IP address as HS Web Server.

    You will need to update the clients manually because I changed the order of the connection event to have the update in first place.

    Regards,
    Christian

  • #2
    I just reinstalled all my HS stuff on a new hard drive and in the process noticed that the .net version is out there . Gotta pay more attention to the boards I guess.

    First, apologies if my answers are already out there. I searched the forums and looked for a readme or something first, and while they might be there I drew a blank.

    I got the server installed OK, but am having trouble with the client (only one machine with a client right now). That box (laptop, actually) is still running Win 98SE. I installed .net 2.0 on the laptop and rebooted. I disabled the old VB6 client. When I unzip the new client (from the link in config for the server) there are three files. I have the .dll in the Windows folder, and the .exe and the .pdb in my existing MS Client folder (I've also tried a copy of the .dll here). I can start the client, but I get an error message right away. It is a Windows dialog box that states:

    Unhandled Exception in your application........

    Feature requires Windows NT

    I can select to continue and the client loads. I can open the window, but when I click on settings I get a similar error. I can tap continue and the client will close.

    From the error.html:

    4/30/08 1:32:04 PM - Client verison: 3.0.1.34
    Function: Loading SettingsCould not load file or assembly 'Interop, Version=2.0.0.0, Culture=neutral, PublicKeyToken=ece3dfc96e5d6d09' or one of its dependencies. The system cannot find the file specified.


    What am I missing?

    Comment


    • #3
      Originally posted by Msekelsky View Post
      What am I missing?
      Feature requires Windows NT

      The Interop file is for MSAgent, TTS and others thing I will see if I can remove some.

      Thanks,
      Christian

      Comment


      • #4
        Originally posted by cyvinec View Post
        Feature requires Windows NT

        The Interop file is for MSAgent, TTS and others thing I will see if I can remove some.

        Thanks,
        Christian
        Are you saying that the client will not run in Win 98?

        Comment


        • #5
          Mark,

          The error message said so and I have no idea what is causing this I will need to investigate.

          Tomorrow I will make a change that will only have the TTS and MSAgent in the Interop file.

          If that does work Win98 will not work until I have time to install it and debug.

          Regards,
          Christian

          Comment


          • #6
            OK, thanks. I will revert back to the old MS for now. Let me know if you need me to test anything with W98.

            Comment


            • #7
              Mark,

              I uploaded version 3.0.1.36 to the updater which should fixe some Win98 issues.
              You will probably found other bug like no TTS, script dialog look strange no form transparency.

              I will only try to fixe the issue with the device or event image give a file not found error but show correctly.

              Regards,
              Christian
              Last edited by cyvinec; May 1st, 2008, 09:15 PM.

              Comment


              • #8
                Wow, that was fast! Installation went well and the W98 laptop is now communicating with HS. I did not see any options to auto start w/Windows, so I assume need a shortcut in the startup folder. Also did not see anything to save my password?

                Comment


                • #9
                  Ya, right mouse click on the client program and select "Create Shortcut". Then put that into the Startup folder.

                  Look again on that sign in box hen the client starts, on mine there is a check mark at the bottom to remember the password.


                  ~Bill

                  Comment


                  • #10
                    I cannot find a checkbox anywhere to save the password. Maybe something to do with W98? I checked the ini file and see no password reference there either.

                    Comment


                    • #11
                      I installed the client to a PC running Vista and still no checkbox, but this time I can at least post a screen shot.

                      I have an event that sends a command to the laptop (which powers a touchscreen) to turn the monitor off when certain conditions are met. With the previous version (non. NET) the command would go to all clients. I find that to be the same with this version as well.
                      Attached Files

                      Comment


                      • #12

                        Comment


                        • #13
                          That did it, thanks!

                          Comment


                          • #14
                            Small spelling error

                            I installed the latest 3.0.1.36 and when it put the message in the Homeseer log about the client needing to be updated, the word 'update' is spelled wrong.
                            ~!~Message Server ~!~Client from : 192.168.11.4 need to uptade.
                            Dick
                            HS PRO 2.5.0.81, WinXP, IE8, Shuttle XS35V3, 2.13GHz, 4GB, 40GB SSD drive, AC-RF2, ADIOcelot, Message Server, TI103, SNEVL CID, pjcOutlook, MCSTemperature, Powertrigger, BLBackup, BLFloorplan, BLIcon, BLOccupied, BLRadar, BLRfid, BLLogMonitor, ACPUPSD, UltraECM, WeatherXML & Stipus' script connector. 500+ devices, 260+ events, 1-wire weather station + temp/humidity sensors & Oregon Scientific temp & humidity sensors & 2 Brultech ECM-1240s

                            Comment


                            • #15
                              Thanks Dick,

                              It's fixed.

                              Regards,
                              Christian

                              Comment

                              Working...
                              X