Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

It's time to figure out my TXB16 thermostat

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • It's time to figure out my TXB16 thermostat

    I have been trying to get my RCS TXB16 thermostat up and running again. It worked for several years under HS 1.6. For reasons I won't explain due to space, I only a few months ago upgraded to 2.x. (I'm currently running 2.3.0.19, but it has happened in other builds the same way, I just haven't attempted to tackle the problem until now.) I can't get HS to communicate at all with the thermostat. I have tried the HS plugin, DooStat, sending direct commands, setting up devices for individual codes, different house codes... nothing works.

    The thermostat functions manually fine, and I can get it to accept x-10 signals sent from wired and wireless controllers. For example, using an x-10 mini controller, decode table P and house code P, sending "P1 on" results in the thermostat changing the set point to 65, just as it should. However, sending that same command from within HS does absolutely nothing. HS logs the command (e.g., "Command sent to X-10 address P1: P1 On Dimval: 0 Data: 0"), but the thermostat doesn't receive it.

    To repeat myself, the thermostat does recieve commands from x-10 controllers and responds normally. However, it does not recieve or respond to any commands sent from within HS.

    Any advice would be appreciated.

  • #2
    What X10 PLC are you using? It sounds like a case of either a weak X10 signal from HomeSeer to the stat.
    -Rupp
    sigpic

    Comment


    • #3
      Thanks for the prompt reply. I should have mentioned that I have tried three different power line interfaces (a Smarthome USB, an X-10 brand USB, and what's currently running is a plain old X-10 serial), all with the same negative results. All other units (wall switches, lamp modules) receive the signals throughout the house.

      Comment


      • #4
        Have you tried the extension code test? Plug an extension cord into the same outlet as your stats X10 interface (can't remember the name if the small white plugin module). Then run the cord to your server and plugin your CM11A into the extension cord and see if you can communicate.
        -Rupp
        sigpic

        Comment


        • #5
          Have you reset the stat - they can get confused!

          From my Note book on how to reset them..........

          How to reset a TX16B stat to factory defaults.

          reset the stat to defaults by issuing P4-ON,L3-OFF,H2-ON,D1-OFF.

          must visit each stat and press the mode button
          simultaneously press the fan button (su on indicator)

          ad = adress A=1 B=2 etc....

          Press the down button the cycles through ad = address
          fc = Fahrenheit/Celcius
          c1 = calibrate internal sensor

          No button for 3 seconds exits setup mode.
          HS3 Pro Edition 3.0.0.435 (Windows 10 vmware)
          BLOccupied:,UltraNetCam3:,weatherXML:,RFXCOM:,Current Cost 3P:,UltraGCIR3:
          DMMQTT:,Kodi:,Z-Wave:,BLRadar:,EasyTrigger:,MySensors:,BLBackup:

          Comment


          • #6
            Thank you both for your help. The extention cord test showed that I can control the thermostat from HS--apparently it was--is--a signal strength issue. I'll look up stuff on how to deal with low signal issues and see what (hopefully low cost) options I have. (I already have a circuit leg bridge (I forgot the formal name) installed.) Maybe I'll also have to search for suggestions on how to increase the WAF related to extention cords transversing the house.

            Incidentally, I had trouble getting DooStat to work until I tried the reset dmurphy suggested. I had done that before, but if there was no signal getting to the 'stat, then that explains why it didn't help.

            Thanks again.
            Last edited by Rooster; August 29th, 2009, 09:30 PM.

            Comment

            Working...
            X