Announcement

Collapse
No announcement yet.

HACS AB8SS Speaker Switcher Plug-In

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #61
    <David>Would like to test beta. Basically currently only using the AB8SS to switch from Alarm voice (alarm panel) input to Homeseer input and vice versa. Not using it for individual speakers yet.
    - Pete

    Auto mator
    Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb
    Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro
    HS4 Lite - Ubuntu 20.04 / VB W7e Jetway JBC420U591
    Fanless IntelĀ® Celeron N3160 SoC 8Gb
    HS4 Pro - V4.1.18.1 - Ubuntu 20.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb
    HSTouch on Intel tabletop tablets

    X10, UPB, Zigbee, ZWave and Wifi MQTT automation-Tasmota-Espurna. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

    Comment


      #62
      Pete,

      Thanks for your willingness to try out the beta. I've just sent a copy to you. Please let me know how it works out.

      Best wishes,

      --David

      Comment


        #63
        Thanks to Pierre's willingness to run with a couple of betas and send me the logs, I was able to track down and repair the problem with the Input A/B text change. Thanks again, Pierre!

        That leaves the non-response issue. What is the longest anyone has run before the switcher has stopped responding? Bill D? I've had the last version of the plug-in running for 47 hours without incident.

        --David

        Comment


          #64
          David,

          I don't have it hooked up right now but I am willing to hook it back up and start testing again. Last time I tried, it would last anywhere from an hour to a couple of days before locking up. If you can email me the latest version I will set it up tomorrow evening and do some testing. I really do want this to work!

          Thanks for the effort you are putting into getting these problems solved.

          Bill

          Comment


            #65
            David,

            I've had mine running now since Monday afternoon - verified that it was still switching OK this morning. This one is controlling my outdoor speakers, so with the weather we've had this week, I haven't been using them much this week
            However, it's pretty nice out today, so I will be using them this afternoon...

            Jim

            Comment


              #66
              Jim,

              Did Pierre or Bill, or Jeff send you the new plug-in? If you're running the one from the Updater, it's not the latest beta. Would you like me to send you the beta? If so, please E-mail me at david at retroscape dot com.

              Mine's been running for 4 days, now, without incident. Unfortunately, I'm going to need to restart HS for some other code changes, so I'll have to start all over for my "torture test". I think I'll try to get the beta into the Updater this weekend, if I don't hear of any error reports.

              Then, I need to integrate some neat functionality Jeff Farmer just sent me last night. You'll like it. Love to put in a teaser like that.

              --David

              Comment


                #67
                David,

                I just got mine hooked back up this morning. Everything seems to be working fine. I did notice an error occur on a poll, the AB8SS didn't respond according to the debug. I then changed the status of one of the speaker devices, the plug-in complained about an invalid response from the AB8SS, and then it recovered, switched the speakers and continued normally. It looks like you've solved the lockup problem, and it looks like what was causing it, at least for me, was the AB8SS not responding to a status request. I'll let you know if I see anything else.

                Thanks,
                Bill

                Comment

                Working...
                X