Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

Out of Area Calls

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Out of Area Calls

    I finally got WAF NetCallerID installed and it's working pretty well. The one reoccuring issue I'm having is that Out of Area calls are coming into the WAF-NetCallerID-phone-list.txt file as as "O 2000 Out of Area". I keep on modifying the entry to say, "O 3010 Out of Area" so it won't speak it. I've also modifed the main script to bypass sending email notifications of any 3000 or above entries.

    The problem is that every time these out of area calls come in they recreate themselves in the text file as "O 2000 Out of Area" and ignore my modifed entries of "O 3010 Out of Area". So in essence it speaks them, and sends the emai notification. This is the only one doing it. All other number mods are working for family, friends, etc.

    Does anyone know why this is occuring, or know of a workaround?

    Thanks!

  • #2
    kwolter,

    The match finding routine looks at each line in your phone list, and separates the component parts (phone number, phone group code and name) by the tab character. All I can imagine is that the line with "O 3010 Out of Area" might not have tabs between the component parts, so the match-finding routine can't split it up properly. Would you mind double-checking?

    Best wishes,

    --David

    Comment


    • #3
      Actually they do have the tabs when I edit the entry. I just didn't post it properly here. The strange thing is though the original capture of "O 2000 Out of Area" does not tab correctly.

      It ends up looking like this...

      Edited entry from previous out of area call:
      O 3010 Out of Area

      Newest out of area call:
      O 2000 Out of Area


      Not really sure what's going on. ?

      Comment


      • #4
        kwolter,

        Sorry for the delay, I've been off the board for a few days. Does your entry have a single tab between each of the values, or is there a chance that extra tabs were added to make things align well visually? There should only be a single tab. I don't have any other ideas at the moment. This is odd.

        Best wishes,

        --David

        Comment


        • #5
          It was a tab problem after all. Works great now. Thanks!

          Comment


          • #6
            GREAT!!!

            --David

            Comment

            Working...
            X