Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

WAF Net Caller ID Not Working On HS 2.0

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • WAF Net Caller ID Not Working On HS 2.0

    I installed the WAF Net Caller ID From the updater today.

    For the life of me I can not get it to work at all with HomeSeer 2.0 Build 1972

    All the files installed correctly in the subdirectories of:

    C:\Program Files\HomeSeer 2\

    In the WAF-NetCallerID.ini I have the following:

    [Settings]
    InstallDone=True
    i_com_port=10
    i_com_port_resource=8
    i_hsp_installed=1
    i_call_external_script=0
    s_script_name=
    s_function_name=
    s_phone_list_file=WAF-NetCallerID-Phone-List.txt
    i_cid_reversed=1
    i_cid_comma_delimiter=0
    i_enable_logging=1

    I have used HyperTerm to connect to Comm #10 when HS is unloaded and verified that I see incoming data when I call the phone number.

    The Statup shows:

    9/23/2005 9:38:40 PM ~!~Startup~!~Running startup script
    9/23/2005 9:38:40 PM ~!~Startup~!~Scripting is OK
    9/23/2005 9:38:40 PM ~!~WAF-NetCallerID~!~Script version: 1.1.6 Port opened On COM 10
    9/23/2005 9:38:40 PM ~!~Info~!~Done with scripting
    9/23/2005 9:38:40 PM ~!~Startup~!~Start up complete.


    What am I missing?
    ---------------------------------------------------
    Jean-Marie G. Vaneskahian
    jean@vaneskahian.com
    ---------------------------------------------------

  • #2
    i_com_port=10
    i_com_port_resource=8

    Both those numbers need to match your port number you are using.


    ~Bill

    Comment


    • #3
      This is from the Documentation:

      INI FILE PARAMETERSDefaults to 8 for all COM ports greater than 8.)

      i_hsp_installed (1=True, 0=False) Indicates whether HomeSeer Phone is installed.

      i_hs_announces_caller (1=True, 0=False) Indicates whether HomeSeer will announce caller's name. Should be 0 if user is planning to have a custom script process the CID.

      s_cid_prefix Holds the words spoken before the telco-provided CID name, if HomeSeer (as opposed to HomeSeer Phone) is used to announce the caller's name.

      i_cid_reversed (1=True, 0=False) Indicates that CID information is presented last name first.

      i_cid_comma_delimiter (1=True, 0=False) Indicates that there is a comma separating the first/last names in CID data.

      i_call_external_script (1=True, 0=False) Indicates that CID information should be passed to an external script.

      s_script_name The name of the external script that will be called after CID data is received. A sample script WAF-NetCallerID-Sample-CID-Processing.vbs is provided.

      s_function_name The name of the function within the script that will be called with the CID data. A sample function process_ncid_data is provided in the sample script.

      s_phone_list_file Contains the name of the text file of telephone numbers, codes and custom announcement text.

      i_enable_logging (1=True, 0=False) Indicates whether or not the script will write CID data to the HomeSeer log.
      InstallDone (True, False) Indicates that hs_install was executed successfully or this file was modified to contain the values appropriate for the installation.
      I will try making it 10 anyhow thanks.
      ---------------------------------------------------
      Jean-Marie G. Vaneskahian
      jean@vaneskahian.com
      ---------------------------------------------------

      Comment


      • #4
        Here is what I get when I try setting the resource to 10 like you mentioned:

        9/24/2005 10:01:08 AM ~!~Startup~!~Running startup script
        9/24/2005 10:01:08 AM ~!~Startup~!~Scripting is OK
        9/24/2005 10:01:09 AM ~!~WAF-NetCallerID~!~Error 3: COM port will not be opened as the COM port resource specified was out of range (1 - 8): 10
        9/24/2005 10:01:09 AM ~!~WAF-NetCallerID~!~A revised value of '8' has been saved In your WAF-NetCallerID.INI file for the setting 'i_com_port_resource'. Please verify this value before attempting to restart HomeSeer.
        9/24/2005 10:01:09 AM ~!~Info~!~Done with scripting
        9/24/2005 10:01:09 AM ~!~Startup~!~Start up complete.
        ---------------------------------------------------
        Jean-Marie G. Vaneskahian
        jean@vaneskahian.com
        ---------------------------------------------------

        Comment


        • #5
          You may need to swap to a lower com port then.


          So either swap com ports with another device -or-
          You may need to reprogram that com port to a lower numer if say maybe 3, 4, 5, 6, 7, 8 have never been assigned.


          ~Bill

          Comment


          • #6
            I don't fully understand why David has the two separate entries or how they would be used if those numbers would be different. All I know is I had to match them to make mine work a long time ago and I have been running two lines flawlessly since.


            ~Bill

            Comment


            • #7
              Well that sucks! I guess I need to move some device from Comm Port 1-9 (I am actually using them). Why would he document the use of a port number higher than 8 if his code can not really function with it.


              I know for sure that Comm Port 10 is getting data when a call comes in from looking at HyperTerm on Comm 10.

              I will move it to a lower Comm port and try it again.

              Thanks.
              ---------------------------------------------------
              Jean-Marie G. Vaneskahian
              jean@vaneskahian.com
              ---------------------------------------------------

              Comment


              • #8
                Hi, guys.

                Just as a clarification, the COM port number and the resource number actually don't need to match. The way that HST implemented COM port control through the scripting interface limited the number of COM ports available to scripts to a total of 8 (plug-ins are not affected by this limitation), each using a resource from 1 to 8. You can pick whatever unused resource you want to use with the COM port. As a default, I chose one that matched the COM number, but you can change it. HST had it default to "7" if I recall correctly.

                Jean-Marie, if you are using HSP, you'll want to get a copy of build 1973 (or later), which includes some code needed by WAF-NetCallerID to function properly.

                --David

                Comment


                • #9
                  I have not gotten to HS2.0 yet so bare with my questions. Is there a new plugin (upgrade) to run it under 2.0? If not what changes if any will have to be made to the VBS script file to run under HS2.0?

                  John
                  John

                  Comment


                  • #10
                    Hi, John.

                    No changes are needed. The script works fine under HS2. It is confusing, however, where you have to register it (under the phone setup screen).

                    --David

                    Comment


                    • #11
                      Ok where is the phone setup screen?
                      John

                      Comment


                      • #12
                        Go to Setup-->Phone-->Edit Licenses. Not intuitive, I agree.

                        Merry Christmas!

                        --David

                        Comment


                        • #13
                          Thanks... I had found it but realized that HST didn't send me the new serial number.... I got it now and will get to trying it out after Christmas is over....

                          Happy Holidays!!

                          John
                          John

                          Comment

                          Working...
                          X