Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

Net CallerID Reads but doesn't speak.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Net CallerID Reads but doesn't speak.

    Approximately 50% of the time a call comes in, my HS installation doesn't speak the caller ID info. I see the entry in the HS log from the WAF-NetCallerID listing the CID info but no speaky?
    Any ideas as to why?

    Thank you.

  • #2
    Do you have the HS speaker app running? If so are there any errors listed in the speaker app?
    -Rupp
    sigpic

    Comment


    • #3
      Originally posted by Rupp View Post
      Do you have the HS speaker app running? If so are there any errors listed in the speaker app?
      Hello Rupp, thank you for responding.
      The speaker app is running but there are no errors listed in its log. I see an entry in the HS log at 8:55 of the incoming call CID info and no corresponding entry in the speaker app log. I know the speaker app is working because at 09:00 my Big Ben chimes script ran and sounded just fine.

      Comment


      • #4
        How are you using the WAFNetCID plugin?

        Are you using the script that came with the plugin or are you just dumping the data to HSP?

        Is there nobody else on the baseship that can help you?


        ~Bill

        Comment


        • #5
          Shoot us a log snippet of when it speaks like it should and when it doesn't work please.


          ~Bill

          Comment


          • #6
            Originally posted by Bill Brower View Post
            How are you using the WAFNetCID plugin?

            Are you using the script that came with the plugin or are you just dumping the data to HSP?

            Is there nobody else on the baseship that can help you?
            Hello Bill, thanks for the response.
            I am just using the WAFNetCID straight out of the box with its included script. No HSP in use at all - yet anyway.

            Comment


            • #7
              Post your script as an attachment in this thread and I'll add some code so we can debug this.

              If you have personal phone numbers built into your script then PM me and I'll give you my email address and you can shoot it to me directly if you prefer.

              Talk to you soon, Bill


              ~Bill

              Comment


              • #8
                Originally posted by Bill Brower View Post
                Post your script as an attachment in this thread and I'll add some code so we can debug this.

                If you have personal phone numbers built into your script then PM me and I'll give you my email address and you can shoot it to me directly if you prefer.

                Talk to you soon, Bill
                Late yes I know but if you can help here is the files you requested:

                Also, the contents of my WAF-NetCallerID.ini file is:

                [Settings]
                InstallDone=True
                i_com_port=6
                i_com_port_resource=6
                i_hsp_installed=0
                i_hs_announces_caller=1
                s_cid_prefix=Attention, Call From
                i_call_external_script=0
                i_cid_reversed=1
                i_cid_comma_delimiter=0
                i_enable_logging=1
                Attached Files

                Comment


                • #9
                  That vbh file is encrypted, it is not readable except by David.

                  Originally posted by KLS View Post
                  No HSP in use at all - yet anyway.

                  OK, looks like the problem is you are:
                  A) Not using HSP.
                  B) You are not calling an external script to do the speaking. i_call_external_script=0

                  You have in your script library something called: WAF-NetCallerID-Sample-CID-Processing.vbs

                  You need one or the other.
                  Try dumping the following into your ini file and restart HS.


                  [Settings]
                  InstallDone=True
                  i_com_port=6
                  i_com_port_resource=6
                  i_hsp_installed=0
                  i_hs_announces_caller=1
                  s_cid_prefix=Attention, Call From
                  i_call_external_script=1
                  i_cid_reversed=1
                  i_cid_comma_delimiter=0
                  i_enable_logging=1
                  s_script_name=WAF-NetCallerID-Sample-CID-Processing.vbs
                  s_function_name=process_ncid_data


                  ~Bill

                  Comment


                  • #10
                    Originally posted by Bill Brower View Post
                    That vbh file is encrypted, it is not readable except by David.




                    OK, looks like the problem is you are:
                    A) Not using HSP.
                    B) You are not calling an external script to do the speaking. i_call_external_script=0

                    You have in your script library something called: WAF-NetCallerID-Sample-CID-Processing.vbs

                    You need one or the other.
                    Try dumping the following into your ini file and restart HS.


                    [Settings]
                    InstallDone=True
                    i_com_port=6
                    i_com_port_resource=6
                    i_hsp_installed=0
                    i_hs_announces_caller=1
                    s_cid_prefix=Attention, Call From
                    i_call_external_script=1
                    i_cid_reversed=1
                    i_cid_comma_delimiter=0
                    i_enable_logging=1
                    s_script_name=WAF-NetCallerID-Sample-CID-Processing.vbs
                    s_function_name=process_ncid_data
                    Hi Bill, thanks for the help. I got it to work so WAF CID is now adding to and reading from the custom call list. However, I do not see WAF CID listed in the Interfaces configuration page. I now see a 30 days trial license error in the HS log. I have the serial license code but don't know where to install it.

                    Here is my WAF CID ini file:

                    [Settings]
                    InstallDone=True
                    i_com_port=6
                    i_com_port_resource=6
                    i_hsp_installed=1
                    i_call_external_script=1
                    s_script_name=WAF-NetCallerID-Sample-CID-Processing.vbs
                    s_function_name=process_ncid_data
                    s_phone_list_file=WAF-NetCallerID-Phone-List.txt
                    i_cid_reversed=1
                    i_cid_comma_delimiter=0
                    i_enable_logging=1

                    Comment


                    • #11
                      Setup

                      Phone

                      Edit Licenses

                      Nicely Hidden, Huh?


                      ~Bill

                      Comment


                      • #12
                        Originally posted by Bill Brower View Post
                        Setup

                        Phone

                        Edit Licenses

                        Nicely Hidden, Huh?
                        Thank you I found it. Unfortunately the codes I have don't seem to work. I have a license key that is the big long alphanumeric string, a code on the order that begins with SCR-WAFCID... and none of them work. I have a password that is used to register HS and I tried all combinations of registration both manually and on-line.

                        This sucks...

                        Comment


                        • #13
                          Put in a ticket!

                          If you purchased this for 1.7 and are now using it for 2.X, put in a ticket and they will send you the new format for you WAFNetCallerID license. It will be in similar format to any other 2.X licenses you have.

                          Rob
                          .

                          Comment


                          • #14
                            Originally posted by outbackrob View Post
                            If you purchased this for 1.7 and are now using it for 2.X, put in a ticket and they will send you the new format for you WAFNetCallerID license. It will be in similar format to any other 2.X licenses you have.

                            Rob
                            Hello and thanks Rob. I did just that and HS sent me the proper license information.
                            All is nod good in the land of WAF CID!

                            Comment

                            Working...
                            X