Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

WAF-NetCallerID error "80040154"

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • WAF-NetCallerID error "80040154"

    .
    I am (was) running the really useful HS add-on "WAF-NetCallerID" version 1.1.6 by David Kindred and really appreciate it.


    I'm currently running HS2 2.2.0.66, planning to upgrade to 2.3.0.19 later this week.

    Running WAF-NetCallerID, loading it in "startup.txt" and it's been running perfectly for months (years?).

    Yesterday I ran jv16 power tools to clean up the registry, done it many times before without problems.

    However this time when I restarted HS2 I got the following error message:


    1/11/2009 1:02:58 PM ~!~Info~!~This version of HomeSeer is registered.
    1/11/2009 1:02:59 PM ~!~Error~!~Running VBScript startup.txt :Retrieving the COM class factory for component with CLSID {0E59F1D5-1FBE-11D0-8FF2-00A0D10038BC} failed due to the following error: 80040154.
    1/11/2009 1:02:59 PM ~!~Info~!~Finished initializing scripting


    HS loaded and everything worked normally except that WAF-NetCallerID no longer reports incoming phone calls.


    I went into HS's UPDATER and re-installed WAF-NetCallerID.

    After re-installing WAF-NetCallerID the HS log shows the following error messages:

    1/11/2009 12:56:39 PM ~!~Updater~!~Running script install, please wait...

    1/11/2009 12:56:39 PM ~!~Error~!~Running VBScript waf-netcallerid.vbh("hs_install","") :Retrieving the COM class factory for component with CLSID {0E59F1D5-1FBE-11D0-8FF2-00A0D10038BC} failed due to the following error: 80040154.

    1/11/2009 12:56:39 PM ~!~Updater~!~Copying file: C:\Program Files\HomeSeer 2\scripts\waf-netcallerid2.vbh
    1/11/2009 12:56:39 PM ~!~Updater~!~Running script install, please wait...

    1/11/2009 12:56:39 PM ~!~Error~!~Running VBScript waf-netcallerid2.vbh("hs_install","") :Retrieving the COM class factory for component with CLSID {0E59F1D5-1FBE-11D0-8FF2-00A0D10038BC} failed due to the following error: 80040154.

    (I left out those lines where everything was updating correctly.)



    What is the "80040154" error with the CLSID stuff?

    I think it's something about a class (?) no longer being registered in the registry but I have no idea how to re-register whatever it is or what to re-register. I would have thought that just re-installing WAF-NetCallerID from the HS Updates would have fixed it but it hasn't.

    How do I correct it?


    Thanks for any help you can give me to get WAF-NetCallerID running again?

    Great program!
    .

  • #2
    First thing I'd do is shut down all the HS software, got Windows Control Panel, Go to Add or Remove Programs, click on Homeseer, click Change and click until you can do a Repair. Then reboot your computer.

    If that isn't the fix do the same for the Microsoft .NET Frameworks and reboot.


    ~Bill

    Comment


    • #3
      Originally posted by Bill Brower View Post
      .
      First thing I'd do is shut down all the HS software, got Windows Control Panel, Go to Add or Remove Programs, click on Homeseer, click Change and click until you can do a Repair. Then reboot your computer.

      If that isn't the fix do the same for the Microsoft .NET Frameworks and reboot.
      .
      Thanks very much Bill; I followed the first instruction to the letter and HS now runs perfectly again. Didn't have to try the second step with the .NET Framework.

      Thanks again - really appreciated!
      .

      Comment

      Working...
      X