Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

xAP Plugin not updating HS Devices

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • xAP Plugin not updating HS Devices

    I have encountered an issue whereby my HS devices are not being updated by the xAP stream for some reason.
    My current configuration is several machines running xAP programs

    Computer #1
    Workstation running the following
    xAP Gui Hub (so that i can watch the stream for now)
    xAP Weather
    xAP 1 Wire to monitor my temp sensors
    xAP Watcher

    Computer #2
    HomeSeer Workstation running the following
    xAP Gui Hub (so that i can watch the stream for now)
    xAP HomeSeer Plugin

    Computer #3,4,5
    Workstation running only xAP Watcher

    HomeSeer / xAP seen the new xAP devices, and once added into HomeSeer as devices did update for a very short period of time. For some reason, it just stopped updating and has not updated any of the devices for the last 24 hours.

    The following is a list of things that I have tried / monitored so far
    - installed .net on only the HS box (and Workstation #1) via Windows Update
    - tried xAP Gui Hub, as well as xAP Service Hub on HS box
    - tried only running xAP HomeSeer Plugin in HS box and having only external xAP information coming in from other workstations.
    - checked the xAP Gui Hub on both machines and confirmed that the information is being seen in the Hub screen, so this to me confirms that the information is being sent out over the network and getting to the machines.

    Any thoughts on fixing this would be greatly appreciated as I have tried a number of things with little success. xAP seems like a great way to pull in lots of information from anywhere on my network, so I can see its great potential.

    Steven
    Brampton, Ontario, Canada

  • #2
    Did you try shutting down HS and restarting it?
    -Rupp
    sigpic

    Comment


    • #3
      Hi
      When I have been trying to resolve problems like this I have found that running xAPViewer on each machine has allowed me to find out what is not working.

      With viewer you can see each xAP message and its contents.
      http://www.xapframework.net/modules....rticle&artid=8


      As far as the xAP plugin is concerned then you should be seeing messages in the Homeseer log

      I think there is also a debug mode for the plugin, but thankfully I have never had to use it as the volume of info is likely to be high

      Rupps suggestion is also a good one
      You could also try turning off any Firewalls you have on each PC incase one of them is the cause

      Kevin

      Comment


      • #4
        Rupp,

        Thanks for the suggestion, I have unfortunately tried rebooting many times.

        Kevin,

        I will have to check out the viewer app as you suggested. The gui hub does show the information coming into the HS box but with little success. None of my machines are actually running any firewalls, as this is dealt with by my router. I had turned on the debug mode for a while and will have to go back and turn this back on to see if I can help identify the issue.

        I will update you on how my progress goes.

        Thanks

        Steven

        Comment


        • #5
          I am a little stumped now!

          I checked the viewer on both my Homeseer box and other workstation and confirmed that the xAP messages are being sent out over the network (these include weather, 1 wire, and PC Status from watcher).
          From all the reading, and someone please correct me if I am wrong, that if I am only running the xAPHomeSeer plugin on the HomeSeer box that I do not need any form of Hub. I have disabled the Hub service and rebooted HomeSeer just to be on the safe side. No other xAP applications are currently running on the HomeSeer box, yet it received the first update for some items like temp, but has not updated any devices for any other xAP messages since then.
          I fear that there is something obvious that I am missing and that the problem lies in the HomeSeer side of the equation. Either something to do with the installation method used or some other background item that is need for proper operation, but that is missing.

          Any thoughts ?

          Steven
          Brampton, Ontario, Canada
          Last edited by karls; December 27th, 2004, 11:17 PM.

          Comment


          • #6
            My understanding is that a hub is required if you want to run more than one xAP app on a box

            and that the hub of whatever type must be the first app to run

            The reasoning for this is something like:-
            xAP is transmitting and recieving on a UDP port
            Like a com port only one program can access the port until it is released
            so the hub accepts requests,etc and handles the udp port
            once the hub is stopped the port is released then another app could be started and access it

            It is not necessarily true to say that once the hub is stopped and releases the port that another (running) xap can uses it. I would have thought that the app would have to be restarted so it can do its own initialisation

            Since you have had xAP conduit working it must have offered to configure some homeseer devices under xAP conduit?

            and if you change the state of those what does the homeseer log say
            and what does viewer on each machine say?

            and similarly when you change a xAP device somewhere else
            what does the viewer say on each machine say
            (and you say that the device is configured in homeseer but does not change?)

            If you create a new xAP device somewhere else on the network does the homeseer see it and offer to create a device
            (Try my barking dog here

            http://forums.homeseer.com/showthrea...900#post619900
            )
            This long distance faultfinding is hard !

            Kevin

            Comment


            • #7
              Hi Steven,

              The fact that HomeSeer originally recognised the devices indicates that HS was (at that time) certainly hearing xAP messages OK. So three possibilities - 1) HomeSeer can't hear xAP messages anymore or 2) It is hearing them but they are not of the correct nature to update your devices or 3) Some bug somewhere we have not discovered. At this stage I don't think it's the latter as other people would likely have experienced it by now.

              Adressing 1) Yes, HomeSeer can be the only application running and in that situation it does not require a hub. However for ease of use I would always recommend that you do run a hub first as this will allow other xAP applications to be started and stopped at will. Indications of hub problems are that applications appear to be deaf. If you look at the heartbeat message sent by HomeSeer it will have a port= line in the header . If HS is indeed the only xAP application then the port number will show as 3639. If it is any other number then it is relying on a hub to be able to receive xAP. If this is the case then worth checking are the services running on the PC - those named starting xAP... perhaps you could have a xAP service application launching at startup ?

              TIP: Here's a way to quickly tell if HS is receiving xAP messages... Run xAP Viewer on any machine. Select a message ,but not a heartbeat, from a suitable xAP source ie any xAP application apart from HS itself . Double click the message to view the actual content. Now manually change the source address slightly, (edit before any : there may be in the address) , perhaps adding a character.

              eg
              source=acme.device.machine
              change to......
              source=acme.tempdevice.machine

              Now click the resend button - (curved arrow icon). HomeSeer should pop up its wizard as it recognises what it thinks is a new device . If it doesn't then certainly HS is not processing or receiving xAP messages correctly.

              Option 2) If the above TIP did result in the xAP wizard triggering in HS then is there any chance you have renamed the originating xAP applications, or changed teh machine they are running on after you first recognised them using the wizard in HomeSeer - in which case they wouldn't now be updating. If not and all seems well what I would do is try re-recognising them . Select CONFIG in the xAP Conduit menu - find your device that is not responding and click the box against it to re-recognise the device - now when that xAP device sends its information the wizard will allow you to create another device within HS. If this works then you can delete the original that is not working..

              Let me know what works and doesn't and we'll take it from there....

              Kevin

              Comment


              • #8
                Kevin (x2)

                Thank you both for your feedback.

                After an almost total meltdown of my HomeSeer PC (Thank God for Backups) and lots of spare parts. I have rebuilt and stabilized my system. It looks like the mother board was going flakey and causing weird little issues like spontaneous reboots when too much network activity was occuring.
                I could force a reboot simply by trying to copy my 80mb backup file from that machine over the network.
                The box has now been up for over 18 hours so things are definitely much improved.

                You mentioned a number of things in your message, so I will try and answer them as best as possible.
                - HomeSeer did originally recognize the xAP devices and added them as a device. - Good!
                - Now running the GUI Hub in order to see the xAP information running between machines. This is in the windows startup and is the only other xAP app on the HS box. HS is launched manually to ensure the HUB is up first. - Good!
                - The xAP devices did start to update once all was back up and operating. For some reason after about 3 hours last night it stopped updating the devices. A restart of HS seemed to have corrected it this AM. 2 hours later it again stopped listening to the messages. I have attached the 2 messages of the heartbeats below from HS.
                The GUI Hub on the HS box is seeing the incoming temp sensor updates religiously every 10 seconds. I attempted to change one to read 44 degrees instead of 21, but HS still did not respond. On the other side though, HS is pumping out the xAP information when a device changes state, etc, so the xAP pipe is not fully closed. I have activated the debug mode on the xAP HS Plugin and found that it is only sending out "timer check" and other outbound xAP messages. No response to incoming xAP messages.

                Any thoughts ?
                I hope this long winded message makes sense.

                Steven


                xap-hbeat
                {
                v=12
                hop=1
                uid=FF101200
                class=xap-hbeat.alive
                source=KCSoft.Hub.homeseer
                interval=60
                port=3639
                pid=1132
                }

                xap-hbeat
                {
                v=12
                hop=1
                uid=FF411100
                class=xap-hbeat.alive
                source=mi4.homeseer.homeseer.Master
                interval=60
                port=49153
                }

                12/30/2004 11:12:21 AM~!~xAP Conduit~!~Device string change - Computer Uptime: 0 days, 18 hrs, 17 mins, 02 secs-Computer Uptime: 0 days, 18 hrs, 13 mins, 02 secs
                12/30/2004 11:12:21 AM~!~xAP Conduit~!~Timer Trigger event on device change 12138 ComputerUptime.dvevt
                12/30/2004 11:12:21 AM~!~xAP Conduit~!~Running Sequence Device\12138 ComputerUptime.dvevt
                12/30/2004 11:12:21 AM~!~xAP Conduit~!~Finished Sequence Device\12138 ComputerUptime.dvevt
                12/30/2004 11:12:51 AM~!~xAP Conduit~!~Timer check

                Comment


                • #9
                  The hub is not forwarding messages so debug should be focused on the hub. Try a different hub. There is one at P. Lidstone's site and I have one you can work with.

                  Comment


                  • #10
                    Patricks site is not up

                    There are 3 Hubs to choose from here
                    http://www.xapframework.net/modules....download&cid=5

                    I use the service hub, no problems (so far )

                    Kevin

                    Comment


                    • #11
                      Patrick's hub for windows is also available here:

                      http://www.mi4.biz/modules.php?name=...download&cid=5

                      (you will need both the hub and the cgywin installers)

                      When the HomeSeer plugin is in debug mode and it has incoming xAP messages you will see lots and lots of messages, it won't be subtle! The .net apps can be a little sensitive to multiple network cards, does you pc have more than one?

                      James

                      Comment


                      • #12
                        Hi Steven,

                        This looks like its going to be awkard to track down - very easy to blame it on a flaky machine but lets try something..

                        Can you run just as you are (with any hub), get HS working OK. Then also launch xAP Viewer which will connect as a hub client to the hub. Then wait and when HS goes 'deaf' can you see if Viewer does too. This would then focus us on a hub problem or machine problem rather than Homeseer.

                        BTW What versions of HS and xAP Plugin are u running ?

                        Kevin

                        PS I have had HS running for days, maybe even weeks and don't see this

                        Comment


                        • #13
                          Thanks guys for all your support.

                          I have tried the "service" hub as suggested and found that HS is falling asleep as well. When I was running the GUI hub, I could still see my 1 wire temp sensor updates coming into the hub, HS was just not getting the information. So either the hub is not retransmitting them within the machine or the HSplugin is not listening. I was however seeing HS information on my other PC, as it was sending out xap messages for x10 device changes.
                          I will have to run viewer as suggested

                          info as requested.
                          I have only 1 NIC in the machine so no problems there.
                          I am running HS on a P3-800mhz (512M ram) machine, with HS version 1.7 running on a W2K Pro OS with SP4 and hotfixes.
                          The HSxapplugin is (i believe) version 0.8.128 - beta test 2. If I am wrong I will update it when I get back home.

                          Steven

                          Comment


                          • #14
                            On the same PC run the hub, viewer, and Homeseer. (PC 1)
                            On another PC run the hub and/or viewer (PC 2)
                            On either PC run the 1-wire app (PC 1 or 2)

                            If the viewer on PC1 sees the 1-wire messages then the problem is with Homeseer Conduit.

                            If the viewer on PC1 does not see the 1-wire messages then the problem is with the hub. The xapFramework service, console, and GUI hubs are all the same. If you have a hub problem then you need to use something else other than these.

                            If the viewer on PC2 does not see the 1-wire messages, but they are visible on PC1's viewer then the problem is with the network, firewall, etc.

                            Comment


                            • #15
                              Michael,

                              As suggested, I ran the test configuration as outlined, running the 1 wire app on PC-2.
                              Unfortunately, I can see (via the viewer) on PC1, the 1-wire messages, so it would appear then the problem is with Homeseer Conduit.
                              Once I get back from travelling, I plan on upgrading this PC to a new unit as it is currently only running on an 800Mhz motherboard.

                              If you (or anyone else) have any other thoughts in the meantime, I would be interested in trying them.

                              Steve

                              Comment

                              Working...
                              X