Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

Problem with xAP and HS2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with xAP and HS2

    Hi There,

    I am very new to xAP but seem to be making headway, except for a small problem I am having.

    Background: I am using HS2 (Homeseer 2) with the xAP v2.0.0.182 plugin. I have a xAP program running with my Quasar 3145 temperature sensor which is sending out data without problem.

    Problem: If I restart HS2 my xAP devices seem to loose their configuration. For example, xAP detected the new xAP devices in Homeseer and I added them using the "New Hardware" tab. Once the device was added I renamed it to something more friendly in Homeseer (The device code stays the same e.g "\1"). It then seems to run fine until I restart Homeseer (which with version 2 is alot !). Once HS2 is restarted the previous devices seem idle and I get a new "New Hardware" from the xAP plugin.

    Another question.. Is there a way to change the Device Type from "telemetry" to something I can define ? I want to change it to something like "Temperature Sensor". Can I just hack it in the .mdb ?

    Any ideas ? any help is appreciated, and please remember.. I've only been using xAP for 5 hours now

    Cheers

    Marc

  • #2
    I'm now not getting any input to the xAP plugin. I had this in the log

    02/09/2005 11:34:30 ~!~Warning~!~In event #64 callback for plug-in xAP Conduit, object removed, error: The callee (server [not server application]) is not available and disappeared; all connections are invalid. The call may have executed. Source: mscorlib

    Since that I've not seen anything in Homeseer. If I check the xAP stat it shows no messages received. I've tried a restart without success. I know my xAP app is still sending data because my xAP viewer is showing the data still flowing.

    Comment


    • #3
      I have been having simular problems with the xAP conduit as well. Same as you, when I add a new xap device ,change it's name to a friendly and restart HS I lose the devices' input. I run some variables and events based on alot of my xAP devices and have found too that after adding variables that HS2 will not shut down.

      James is aware of the bugs and I believe he is working at it. I do know that the HS1 version of his plugin did in fact work with HS2 but gave alot of errors in the HS2 log.
      Hopefully James will be able to isolate the problems with it. You may want to try and contact him in the yahoo xAP group about it. I'm not too sure how much he gets on the HS bb.

      Comment


      • #4
        Funny enough, I've noticed that it's stopped working even though I haven't restarted... I know the xAP data is still flowing on the network as I can see it using the xAP viewer.. it just doesn't seem to be reaching the Homeseer xAP plugin.

        I've unloaded Homeseer, Unloaded the xAP hub and unloaded the xAP temperature logger, then restarted the hub, then the temperature program and then loaded Homeseer and now it's not working at all !

        Gah !

        Comment


        • #5
          Trying to resolve this in duplicate thread on xAP Auto - will post resolution back here when done.

          K

          Comment

          Working...
          X