Announcement

Collapse
No announcement yet.

XAP Problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • XAP Problems

    I have just set up a NETIOM Xap board, and have connected up and working (I can view it via its built in web page). I have also downloaded and installed the XAP Conduit (v2.0.0.313) from mi4.biz.

    I was expecting HS to start to receive XAP messages and thus create XAP devices in the XAP config window, but nothing happens. HS also puts this message to the log every 5 minutes...

    "27/12/2006 16:18:34 - xAP Conduit - HomeSeer is not receiving xAP messages. Please check your network connection and the xAP Hub. If you have to restart the hub it may take upto 1 minute for this message to disappear"

    Can anyone help? I have tried uninstalling the plugin and reinstalling, but no luck.

    Hope someone has an idea - otherwise I have a lovely NETIOM board but no way to make it do anything!

    Cheers...R55Boy
    Last edited by r55boy; December 27th, 2006, 12:26 PM.

  • #2
    There needs to be a xAP hub running on the same computer that Homeseer is running.

    Comment


    • #3
      Michael - I thought that was only if more than one program was using XAP. In my case HS is the only XAP application. In fact in the startup log HS says that no hub is running and that this is ok.

      Still confused. Any other ideas? I'm at my wits end now - have tried everything!!

      Comment


      • #4
        Is it possible that you have a firewall blocking the xAP incoming UDP packets on port 3639 ? This sounds the most likely scenario. A network failure is another, eg a bad cable. Lastly do you have multiple network cards enabled in that PC by any chance ? If so is the xAP plugin using the correct one ?

        You are correct that if HS is the only xAP application running then you don't need the hub , although it's not a recommended configuration as future xAP applications will fail should you run one. Also if you have no hub you are unable to run the xAP Viewer application to check that the incoming xAP packets from the Netiom are being seen on your PC.

        What I recommend that you do is quit HomeSeer and download and run xAP Viewer from mi4 (its an xFX application) . It will startup as a xAP hub. You should now (within a minute) see the Phaedrus Netiom being listed as a xAP device in the left hand tree display. Also re-launch HomeSeer which will now be dependent on Viewer as its hub and it too will appear in Viewer immediately. Now check if HomeSeer is receiving the xAP messages from the Netiom and that all messages show in Viewer.

        Kevin

        PS Once it's working you can later choose to run 'hubless' or to use one of the various hubs available - I would recommend one that can run as a service.

        Comment


        • #5
          Thanks CP - might be on the right lines here. Will have (another) good look at my routers config pages. Think I might have seen UDP listed as blocked now you come to mention it. Will let you know!

          Best wishes!

          R55Boy

          Comment


          • #6
            I have now downloaded and run xAP Viewer, and sure enough no XAP messages are getting through, so its not a HS issue. I have spent the last 4 hours trying every possible setting in the router but with no success. All the settings are now open to all types of request. I can ping the unit and access its web demo page, but no XAP messages appear.

            HELP! Any other suggestions? Is it possible to somehow trace or manually trigger these XAP requests to see where they are getting blocked? Incidentally I have tried the xAP Viewer viewer on another PC on the network with the same results, so its either the NETIOM itself or my router.

            Two more things confuse me too - does the NETIOM always send messages, and how does it know where to send them to?

            Cheers...R55Boy

            Comment


            • #7
              You can send messages using the xAP Viewer with the Resend button. You should be getting a regular unsolicited heartbeat message. Did you check the multiple NIC possibility. For example do you have a USB that looks like an IP. If you look at your network properties you can see how many adapters Windows thinks it has.

              Comment


              • #8
                OK - I think its a windows config error or corruption. I cannot view network properties due to a WMI (Windows Management Information) corruption problem, which is a known issue on MS support site. The cure unfortunately is to restore to a control point (which!!), or do a repair install! Rats...

                I put the viewer on my old laptop and it sees the XAP heartbeats fine. In fact it even sees the one from the main PC, even though the main PC sees nothing.

                Trouble now is I can't find the XP CD!! Can't ask for your help with that though... ;-)

                Thanks for your help - will let you know if this cures the problem.

                Comment


                • #9
                  It seems your main pc does not have a functioning hub. Sending does not require a hub, but receiving does. When you startup make certain the xAP viewer is the first xAP application started. That means before HS.

                  Comment


                  • #10
                    I found that though I can ping from the main PC, nothing can see it. Disabling all firewalls etc made no difference either, and there was a problem with WMI.

                    Downloaded new drivers, did a BIOS flash, uninstall network and reinstall, you name it.

                    So finally I did a repair install, which also didn't cure the problem, but then I gave in, reformatted the HDD and a full reinstall and now, so far, touch wood, its working!

                    Thanks all for your help - this was a weird one. I just hope it doesn't come back! When I'm fully set up I'm going to image the drive and lock it away, just in case!

                    Comment

                    Working...
                    X