No announcement yet.

Comma in device codes

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

    Comma in device codes

    I just installed three new Rly8-XA modules and when I create devices, the devices for one of them are ,1 through ,8. That seems to be causing a couple of problems. One is I am unable to define those devices to MCSsprinkers because you list the devices separate by a comma.

    The second problem is that every time I start HS, the "Last Change" field for those 8 devices is listed as "unknown" (or something to that effect).

    Is there a way to create these devices with a code other than comma?

    Is there no way to tell this plugin to NOT create devices with a comma in the device code?


      Try this:
      • Temporarily remove the plug-in
      • Delete the comma devices
      • Create a new device with house code ",1"
      • Specify some string for the interface property of that new device (will need to use scripting). Something like "dummy plug-in".
      • Add your plug-in back and let it create its devices
      If I am thinking correctly, the plug-in will think that another plug-in is already using the comma housecode.
      Jim Doolittle

      My Twitter
      My Hardware & Software


        I tried that approach but couldn't figure out how to create devices with , in the device code. I could only select A-P and q-z from the housecode/unit code dropdown. I looked for a script command to create devices but couldn't find one.

        But, there is an easier way. I opened a help desk ticket and this was their answer:

        Edit your settings.ini file in the HomeSeer config folder and enter the line:


        This tells HS to not use this code when creating housecodes.

        Restart HS after making the change and then delete all of the comma devices and then re-create your Ocelot devices from the Ocelot config.

        I did that and it worked perfectly.

        Thanks for your response and suggestion.