No announcement yet.

HS2 - Ocelot Wits End

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

    HS2 - Ocelot Wits End

    Seriously, I'm at wits end here. I have programmed the Ocelot to a very simply program using CMAX:

    IF Variable #51 is = 1
    THEN Module #1 -SECU16 Relay #8 Turn ON
    IF Variable #51 is = 0
    THEN Module #1 -SECU16 Relay #8 Turn OFF
    IF Module #1 -SECU16 Input #0 is OFF
    THEN Variable #51 =0
    IF Module #1 -SECU16 Input #0 is ON
    THEN Variable #51 =1
    End Program

    So when the contact on Input #0 is closed, It sets Variable #51 to 1, which in turn closes the relay. This works perfect, no problem, no matter whether Homeseer or CMAX is running or even if they aren't.

    Homeseer, I never see a variable change...NEVER. Homeseer initializes the Ocelot, appears to talk with the Ocelot, but nothing!! I have tried all 4 plug ins...same result, no variable change ever.

    Any help, ideas or otherwise would be greatly appreciated.

    I don't use the ADI Ocelot plugin, but with the other plugin you have to load the ocelot/secu variables. Do you have to do that with this plugin? Have you tried that?

    Sorry if it doesn't help.


      Yeah, in all 4 of the plugins I've tried, there is a create variables button. In all instances variables are created but they don't seem to be tied to the Ocelot. That is I've programmed it like in my first post where I force a variable change, I know the variable changes in the Ocelot (because it performs the action based on the variable changing), but HS2 never sees it.

      Curious as to which plugin you are using and which version of HS2? Thanks.


        I am on HS version and the HS Ocelot plugin version from the updater.


 have the ocelot programed to change variable values? and you can "see" the variable change in homeseer with the HS Ocelot plugin? Curious on how you "see" the changes? Do you have an event trigger based on a value change? What about the other way? Where you change a variable in HS2 and Ocelot reacts?

          I'm asking because I figure if you could provide more details on what you are doing correct, maybe I can figure out what I'm doing wrong (I always assume me until I prove otherwise). Thanks.


            What are you looking for in the HS variable? Typically the DeviceValue is used for the SECU-16 inputs. It has been too long since I last had the Ocelot connect to HS to remember for certain.


              Michael...When you install the Ocelot plugin into HS2 it sets up "Devices" of device type Interface Variable that are named "Variable xx" which I'm assuming map to the equivalent Ocelot variable. Like I said...the setup seems to recognize the Ocelot, understands the variables, but then never seems to be able to read or write to the Ocelot after that.

              Think I will try a fresh reload for kicks...


                I have 2 different ocelots working very solidly with 2 different HS machines. I have variables that I set in the Ocelot that HS sees and I also set some variables in HS that the ocelot sees.
                I am really buried so I don't think I can help much but I wanted to let you know that it does work well.

                Running HS 3 on Win10 .


                  Is there a simple how to that someone can post


                    but then never seems to be able to read or write to the Ocelot after that
                    What are you looking at or setting to interact with the Ocelot variables? If I remember correctly you will never see anything on the HS Device Status page. You will see it via scripting or other technique that looks at the DeviceValue.


                      I have an ocelot running and use the variables, but it has been a very very long time since I have set that up or changed anything.

                      From what I remember,
                      Relays change instantly.
                      Inputs change instantly ( except for analog inputs )
                      Variables have to be polled by the plugin for updates.

                      What time is your polling set to on the plugin ?

                      If I remember correctly if the polling is set to fast it does not work correctly.

                      Can you control the relays from HS ?
                      Can you see input changes from HS ?

                      I am using the ADIOcelot plugin, I don't quite remember why at this point.

                      Why oh why didn't I just leave things alone, they had been working.


                        Here is the program that I am using with my Ocelot. As you can see from the file, I am setting the variable with data from the Ocelot.

                        Attached Files


                          I've reloaded to match Sonypoolplr's software configuration...HS2 with the HS Ocelot Plug in 2.1.0.

                          This time I turned on all of the error logging I could and it appears the plug-in simply isn't talking to the Ocelot other than when in configuration.

                          On the HS2 start up I get: "Ocelot Plug-in, Ocelet, init error: The device is not open"

                          Then I get: "Ocelot Plug-in, Timeout getting Vars"

                          So I guess I'm at the fundamental diagnosis of what is wrong in my initialization of the Ocelot plug-in. If I go to the Interface tab in setup it shows the Applied Digital Ocelot is enabled and Plug-In Status is "Interface OK", when I click on the config for the interface it brings up the pop up, says it finds it on COM2 and asks what I want to do. As a matter of fact I notice when I have the pop up open the logging changes from the "Ocelot Plug-in, Timeout getting Vars" to "Ocelot Plug-In, Timeout getting realtime I/O" so it appears to understand that I'm interfacing with the unit via other means.

                          Well since I bought it from Homeseer I'm going to put in a help ticket...I will keep you all informed...thanks for the feedback so far.


                            <<sigh>> submitted the help desk ticket with Homeseer.

                            While waiting I decided to unplug everything that could conflict with the comm port (z-wave interface, TED, USB Webcam, etc.). Same HS2 to Ocelot joy.

                            Put the Ocelot on a different comm port. Same HS2 to Ocelot joy.

                            Put everything back to the original way it was setup. And HS2 to Ocelot JOY!!

                            Makes no sense, have no idea on why it decided to suddenly work (other than Homeseer help desk ticket was being worked in the background by the mystics at Homeseer).

                            Thanks to everyone for onto the real fun of programming!!