Announcement

Collapse
No announcement yet.

Warning~!~Ocelot Plug-in, Timeout getting Vars

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Warning~!~Ocelot Plug-in, Timeout getting Vars

    I'm getting repetive "Warning~!~Ocelot Plug-in, Timeout getting Vars" messages. It happens once every few (2 - 5) days. When it happened, I have to restart Homeseer. Then everything is ok for few more days. When these messages occurred, I turned off Homeseer and used Cmax to talk to the ocelot, everything seems to be ok.

    I am using Applied Digital Ocelot version 2.2.2433.35446, firmware v8.23/15, HS v2.3.0.19 and two SECU16s connected to the ocelot.

    What do I need to do to correct this or is my ocelot going bad?

    Thanks

  • #2
    Is your Ocelot connected directly to a com port?
    -Rupp
    sigpic

    Comment


    • #3
      I agree with Rupp's analysis in that the likely culprit is not the Ocelot, but in the software driver for the COM port. Restarting HS will close the port and when reopened the software driver will be reset and work until it gets intself into the same situation. I run my ocelot with an IP/Serial adapter. I do it locally and also have also done the same over the internet where the ocelot is in one house and the PC in a second. The ocelot makes for a fine device for remote monitoring and control.

      Comment


      • #4
        Not sure if I have the same problem as vanyeh or not...what I get are spurts of "Ocelot Plug-in, Checksum error reading vars" they last between 30 minutes and 3 hours and the times in between everything seems to run smoothly (ie no Ocelot errors reported).

        I've tried the HS and ADI plug-ins and get the same results. Changed Com address and IRQ and get the same results.

        Comment


        • #5
          All the variables are downloaded fom the ocelot and a checksum performed over the bock. For the checksum to suced you need solid communications overs the transmission period. This is the most streneous communication for ocelot/hs. It could be noise on the cable from some form of external interference. It could be voltage leveks at the interface (3.5 volts from a typical pc vs. 12v per rs-232 spec. It could be bad interface drivers for the com port or com port hardware. The ocelot itself at the rs-232 interface could contribute too.

          Comment


          • #6
            Turns out that I had a "bouncy" relay (external to the Ocelot/ACU). Essentially what was happening was the status of the variable was changing during the Ocelot/HS communication and hence the checksum error. I replaced the external relay and the checksum errors went away.

            Comment

            Working...
            X