Announcement

Collapse
No announcement yet.

Control 2 Ocelots with Homeseer.

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • stevene
    replied
    Michael,

    I believe I have both working, both load and I do no see any errors.

    My 1st ocelot appears to be working normally. The second unit I will run the wire and connect this weekend.

    I went through the registry and manually deleted any ref to ocelot, after backing up of course.
    Then I restarted the pc and followed your directions, the house code thing confused me for a few minutes then I figured it out.

    Thanks for the plugin changes and all the help !!!!!!!!!!!!!!

    Thanks StevenE

    Leave a comment:


  • Michael McSharry
    replied
    I believe you are having problems because of registry entries. I suspect hs_compatibility has some memory of what it previously loaded. For my test I compiled both plugins again without any compatibilty to the prior versions. I loaded the first, when into its setup and changed the Interface property to ADIOcelot. I restarted HS, but likely did not need to. I then did the same thing with ADIOcelot2 so now the interface properties are ADIOcelot and ADIOcelot2. I went to ADIOcelot and created an additional variable on each of its existing house codes. I then used InterfaceManager (from sticky on ADIOcelot forum) to edit the two new variables to belong to ADIOcelot2 and changed their device codes to an unused sequential pair. I used Windows\Accessories\System Tools\Character Map to find a sequential pair. I exited HS. I then edited settings.ini and changed the base_var=XX for hspi_ocelot2 to be the integer value corresponding to the new house code. I restarted HS and went to ADIOcelot2 setup and added some additional variables. From this point forward they should remember their house codes. I'm attaching the two that I worked with.
    Attached Files

    Leave a comment:


  • Michael McSharry
    replied
    Tomorrow I will give it try with my HS install.

    Leave a comment:


  • jasv
    replied
    Originally posted by Czechmarty View Post
    Just out of curiosity - What is the reason for 2 Ocelots?
    I have some stuff that I control / sense in our livingroom such as fireplace, temp sensors, fans for the equipment cabinet, IR for audio/video equipment.

    On the other side of the house, upstairs, I would like to control more IR and some relays but It is not worth the wiring nightmare. Using a wireless serial to IP server I could connect the 2nd Ocelot and do what I need.

    Leave a comment:


  • stevene
    replied
    Originally posted by Czechmarty View Post
    Just out of curiosity - What is the reason for 2 Ocelots?
    I have a work shed on my property I would like to control some things in. I want the ocelot to run independent, so nothing I do purposely or other affects the house or vice versa. But I still wanted to be able to monitor things from the house.

    StevenE

    Leave a comment:


  • stevene
    replied
    I restarted HS after each step.

    If I load hspi_ADIocelot.exe all appears to work well, after i renable in setup.


    If I remove the file hspi_ADIocelot.exe and then add hspi_ADIocelot2.exe, 2 seems to initialize and has this error in log.

    9/21/2009 7:20:07 PM ~!~Info~!~HS Compatibility, cannot access plug-in HSPI_ADIOCELOT2.HSPI Automation error
    The system cannot find the file specified.

    I went into the ADIocelot2 config, changed the com port and the instance to 2 hit update.

    I then added the orig back hspi_ADIocelot.exe

    Now ocelot 2 inits but ocelot1 does not and I get this error again.

    9/21/2009 7:25:00 PM ~!~Plug-In~!~Found plug-in: ADIOcelot2, version: 1.14.0.10
    9/21/2009 7:25:00 PM ~!~Plug-In~!~Found plug-in: ADIOcelot2, version: 1.14.0.12
    9/21/2009 7:25:00 PM ~!~Error~!~Could not add ADIOcelot2 to the plug-in list. Is this a duplicate? Check for two plug-ins with the same plug-in name.

    And a message ocelot2 cannot communicate with the ocelot ( not hooked up yet )


    StevenE

    Leave a comment:


  • Czechmarty
    replied
    Just out of curiosity - What is the reason for 2 Ocelots?

    Leave a comment:


  • jasv
    replied
    I don't have time to try this for a couple of weeks but wanted to let you know there is at least one more person interested in the same thing. Thanks for working on this.

    Leave a comment:


  • Michael McSharry
    replied
    The .12 is the correct one. It may be a registry thing. Try a hs restart. You can also trying to temporily remove the original adiocelot then put it back when the new one is recognized

    Leave a comment:


  • stevene
    replied
    I know get this message.

    9/21/2009 6:50:17 PM ~!~Plug-In~!~Found plug-in: ADIOcelot2, version: 1.14.0.10
    9/21/2009 6:50:17 PM ~!~Plug-In~!~Found plug-in: ADIOcelot2, version: 1.14.0.12
    9/21/2009 6:50:17 PM ~!~Error~!~Could not add ADIOcelot2 to the plug-in list. Is this a duplicate? Check for two plug-ins with the same plug-in name.
    9/21/

    Leave a comment:


  • Michael McSharry
    replied
    I forgot to change the project name. Try the attached.
    Attached Files

    Leave a comment:


  • stevene
    replied
    Michael,

    I dropped it in the HS directory and restarted HS and got these errors.

    9/21/2009 6:13:46 PM ~!~Plug-In~!~Found plug-in: ADIOcelot2, version: 1.14.0.10
    9/21/2009 6:13:46 PM ~!~Info~!~HS Compatibility, cannot access plug-in HSPI_ADIOCELOT2.HSPI ActiveX component can't create object
    9/21/2009 6:13:46 PM ~!~System~!~Registering hspi_ADIocelot2.exe with Windows
    9/21/2009 6:13:48 PM ~!~Info~!~HS Compatibility, cannot access plug-in HSPI_ADIOCELOT2.HSPI ActiveX component can't create object
    9/21/2009 6:13:48 PM ~!~Error~!~Unable to access plugin: hspi_ADIocelot2.exe, try reinstalling plug-in


    Ocelot is not hooked up yet, that will be this weekend.

    SteveE

    Leave a comment:


  • stevene
    replied
    Thanks Michael,

    I will give it a try this weekend.

    StevenE

    Leave a comment:


  • Michael McSharry
    replied
    This should be the same as the existing ADIOcelot, but the name is ADIOcelot2 and the setting.ini group is hspi_ocelot2. I believe it comes up in default of Interface name "Applied Digital Ocelot" and you will need to make the selection to use the ADIOcelot2 as the Device .Interface property. An HS restart after the inteface name is changed is likely prudent. Obviously do appropriate backups before trying.
    Last edited by Michael McSharry; September 21, 2009, 05:42 PM.

    Leave a comment:


  • stevene
    replied
    Originally posted by Michael McSharry View Post
    Another thing that could be done is to recompile ADIOcelot with a new interface name and load it as a second plugin.
    Would that be hard to do ?

    Thanks StevenE

    Leave a comment:

Working...
X