Announcement

Collapse
No announcement yet.

Ocelot works in CMAX but not Homeseer

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ocelot works in CMAX but not Homeseer

    Hi, all. I tried to find a post on this particular issue without luck.

    I just started using HSPRO and am having trouble getting either Ocelot plugin to work. When I enable even one of the plugin interfaces for Ocelot (like X10 for Applied Digital Ocelot) and put in the COM port, Homeseer freezes and the plugin takes up all of my computer's CPU resources. If I shut and restart (both computer and HS), when the startup routine gets to the Ocelot plugin, it hangs, with

    <TABLE border=0 cellSpacing=2 cellPadding=0 width="100%"><TBODY><TR><TD class=LOGDateTime1 noWrap align=left>12/1/2010 12:40:24 AM </TD><TD class=LOGType1 colSpan=3 align=left>Plug-In </TD><TD class=LOGEntry1 colSpan=8 align=left>Initializing X10 Plug-in: Applied Digital Ocelot On COM Port 3</TD></TR><TR><TD class=LOGDateTime0 noWrap align=left>12/1/2010 12:40:24 AM </TD><TD class=LOGType0 colSpan=3 align=left>Plug-In </TD><TD class=LOGEntry0 colSpan=8 align=left>Initializing Plug-in: Applied Digital Ocelot</TD></TR><TR><TD class=LOGDateTime1 noWrap align=left>12/1/2010 12:40:26 AM </TD><TD class=LOGType1 colSpan=3 align=left>Info </TD><TD class=LOGEntry1 colSpan=8 align=left>Ocelot Plug-in, Version 2.1.0</TD></TR></TBODY></TABLE>

    The Ocelot log repeatedly says, "MSCOMM."

    I have to end-task the Ocelot plugin to have HS resume starting up.

    The Ocelot is connected via a serial to USB cable, and it works fine in C-MAX. Are there any settings I'm missing here? Other thoughts?

    Thanks for any advice!

    Avi

  • #2
    If using the ADIOcelot plugin for Homeseer 2 the Interface type needs to be set to ADIOcelot and not Applied Digital Ocelot. The HST Ocelot plugin uses the Applied Digital Ocelot interface name. The COM port for the unit is setup on the HS setup page for Interfaces. If you are getting MSCOMM in the log then it looks as if you are communicating, but normally you will not use the setting to show the debug/communication log.

    Comment


    • #3
      this may help (or it may not)

      http://board.homeseer.com/showthread.php?p=936950

      Ian
      Plugins:
      BLLogMonitor, BLGarbage, BLBackup, BLOutGoingCalls, BLUps, BLRfid, JvEss, DooMotion, Applied Digital Ocelot, AC RF Processor, UltraMon, PJC AVR 430, UPB, Rain8net, DSC Panel, JRiver Media center, Windows Media Player, SageMediaCenter, SnevlCID, MCSTemperature.

      Comment


      • #4
        thanks, but still not working

        Thanks for your replies and thoughts. I uploaded an empty program using CMAX that had an "end program" line in it. The upload went fine, but it didn't solve my problem.

        Just to test, I switched from the HS Ocelot plugin to the ADIOcelot plugin. When that start up, as before, here's what the HS log said:

        <TABLE border=0 cellSpacing=2 cellPadding=0 width="100%"><TBODY><TR><TD class=LOGDateTime1 noWrap align=left>12/2/2010 12:00:27 AM </TD><TD class=LOGType1 colSpan=3 align=left>Plug-In </TD><TD class=LOGEntry1 colSpan=8 align=left>Initializing X10 Plug-in: ADIOcelot On COM Port 3</TD></TR><TR><TD class=LOGDateTime0 noWrap align=left>12/2/2010 12:00:27 AM </TD><TD class=LOGType0 colSpan=3 align=left>Plug-In </TD><TD class=LOGEntry0 colSpan=8 align=left>Initializing Plug-in: ADIOcelot</TD></TR><TR><TD class=LOGDateTime1 noWrap align=left>12/2/2010 12:00:27 AM </TD><TD class=LOGType1 colSpan=3 align=left>ADIOcelot </TD><TD class=LOGEntry1 colSpan=8 align=left>Initializing X10 Interface on port 3 0 </TD></TR><TR><TD class=LOGDateTime0 noWrap align=left>12/2/2010 12:00:30 AM </TD><TD class=LOGType0 colSpan=3 align=left>ADIOcelot </TD><TD class=LOGEntry0 colSpan=8 align=left>Using Comm Port 3 0 </TD></TR></TBODY></TABLE>

        At this point, everything hangs until I end-task the plugin, at which point, I get this:

        <TABLE border=0 cellSpacing=2 cellPadding=0 width="100%"><TBODY><TR><TD class=LOGDateTime1 noWrap align=left>12/2/2010 12:00:53 AM </TD><TD class=LOGType1 colSpan=3 align=left>COM Plugin Error </TD><TD class=LOGEntry1 colSpan=8 align=left>Error initializing X10 Interface: Automation error The remote procedure call failed. </TD></TR><TR><TD class=LOGDateTime0 noWrap align=left>12/2/2010 12:00:53 AM </TD><TD class=LOGType0 colSpan=3 align=left>Plug-In </TD><TD class=LOGEntry0 colSpan=8 align=left>Finished initializing X10 interface ADIOcelot</TD></TR></TBODY></TABLE>

        Any further thoughts?

        Thanks so much,

        Avi

        Comment


        • #5
          You don't have CMAX and Homeseer running at the same time do you? They both can't access the Ocelot together, you have to shut down CMAX before starting Homeseer.

          Comment


          • #6
            Hi,

            The ADIOcelot plugin is the good one. If it's not working try to re-install it.

            Do you realy use the X-10 interface of the plugin? Mine is not active. Only Infrared currently.

            If you use something like a CM11a for your X-10 communication, it could be the cause of your problem...

            Comment


            • #7
              Still having trouble

              Thanks to everyone for your thoughts. At this point, I think I've tried everything suggested. I've removed and reinstalled (including the full deletion procedure) the Ocelot plugins (one at a time and together). I've confirmed that CMAX can control the Ocelot on COM3, which is the setting I'm putting in HSPRO, and CMAX is not running when I start HSPRO.

              I've removed the CM11 and CM15 plugins. I've enabled and disabled the various interfaces (X10, IR, Other).

              I've manually installed the ADIOcelot plugin from the download on this sub-forum. I've also tried installing the various files in Windows\System32.

              HSPRO just refuses to start with either of the Ocelot plugins enabled.

              While I can set the COM port setting for the ADIOcelot plugin, I can't access the config screen. There is no "config" button or link on the Setup > Interfaces page, and when I click on the drop-down for "ADIOcelot" in the HSPRO server window, there is a "setup" option but nothing happens when I click on it (and if I minimize all other windows, I still don't see anything).

              If I give it an incorrect COM port (like 1 or 2), it gives me different errors. In that case, it will have a timeout error (whereas when I give it the correct COM port, it throws off the errors above).

              Here's what my system.ini file in the HSPRO directory says about the Ocelot plugin:

              Code:
              [hspi_ocelot]
              reg_moved=1
              first_run=1
              mappings=
              comport=3
              poll_interval=2000
              invert=0
              log_errors=1
              log_comms=1
              showInMenu=1
              Recognition=0
              X10Xmit=1
              UpdateStrings=0
              RunAsXapNode=0
              IncludeVariables=0
              IncludeIO=0
              IncludeIR=0
              IncludeX10=0
              IncludeMessages=0
              SyncMaster=0
              Any thoughts?

              Thanks very much!

              Avi

              Comment


              • #8
                what are the parameters of the ocelot? [Cmax-> Controller Utiliity->Retrieve parameters - only 1st 26 matter] For some reason I'm thinking one of those may have an effect. Also, can you try it on another com port (swap with CM11a maybe)? Maybe try another com port number? Com3 used to use the same interrupt as Com1 but that was in the old hardware days and probably shouldn't be an issue now.
                jim

                Comment


                • #9
                  Jim, thanks very much for the reply. I will try changing the com port tonight. In the meantime, here are the Ocelot parameters (first 26; the ones after these are all 65535). I admit that I have no understanding what these numbers are supposed to represent. Thanks for your wisdom!

                  0 - 1261
                  1 - 0
                  2 - 0
                  3 - 1
                  4 - 0
                  5 - 0
                  6 - 3
                  7 - 0
                  8 - 15
                  9 - 15
                  10 - 2
                  11 - 4
                  12 - 0
                  13 - 0
                  14 - 0
                  15 - 1
                  16 - 2
                  17 - 1
                  18 - 0
                  19 - 0
                  20 - 80
                  21 - 0
                  22 - 128
                  23 - 0
                  24 - 0
                  25 - 50
                  26 - 1

                  Comment


                  • #10
                    Nothing especially jumps out except I would try changing parameters 1 and 6 to 0. If you have a bobcat you might want another value for parameter 1 for addressing but 1261 won't work. I've attached the list of parameters. In the 2nd worksheet is a listing of my parameters and yours for comparison. Pretty similar except where there would be differences in our system installatons (# of modules, etc.)

                    jim
                    Attached Files

                    Comment


                    • #11
                      Solved!

                      I've got it working. Here's what I did.

                      I disconnected my Napco panel that had been connected to the main serial port on my PC and connected the Ocelot to that COM port and restarted Homeseer. Suddenly, the ADIOcelot plugin loaded properly. Then, I was able to connect the Napco to COM5 (where Ocelot had been), restarted, and both are working!

                      (I did adjust the Ocelot parameters according to the manual before doing so, but that alone did not fix the problem.)

                      Thanks again for all the advice. Now, I can finally get started with HS!

                      Avi

                      Comment


                      • #12
                        Originally posted by avi@avidana.net View Post
                        I've got it working. Here's what I did.

                        I disconnected my Napco panel that had been connected to the main serial port on my PC and connected the Ocelot to that COM port and restarted Homeseer. Suddenly, the ADIOcelot plugin loaded properly. Then, I was able to connect the Napco to COM5 (where Ocelot had been), restarted, and both are working!

                        (I did adjust the Ocelot parameters according to the manual before doing so, but that alone did not fix the problem.)

                        Thanks again for all the advice. Now, I can finally get started with HS!

                        Avi
                        Seems like you had the ocelot set to com port 1 then. I noticed in this plugin if you set the comport, it acutally dont update in the ini... I would change mine to port 6 but the ocelot wont work until i manually went into the ini file and changed it to port 6. then it would work...

                        -Tom-
                        -Tom-

                        Comment

                        Working...
                        X