Announcement

Collapse
No announcement yet.

Trouble with the plugin

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Trouble with the plugin

    After I installed the iTunes plugin I can't get it working.

    I am running the latest HS 2.3.0.19 and the latest iTunes beta plugin from the updater 2.4.0.25. Also using HS touch plugin.

    Itunes is installed on the same machine and has 1 song in it.
    The plugin screen loads but shows this error on the top:

    Error: Public member 'GetMusicAPI' on type 'MarshalByRefObject' not found.

    Running WinXP SP3.

    Bastiaan

    #2
    restart HS and verify log if itunes loads up ok. seems that plugin did not load the song. this happens when you add recently new songs. I just restart hs and all is ok. at least for me.
    Hector
    ____________________________________
    Win.2003 OS, HS3
    BLDSC,BLstat,BLRadar,BLRamdom,BLOccupied
    BLups,BLrain8,HSTouch,Ultrajones Weatherbug,
    MyTrigger,ACRF2,W800,Zwave
    AP800,Honeywell Stat

    Comment


      #3
      Thanks for the the reply.
      I have restarted and reinstalled te plugin several times, no change.
      Went back to a bit older version too.
      Plugin must be loaded and working because I I can see the whole music player.
      It just doens't show the songs and gives the error as mentioned

      Lines I found in the log:

      ~!~Error~!~Web Server Error 404, cannot serve file: C:\Program Files\HomeSeer 2\html/

      and:
      26-12-2008 6:02:12 ~!~Database Item~!~Saving Event iTunes iTunes Controls VR
      26-12-2008 6:02:12 ~!~Database Item~!~Saving Event iTunes iTunes Controls VR
      26-12-2008 6:02:12 ~!~Database Item~!~Saving Event iTunes iTunes Volume VR
      26-12-2008 6:02:13 ~!~Database Item~!~Saving Event iTunes iTunes Volume VR
      26-12-2008 6:02:13 ~!~Database Item~!~Saving Event iTunes iTunes Album VR
      26-12-2008 6:02:13 ~!~Database Item~!~Saving Event iTunes iTunes Album VR
      26-12-2008 6:02:13 ~!~Database Item~!~Saving Event iTunes iTunes Artist VR
      26-12-2008 6:02:14 ~!~Database Item~!~Saving Event iTunes iTunes Artist VR
      26-12-2008 6:02:14 ~!~Database Item~!~Saving Event iTunes iTunes Genre VR
      26-12-2008 6:02:14 ~!~Database Item~!~Saving Event iTunes iTunes Genre VR
      26-12-2008 6:02:14 ~!~Database Item~!~Saving Event iTunes iTunes Playlist VR
      26-12-2008 6:02:15 ~!~Database Item~!~Saving Event iTunes iTunes Playlist VR

      and:
      26-12-2008 6:27:13 ~!~iTunes Error~!~LibGetTracks exception: Value cannot be null.Parameter name: Argument 'Array' is Nothing.

      and:
      26-12-2008 6:27:15 ~!~iTunes~!~Unable to play title: Object reference not set to an instance of an object.

      Hope someone can connect these errors to point to the right place :-)

      Comment


        #4
        Try loading more songs. I seem to remember there being a problem when only one song is in the library.
        💁‍♂️ Support & Customer Service 🙋‍♂️ Sales Questions 🛒 Shop HomeSeer Products

        Comment


          #5
          try this in the "Run" prompt under startmenu type this itunes/regserver then hit enter.
          I had a issue some what like that and it help. try it ,it may help
          Hector
          ____________________________________
          Win.2003 OS, HS3
          BLDSC,BLstat,BLRadar,BLRamdom,BLOccupied
          BLups,BLrain8,HSTouch,Ultrajones Weatherbug,
          MyTrigger,ACRF2,W800,Zwave
          AP800,Honeywell Stat

          Comment


            #6
            Added extra songs -> no change
            reinstalled/repaired Itunes -> no change
            ran regserver -> no change.

            Thanks for all the good tips, it must be something small.....

            Comment


              #7
              Error in Itune

              I am getting this error on the log and Itunes Play doesn't Function

              Warning, unable to create playlist: Object reference not set to an instance of an object.

              HomeSeer Version: Standard Edition 2.3.0.19
              HSPI_ITUNES.dll 2.4.0.21
              HSPI_HSTOUCH.dll 0.0.0.18

              Could someone tell me what is correct version I should be running.

              I also have old dll from Itune previous installs, What dll should I have for Itunes and hstouch.

              Thank You

              Greg Mack

              Comment


                #8
                What version of iTunes are you guys running?
                💁‍♂️ Support & Customer Service 🙋‍♂️ Sales Questions 🛒 Shop HomeSeer Products

                Comment


                  #9
                  Originally posted by BIGMACK48 View Post
                  I am getting this error on the log and Itunes Play doesn't Function

                  Warning, unable to create playlist: Object reference not set to an instance of an object.

                  HomeSeer Version: Standard Edition 2.3.0.19
                  HSPI_ITUNES.dll 2.4.0.21
                  HSPI_HSTOUCH.dll 0.0.0.18

                  Could someone tell me what is correct version I should be running.

                  I also have old dll from Itune previous installs, What dll should I have for Itunes and hstouch.

                  Thank You

                  Greg Mack
                  I just got this error. I had to bring up the iTunes link on the web interface and select something to play. Then it worked as expected.
                  💁‍♂️ Support & Customer Service 🙋‍♂️ Sales Questions 🛒 Shop HomeSeer Products

                  Comment


                    #10
                    I havent been able to get the iTunes plugin to work reliable.

                    For a while it worked, then after a restart of HS all the problems were back.
                    Since I do a lot of beta testing I need frequent restarts and it would be soooo nice if the iTunes plugin would keep working...

                    Versions: HS2 latest beta .39
                    HStouch beta .30
                    plugin versions: Tried them all from the updater, beta from updater, now I am (back) on the version that came with HStouch 2.4.0.22

                    Itunes v: 8.0.2
                    I have run itunes.exe /regserver to make sure that was not the problem:

                    Restarting HS the log gives:

                    17-2-2009 15:35:27 Info Initializing Plug-in: iTunes17-2-2009 15:37:27 iTunes Error initializing iTunes, either iTunes is not installed or the iTunes application is hung waiting for a response to a dialog.17-2-2009 15:37:27 iTunes Loading library in the background, this could take a few minutes...17-2-2009 15:37:27 Info Finished initializing plug-in iTunes17-2-2009 15:37:27 Info Initializing X10 Plug-in: ACT TI103 On COM Port 417-2-2009 15:37:27 Info Initializing Plug-in: ACT TI10317-2-2009 15:37:27 iTunes Finished loading tracks library17-2-2009 15:37:27 iTunes Error loading Library, Object reference not set to an instance of an object.17-2-2009 15:37:27 iTunes Finished loading Playlists17-2-2009 15:37:27 Info TI103 Plug-in, Version 2.0.517-2-2009 15:37:28 Database Saving Device iTunes Volume17-2-2009 15:37:29 Database Saving Event iTunes iTunes Controls VR17-2-2009 15:37:29 Database Saving Event iTunes iTunes Controls VR17-2-2009 15:37:29 Database Saving Event iTunes iTunes Volume VR17-2-2009 15:37:29 Database Saving Event iTunes iTunes Volume VR17-2-2009 15:37:30 Database Saving Event iTunes iTunes Album VR17-2-2009 15:37:30 Database Saving Event iTunes iTunes Album VR17-2-2009 15:37:30 Database Saving Event iTunes iTunes Artist VR17-2-2009 15:37:30 Database Saving Event iTunes iTunes Artist VR17-2-2009 15:37:30 Database Saving Event iTunes iTunes Genre VR

                    I can see in the taskmanager that iTunes is started, but it does not open on the computer. I can start it manually and play music without a problem.

                    If I leave iTunes open during a restart, it does not complain about a 'hung' iTunes but the other error is usally there

                    Error loading Library, Object reference not set to an instance of an object.

                    The machine is WinXP Sp3, plenty of memory and diskspace

                    Who has the magic trick to make it work?

                    Comment


                      #11
                      OK found a version of iTunes 7 on the net and installed it to see if it would make a difference but it did not.
                      Still get: Error loading Library, Object reference not set to an instance of an object.

                      I give up, going to open a ticket on this.

                      Comment


                        #12
                        Does iTunes start when HomeSeer starts? Is there a popup asking you to upgrade poping up?
                        💁‍♂️ Support & Customer Service 🙋‍♂️ Sales Questions 🛒 Shop HomeSeer Products

                        Comment


                          #13

                          Comment


                            #14
                            If iTunes isn't starting and showing when HS starts then this indicates a problem with iTunes. You should see iTunes startup on your screen.
                            💁‍♂️ Support & Customer Service 🙋‍♂️ Sales Questions 🛒 Shop HomeSeer Products

                            Comment


                              #15
                              Thats a nice conclusion :-)

                              But the program works normal, starts normal etc. Only HS seem not able to communicate with it.

                              I will once again de-instal everything and wipe all directories, then install version 8 again.

                              But this has been done numerous times and I just want it to work.

                              What/where else could I look for clues. Are there logs, debug options?

                              THanks for the help.

                              Bastiaan

                              Comment

                              Working...
                              X