Announcement

Collapse
No announcement yet.

Playlists take 30 seconds to start playing

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • jamester
    replied
    Rich,

    That is so awesome, thanks soooo much. My playlists start playing a lot quicker. THe one that used to take 30 seconds now takes 4 seconds. I still have one that takes 17 seconds to start but I can live with that.

    Thanks again for the quick turnaround.

    James

    Leave a comment:


  • rjh
    replied
    iTunes 2.3.0.34 is posted to the updater with the playlist delay removed.

    Leave a comment:


  • stevea
    replied
    Originally posted by rjh View Post
    I did not try it with MP yet, but I'll check. We recently changed how playlists are handled so it should simply just play this, so I don't see a reason for a long delay. Playing ALL tracks can take some time to start as we create a temp playlist then add all the tracks to it. This can be time consuming.
    Rich,
    My playlists are around 3K songs each (I think - can't remember exactly), and it currently takes somewhere between 2:30 and 3 minutes to start playing from when I tell it to start. HSTouch freezes while it is waiting for a return from the plug-in.
    Steve

    Leave a comment:


  • rjh
    replied
    I did not try it with MP yet, but I'll check. We recently changed how playlists are handled so it should simply just play this, so I don't see a reason for a long delay. Playing ALL tracks can take some time to start as we create a temp playlist then add all the tracks to it. This can be time consuming.

    Originally posted by stevea View Post
    Could the same problem be happening with WMP plug-in? I've been trying to communicate the problem with Rupp but I think his conclusion was that my playlists are too big.

    Steve

    Leave a comment:


  • stevea
    replied
    Originally posted by rjh View Post
    I see the issue, will post a fix asap.
    Could the same problem be happening with WMP plug-in? I've been trying to communicate the problem with Rupp but I think his conclusion was that my playlists are too big.

    Steve

    Leave a comment:


  • rjh
    replied
    I see the issue, will post a fix asap.

    Leave a comment:


  • jamester
    replied
    My library has about 7000 tracks & 20 playlists. THe library has been about this size for a few years but the delay with the plugin has only started to occur recently.

    Leave a comment:


  • rjh
    replied
    I'll have a look and post my findings. Can you tell me how large your music library is, how many tracks?

    Leave a comment:


  • jamester
    replied
    I have taken one for the team and paid for priority support.

    Leave a comment:


  • Rupp
    replied
    If you want priority support on this I would recommend the paid support available here:
    http://board.homeseer.com/forumdisplay.php?f=990

    Otherwise it will be a while before Rich has a chance to look at the code.

    Leave a comment:


  • jamester
    replied
    I haven't opened a ticket. Is that the best route to take?

    Leave a comment:


  • neiltimms
    replied
    I think the problem is caused by the fact that instead of just playing the playlist that is in ITunes HS creates a new playlist (called HSTemp) each time and then copies the tracks from the original playlist to this temporary one.

    Leave a comment:


  • Guest
    Guest replied
    I'm seeing the same problem. Have you put in a ticket on this?

    Leave a comment:


  • jamester
    replied
    At one point this plugin would scan the playlists at start up. I remember seeing the playlist names in the HS Log on start up. That would seem more efficient.

    I have around 20 playlists (some normal and some smart playlists). For me the size of the playlist does not change the time it takes to start playing. I created a playlist with just one song in it and it still took 30 seconds to start

    I have several keypads around the house that call a script to start playing playlists. This delay does not give an "automated" feel.

    Leave a comment:


  • mwaite
    replied
    I find this is the case. It appears the larger the playlist is, the longer it will take to load. It seems as if HS is loading the playlist data from iTunes when called up the first time.

    Leave a comment:

Working...
X