Announcement

Collapse
No announcement yet.

Playlists take 30 seconds to start playing

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Playlists take 30 seconds to start playing

    I'm using the latest version of the plug-in and iTunes.

    When I start playing a playlist from the web interface or thought scripting using

    MA.PlayMusic "", "", "playlist name"

    it will take 30 seconds to start playing the playlist.

    If I play a genre, artist, album using the web interface or using scripts it is instantaneous.

    Any suggestions would be great.

    #2
    I find this is the case. It appears the larger the playlist is, the longer it will take to load. It seems as if HS is loading the playlist data from iTunes when called up the first time.
    Mike

    Comment


      #3
      At one point this plugin would scan the playlists at start up. I remember seeing the playlist names in the HS Log on start up. That would seem more efficient.

      I have around 20 playlists (some normal and some smart playlists). For me the size of the playlist does not change the time it takes to start playing. I created a playlist with just one song in it and it still took 30 seconds to start

      I have several keypads around the house that call a script to start playing playlists. This delay does not give an "automated" feel.

      Comment


        #4
        I'm seeing the same problem. Have you put in a ticket on this?

        Comment


          #5
          I think the problem is caused by the fact that instead of just playing the playlist that is in ITunes HS creates a new playlist (called HSTemp) each time and then copies the tracks from the original playlist to this temporary one.
          Running HS PRO V2.5.0.49 & HS Pro V2.5.0.51

          Comment


            #6
            I haven't opened a ticket. Is that the best route to take?

            Comment


              #7
              If you want priority support on this I would recommend the paid support available here:
              http://board.homeseer.com/forumdisplay.php?f=990

              Otherwise it will be a while before Rich has a chance to look at the code.
              💁‍♂️ Support & Customer Service 🙋‍♂️ Sales Questions 🛒 Shop HomeSeer Products

              Comment


                #8
                I have taken one for the team and paid for priority support.

                Comment


                  #9
                  I'll have a look and post my findings. Can you tell me how large your music library is, how many tracks?
                  💁‍♂️ Support & Customer Service 🙋‍♂️ Sales Questions 🛒 Shop HomeSeer Products

                  Comment


                    #10
                    My library has about 7000 tracks & 20 playlists. THe library has been about this size for a few years but the delay with the plugin has only started to occur recently.

                    Comment


                      #11
                      I see the issue, will post a fix asap.
                      💁‍♂️ Support & Customer Service 🙋‍♂️ Sales Questions 🛒 Shop HomeSeer Products

                      Comment


                        #12
                        Originally posted by rjh View Post
                        I see the issue, will post a fix asap.
                        Could the same problem be happening with WMP plug-in? I've been trying to communicate the problem with Rupp but I think his conclusion was that my playlists are too big.

                        Steve

                        Comment


                          #13
                          I did not try it with MP yet, but I'll check. We recently changed how playlists are handled so it should simply just play this, so I don't see a reason for a long delay. Playing ALL tracks can take some time to start as we create a temp playlist then add all the tracks to it. This can be time consuming.

                          Originally posted by stevea View Post
                          Could the same problem be happening with WMP plug-in? I've been trying to communicate the problem with Rupp but I think his conclusion was that my playlists are too big.

                          Steve
                          💁‍♂️ Support & Customer Service 🙋‍♂️ Sales Questions 🛒 Shop HomeSeer Products

                          Comment


                            #14
                            Originally posted by rjh View Post
                            I did not try it with MP yet, but I'll check. We recently changed how playlists are handled so it should simply just play this, so I don't see a reason for a long delay. Playing ALL tracks can take some time to start as we create a temp playlist then add all the tracks to it. This can be time consuming.
                            Rich,
                            My playlists are around 3K songs each (I think - can't remember exactly), and it currently takes somewhere between 2:30 and 3 minutes to start playing from when I tell it to start. HSTouch freezes while it is waiting for a return from the plug-in.
                            Steve

                            Comment


                              #15
                              iTunes 2.3.0.34 is posted to the updater with the playlist delay removed.
                              💁‍♂️ Support & Customer Service 🙋‍♂️ Sales Questions 🛒 Shop HomeSeer Products

                              Comment

                              Working...
                              X