Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

Homeseer Omni Pro 2 Connection Problems. Help Please!!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Homeseer Omni Pro 2 Connection Problems. Help Please!!

    I am a new user of HS and by no means am experienced with all of its operations. To make things even more of a challange this is the first time we are using the HAI Omni Pro 2 board. Although they are both new systems, I seem to have no problem using both independantly. Put them together....... hours of frustration. I was able to find one other post that seem to have the same exact issue I was having but appeared never to have been resolved. Here is the brief overview, I will go into detail if anyone thinks they can help.

    The omni board will communicate with pc access and other interfaces with no problem. I am connected to the panel vai a serial to usb connection. Upon attempting to get the HAI plugin to initialize, I was given a can not communicate with panel message. This was occosionally replaced with a need more information (panel code) message. I went through various checks and changes in the web interface which would result in minor message variations but never a sucsessfull connection.

    Finally I changed the code in the configuration page to the PC ACCESS code in the panel and I seemed to get a different response. I restarted HS and once again got the could not connect message. After hours of working with the settings I was able to come up with some possible advancement. If I started HS and then changed the code to my pc access code, un checked the "Units" box, pressed save: then entered the code again, and re checked the units button, hs would start importing all of my sone numbers and therostat info. I could go into the device page and do things like change the thermo temp, but no change would be made to the thermos themselfs. The log stated the command had been sent and no error was show in the log. If I attemp to go to the security page I am given an error that stated "error in BuilZonePage. Error on line 650" I am given various error messages pertaining to errors in certian lines of code, and buildzonepage. I am going crazy trying to figure this out.

    If there is any one with any information I would greatly appreciate it. If you need any other information regarding the process or steps I have taken. Please just ask. Thank you very much for taking the time to read through this.

  • #2
    I would eliminate the USB to serial connection cable first. These things can and do cause many headaches due to the many incompatibilities they cause.
    -Rupp
    sigpic

    Comment


    • #3
      I experienced the same problems you are talking about. I spoke with HAI and they only suport 1 or 2 USB to Serial adapters. One of them is Keyspan USA-19HS. I am currently using this adapter because there are no serial ports and no open PCI slots in my computer. I get a connection fine but I'm finding that the Kesyspan drivers aren't that stable. I get a "blue screen" every few days. I think it's caused by some other program trying to access the COM port. It causes an IRQ error. This problem got a lot worse when I installed APC UPS software. I had to disable communication between the computer and the UPS. I also get occasional checksum errors in HomeSeer when trying to communicate with the OmniPro II. I have spent weeks trying to get this to work, have resinstalled XP serveral times, tried different USB to serial devices and it is still not stable. I'm now considering finding a different computer that has an available serial port and moving HomeSeer to that. Good Luck.

      Bob

      Comment


      • #4
        O.K. What your problem is (or maybe one of a few) is that you installed the HAI beta as the first HAI plug-in you used. Not a good move, since the beta has its share of bugs, and one of them is that you get the problem you describe. Install the non-beta from the updater first. Get that working. Then install the beta if you feel lucky.

        Let me know if your still having problems.

        Comment


        • #5
          Wow!! Thanks for immediate respnoses

          Being that this is my first time using a forum or mesage board I am shocked at how quickly everyone responded and how helpful everyone is. Thanks already. I now realize I should have put a little more information in my original post. In regards to the USB issue.

          I have tried a straight serial connection as well as the usb connection and the problem is identical. The usb to serial device I am using is a Edgeport/1 device. In regards to the HAI Beta: The first attempts with the HAI plug-in were with the stable version. I recieved the same exact problems but was never able to get as far as I have now. Now that I am actually getting some response from the panel, I will try to go back and try the stable version and see if that gets me any different response. Another question I have is regarding the HAI INF file. I opened the INF file to see what kind of settings I could find. Once again I am in no way experienced with the operations of INF files. Here are the problems I occured.

          1. I could not find an area in the INF file that was used for Panel Code. As far as a user code. This may just not be in the INF file, I just wasn't sure.

          2. If I change anything in the INF file, when I restart HS2 the INF file is rewrote to exactly what was there previously. This may or may not be normal operation. ???? One of the main reasons I started looking in the INF file is that I would save a bunch of settings in the HAI plugin interface page, such as 32 zones, 3 thermostates, 16 outputs, etc.., and when HS2 would start loading the plugin, it would say "25 zones, 6 units, 2 thermos, 4 outputs, etc... " Completely different then what I would have saved prior.

          I don't know if any of this information halps at all with my problem.. Has anyone got HS2 to work fine with Omni Pro 2 panel, with the stable or beta version of the plug in??

          Once again thanks everyone for taking the time to help out, much appreciated it!!

          Comment


          • #6
            Sure, lots of people use the plugin, but its tricky.

            - First, only use the stable release until you get it going.
            - You can't use PCAccess and HomeSeer at the same time with the same serial port. Shut off PC Access.
            - The panel code you should be using for Homeseer is the PCAccess Code, not a user code.
            - You should find an entry with something like "Panel Code=" in the ini file. The characters after it is not your panel code, but your "encrypted" panel code. There used to be problems with the encryption, so you should change the string of "random" characters to your 4-digit panel code. The plug-in will re-encrypt the code the next time around.
            - If you have a wrong code, for some reason, the panel will lock you out for an hour. Shut down HomeSeer, fire up PCAccess, and make sure that can log in so you know your not locked out, or just wait an hour.
            - Open up the panel and look at the two red LEDs by the serial port. When something is communicating with the panel, the panel lights flash. Both PCAccess and HomeSeer will cause the LEDs to constantly flicker when they are correctly connected.

            Comment

            Working...
            X