Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

Problem sending commands

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem sending commands

    I am not sure at what point this happened, but I no longer can change any values in my HAI panel from HS. It can READ values no problem, but neither webpage control buttons, nor actions in the events, nor scripting functions will change units or output values in the panel. I do have the latest HAI firmware 3.3d, HSPro version 2.4.0.3, HAI plugin version 2.1.2746.29695. Any hint will be greatly appreciated, thanks.

  • #2
    Any errors when you send commands?
    -Rupp
    sigpic

    Comment


    • #3
      No errors. HS behaves like it did the job, however the values remain unchanged on the panel, and when HS reads it back, it gets the old values. When I execute a script command, the result is False (unsuccessful). Here is my test code

      res=hs.plugin("HAI_System").UnitStatus(388)
      hs.writeLog "HAI", "Unit status " & res
      res=hs.plugin("HAI_System").HAI_Unit_Off(388)
      hs.writeLog "HAI", res
      res=hs.plugin("HAI_System").UnitStatus(388)
      hs.writeLog "HAI", "Unit status " & res

      This is HS log

      3/14/2010 6:10:28 AM ~!~HAI~!~Unit status On
      3/14/2010 6:10:28 AM ~!~HAI~!~False
      3/14/2010 6:10:28 AM ~!~HAI~!~Unit status On

      Comment


      • #4
        I am still unable to send commands to the panel, I looked at the HAI plugin log and don't see anything that would indicate a command. The log is full with STATUS messages and sometimes has UNIT STATUS followed by Neagtive Acknowledge, but I cannot tell if this is the log of my HAI trigger. Should I log a help desk ticket?

        Comment


        • #5
          Have you tried watching the HAI panel in PCAccess while you send commands over to it?

          If you want I can try your code - have to modify it a bit for my panel though.
          Last edited by Pete; March 23rd, 2010, 10:41 PM.
          - Pete

          Auto mator
          Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
          Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
          HS4 pro - 4.0.3.0 - Ubuntu 18.04/W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.8X

          X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

          Comment


          • #6
            Originally posted by Pete View Post
            Have you tried watching the HAI panel in PCAccess while you send commands over to it?
            Yes, nothing changes in PCaccess when I send commands from HS. I can change values through PCaccess commands. Perhaps the 3.2 firmware uses different protocol for commands?

            Comment


            • #7
              I've been using it with HSPro beta .26 / HAI plugin / FW 3.2D / and its working for me.
              - Pete

              Auto mator
              Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
              Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
              HS4 pro - 4.0.3.0 - Ubuntu 18.04/W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.8X

              X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

              Comment


              • #8
                Checked out your script statements and worked for me:

                Here is the log and event



                3/23/2010 11:28:26 PM Event Event Trigger "Test HAI 1"
                3/23/2010 11:28:26 PM Event Running script and waiting: &hs.plugin("HAI_System").HAI_Unit_On(17)
                3/23/2010 11:28:26 PM Event Running script and waiting: &hs.writeLog "HAI", "Unit status " & hs.plugin("HAI_System").UnitStatus(17)
                3/23/2010 11:28:26 PM HAI Unit status On
                3/23/2010 11:29:03 PM Event Event Trigger "Test HAI 2"
                3/23/2010 11:29:03 PM Event Running script and waiting: &hs.plugin("HAI_System").HAI_Unit_Off(17)
                3/23/2010 11:29:04 PM Event Running script and waiting: &hs.writeLog "HAI", "Unit status " & hs.plugin("HAI_System").UnitStatus(17)
                3/23/2010 11:29:04 PM HAI Unit status Off
                Attached Files
                Last edited by Pete; March 23rd, 2010, 11:29 PM.
                - Pete

                Auto mator
                Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
                Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
                HS4 pro - 4.0.3.0 - Ubuntu 18.04/W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.8X

                X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                Comment

                Working...
                X