Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

Run time error "438"

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Run time error "438"

    I had to load a new PC with Homeseer and loaded the newest HAI plugin. My thermostats showed "comm error", so I dug through the posts and found it was best to use the older plugin (not .NET). I renamed the exe and dll files and reinstalled the older plugin. HS starts up, connects to the panel (or so it seems) and the last message is "getting panel configuration information". If I go to the HAI_System web setup, it displays, but then pops up "Run-time error '438': Object doesn't support this property or method".

    Do I need to completely remove the .NET plugin somehow and start fresh? If so... how?
    Last edited by yzpmpgq; November 1st, 2012, 12:30 PM.

  • #2
    Bump

    Hate to bump, but I'm basically down till I get this fixed...

    Comment


    • #3
      Grasping at straws...

      Since there has been no response, I totally removed all existence of the HAI plugin, then reinstalled the new one again. It communicated with the panel (or at least appears to), but is now stuck logging:

      "Panel Model from Settings does not match model from panel. Settings: 16 Panel: 0".

      BUT, when the plugin starts up, it logs:

      11/1/2012 11:21:41 AM - HAI System - About to initialize HAI System on COM4
      11/1/2012 11:21:43 AM - HAI System - Panel Model: 16 (HAI Omni Pro II) with Panel Software Version: 2.5 Rev: F
      11/1/2012 11:21:43 AM - HAI System - Security code is number 1, which has a level of Master
      11/1/2012 11:21:43 AM - HAI System - Web Page not Opened, URL Failed.
      11/1/2012 11:21:43 AM - HAI System - HAI: Plug-In Needs additional configuration information (zone, unit info). Please use the web configuration screen to fill in the additional information needed.

      It appears to see the panel model originally. I also followed the instructions for fixing the configuration issue, but evidently missed something. I deleted all zones, therms, etc, set everything to 1 in the setup, etc. but still no help.

      As an aside, in desperation, I paid 2 days ago for the "priority support", but can't for the life of me figure out where to enter a ticket!

      Comment


      • #4
        Talk about frustrating... In a last ditch effort, I deleted all instances of the newer plugin, removed all HAI system variables and loaded the old plugin. It started up, asked for the COM settings, etc, then communicated with the panel, polled the settings, gave the resuming normal operations and BAM, the original run time 438 error. I ran this thing great for 5 years till the PC died and I had to load a new one. ANY help is appreciated!

        Comment


        • #5
          I give up for today. As an update, I once again removed all traces and reinstalled the new plugin. I found that by setting everything in zones, etc to "1", the configuration issue went away (seems like I remember that from years ago). Now, it loads everything:

          11/1/2012 12:24:37 PM - Plug-In - Initializing Plug-in: HAI_System
          11/1/2012 12:24:37 PM - HAI System - Poll Settings: Units - 8, Zones - 8, Thermostats - 2
          11/1/2012 12:24:37 PM - HAI System - HAI Plug-In Version 2.1.2746.29695
          11/1/2012 12:24:37 PM - HAI System - About to initialize HAI System on COM4
          11/1/2012 12:24:38 PM - HAI System - Panel Model: 16 (HAI Omni Pro II) with Panel Software Version: 2.5 Rev: F
          11/1/2012 12:24:39 PM - HAI System - Security code is number 2, which has a level of Master
          11/1/2012 12:24:39 PM - HAI System - Zone 1 does not have a name saved for it. Default names for all HAI components have been loaded. Please see the 'Plug-In' menu option in HomeSeer to configure names.
          11/1/2012 12:24:39 PM - Plug-In - Finished initializing plug-in HAI_System

          Then, after more startup info, it gives:

          11/1/2012 12:24:41 PM - HAI System - Performing Startup/Recovery Check of the System.
          11/1/2012 12:25:02 PM - HAI System - Error: Failed to get configuration information from the panel.

          Seems like it communicates fine when HS starts up, then drops it and won't communicate after. Any insight or should I scrap this expensive wallhanger that has evolved into just my security system and go to a DSC system?

          Comment


          • #6
            The most recent HAI firmware version is 3.11, yours appears to be very old. Try upgrading the panel's firmware and see if it helps.

            Comment


            • #7
              A bit late, but if you still have the issue, turn on all the debugging in the plugin, let it fail then post it. I'll be able to tell by the serial comms what's going on.
              2.5 Firmware is old, but don't worry too much about that. Post the log and we'll try and see what's going on.

              Ross.

              Comment

              Working...
              X