Announcement

Collapse
No announcement yet.

Polling Interval!?!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    GC,

    Long Time, no talk to. I have following these Posts with interest. You never responded to me following the information I sent you from the See my Post under the "HELLO ??" Thread from back in August. I had some of the same problems JLehnert is experiencing with the Polling, but I have an OMNI PRO II with many zones. I only use the PLUG-IN very rarely, because it does not support all my devices and it does not update them accordingly. I have been using WEB-LINK II without any of the problems here. The status updates almost instantly. I would be willing to help out with any additional testing once you have fixed the Original Problems.

    Comment


    • #32
      Gerry,

      Actually I did respond and worked with you at length on this. I last sent a message on 8/30 detailing that you had not established communications with the panel because the panel model returned by the plugin is 0. After that, you or I involved Rich and that was the last I heard. I did not get a reply from you stating whether or not you got your panel communications working properly or not. It appears as though you have the same problem as Joe in that the HAI software is probably interfering with the serial port.

      I know that the Omni Pro II is not the issue because that is the model of panel that HAI sent for development of the plugin.

      Regarding the updates: Again, there is absolutely nothing I can do about the temperature and unit updates as the Omni protocol does not provide realtime information. I am doing the group poll and the only way I can improve upon that is to remove items from the group poll that do get updated in the event log. If HAI is updating instantly, then either they are using a back door that they do not tell application providers about, just like they will not expose the configuration part of the protocol, or they are polling at a very high frequency.

      Items that are updated in the event log such as zone status changes are updated instantly in the plugin if the communications are functioning properly. The update would be instant and appear realtime if zones were shown as devices in the Windows UI, but because there are so many, they are only shown on the web page and that needs a refresh for the data to be updated.

      This loss of communications/polling thing is absolutely driving me nuts too. I think I am going to change the plugin to NOT poll for zone status since that comes in automatically when the zone changes, just to see if that somehow helps the situation.

      Comment


      • #33
        How about that!

        A password problem, just as Mr. JLehnert suggested.

        There are so many codes that it is sometimes difficult to track, that is why I try to keep them consistent to a certain point.
        My confusion was in the fact that there were no problems with PCACCESS or weblink, yet problems with the plugin.

        Turns out, In OMNI there is an "installer code", "master code", and "manager code", as well as the user codes. Then you have the "Pcaccess code".

        I changed all my codes to be different, which we all know that is the way they should be, and that solved the problem.

        So thanks again for the help, as we are up and running.
        JOE

        <BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by JLehnert:
        cmcjo,

        Unrelated to your problems, but don't use the same code for both PCAccess and your user/master code(s). When dialing into the panel on the phone, if it receives the PCAccess code it sticks the modem online instead of the voice response system.

        My system is described in my profile.<HR></BLOCKQUOTE>

        Comment


        • #34
          GC,

          Thanks for the response. I did E-Mail you an update on 8/31 stating that I just brought the Panel up without the COM-Port connected (I share the Panel Port with another Processor running the HAI (WEB-LINK II) software. I did this just for a demo to get the INFO below. It does not matter whether the Panel is connected or not I still have the same problems. I do not have any problems connecting to the OMNI-Pro II panel. The Plug-in works fine connecting. The problems I still have are described below:
          -----------------------------------------



          New Update - HAI plugin 0.4.0.19

          GC,

          Just loaded the HAI plugin 0.4.0.19.

          1. Did a RESET Configuration.
          2. Shut Down HOMESEER
          3. Went to 'HAI Plug-IN Name and Limits Configuration' Screen and tried to change the ' Number of X10/ALC Units:' to 256 and 312. It would not allow me to do this.
          4. Went to 'Get/Assign Names'.
          5. Did a Load from HAI Panel and downloaded devices.
          6. Did a SAVE.
          7. Brought HOMESEER down and up.
          8. Loaded the WEB Page.
          9. Went to HAI Units and Devices.
          10. In Unit 1 position, which is not used, I see one of my Sprinkler Flags, which is really Flag 24 Unit 416.
          11. Unit 265-272 are HAI Relays, the Names for those Relays are loaded in the HAI Panel in those positions, but never get transfered down when I do a download, but in Unit 271 which I manually loaded 3 weeks ago, the name is still there, and has not been overlayed, and is showing the correct unit status.
          12. Unit 393-417 are my Flags, again no Flag Names are Loaded from the HAI Panel, though the Flag Status seems to be correct.
          13. All of my Buttons seem to be correct.
          14. The Last Unit Code that is loaded is Unit 422 and I do not use Unit 418-422, so I can't tell if they are OK.

          Thanks again for reply.

          Comment


          • #35
            Gerry,

            Can you please verify the version of the plugin you are using? It should be 1.0.0.

            Thanks.

            Comment


            • #36
              GC,

              As per your request:


              11/6/2002 10:40:16 PM~!~startup~!~Done Loading Settings
              11/6/2002 10:40:16 PM~!~Info~!~HomeSeer version is: 1.6.0
              11/6/2002 10:40:16 PM~!~startup~!~Loading config file
              11/6/2002 10:40:29 PM~!~startup~!~Done Loading config file
              11/6/2002 10:40:29 PM~!~startup~!~Restoring device status
              11/6/2002 10:40:29 PM~!~startup~!~Initializing X10 Interface 2
              11/6/2002 10:40:31 PM~!~startup~!~Done Initializing X10
              11/6/2002 10:40:31 PM~!~startup~!~Initializing Infrared Interface
              11/6/2002 10:40:31 PM~!~startup~!~Done Initializing Infrared Interface
              11/6/2002 10:40:31 PM~!~startup~!~Initializing I/O
              11/6/2002 10:40:31 PM~!~startup~!~MR26A Interface version 1.1.617 initializing
              11/6/2002 10:40:31 PM~!~Info~!~MR26A Interface opening port COM7
              11/6/2002 10:40:31 PM~!~Info~!~MR26A Interface started on port COM7
              11/6/2002 10:40:34 PM~!~HAI System~!~HAI Plug-In Version 1.0.0
              11/6/2002 10:40:36 PM~!~HAI System~!~About to initialize HAI System on COM2
              11/6/2002 10:40:41 PM~!~HAI System~!~Panel Model: 16 (Omni Pro II) with Panel Software Version: 2.1
              11/6/2002 10:40:48 PM~!~Temp05 Plug-in~!~Version: 0.0.6
              11/6/2002 10:40:48 PM~!~Temp05 Plug-in~!~Initializing Interface
              11/6/2002 10:40:56 PM~!~startup~!~Done Initializing I/O
              11/6/2002 10:41:00 PM~!~Info~!~Web Server started on port 1180
              11/6/2002 10:41:00 PM~!~Info~!~Local IP address is: 192.168.1.7
              11/6/2002 10:41:00 PM~!~startup~!~Initializing text to speech
              11/6/2002 10:41:06 PM~!~HAI System~!~Performing Startup/Recovery Check of the System.
              11/6/2002 10:41:16 PM~!~startup~!~Done Initializing speech
              11/6/2002 10:41:17 PM~!~startup~!~Initializing Telephone Interface
              11/6/2002 10:41:17 PM~!~Info~!~HomeSeer Phone is not available
              11/6/2002 10:41:19 PM~!~startup~!~Done Initializing Telephone Interface
              11/6/2002 10:41:19 PM~!~Info~!~Script engine version: 5.6.7426
              11/6/2002 10:41:34 PM~!~Device State has been RESTORED~!~COMPLETE

              Comment


              • #37
                Gerry,

                I read and re-read what you wrote, and then Rich and I did some testing. Here are the answers to your issues:

                First and foremost, most of your issues with the names being incorrect is due to the downloading of the names from the panel not working correctly. This could be due to there not being enough time allocated for this operation on the Omni Pro II (e.g. very large) systems, or it could just be that the CPU is having trouble keeping up. It could also be the panel choking a little. Either way, the downloading of the names is a one-time (hopefully) event that until I get working correctly you will have to work around. Using the UI in the plugin to assign names, you should be able to assign all of your units and devices the name you know to be true, even if it is mislabelled after the download. If that UI does not work well for you, then a manual edit of the settings.ini file should yield an obvious syntax for putting the entries there, and that is where they are stored permanently anyway. Remember that the plugin does not limit the length of the names like the panel does, so the plugin could not store the names back in the panel or they would have to be short again.

                Another problem is a simple 10lbs not fitting into a 5lb container. The X10/ALC number box which you tried to put a 300+ number in cannot have that large a number. Although this is the largest panel Omni makes, HAI still did not invent additional X-10 codes and so 256 is all it will accept -- Rich tested and found this to work fine.

                We did find one bug though - the number of zones for security was only allowing 2 digits when in large systems like this it should allow 3. Until I get the plugin changed, a manual edit of settings.ini will work for those who do use over 100 zones of security. (Which, by the way, is one huge house!)

                So most of your issues are with the labels themselves, and I do acknowledge that the name download does not always work correctly on these large systems, but you should be able to use the name UI from the plugin to get the proper (and long) names for everything loaded without any problems.

                Let me know how it goes or if you need help getting the names in there.

                Comment


                • #38
                  GC,

                  Several emails with no reply. Hopefully it means you've forgotten to check that box and nothing bad has happened.

                  Any progress on a fix?

                  My system is described in my profile.
                  My system is described in my profile.

                  Comment


                  • #39
                    Sorry - yes, the box that I get that email account with has been down, and I have not had time to even check this message board in a couple of weeks. I am looking at some full-time employment and may be handing the HAI plug-in to somebody else to support and code the enhanced version of.

                    I will try to get that other email box running again and catch up with the emails - sorry for the delay.

                    My last message (or was it a post?) to you mentioned something that I wanted to try, and in my system it did help some with the speed. I have been working with an Omni Pro II recently, and it was able to download all of the names without any problems, so I am encouraged on that too. My last message involved trying to get the HAI plug-in into a beta package in the updater so that you could try it out without having to manually install it. I will try to get off my butt and get that done soon.

                    Sorry again for the delay.

                    Comment

                    Working...
                    X