Announcement

Collapse
No announcement yet.

Guest Mode access to HAI Security page and links

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Guest Mode access to HAI Security page and links

    Is it just me or can guests to homeseer trigger anything on the HAI page. I just tried it tonight. On the Homeseer status page it says guest mode but when you click on any HAI links it no longer says guest mode. It also allows me to arm or disarm my system(I sat in front of my HAI keypad as I did this). I logged in from within my home network, but I did so from my domain name which points back to my home network to a different computer. I logged in as guest and got the response I described above. Anyone else see this?

    -Shane

    #2
    Shane,

    That would be accurate - if guests can get to the page, they can use it.

    I am making some other changes to the HAI plug-in, so I will see if I can add support for checking for the guest access. For now, just disable guest access.

    You said you had some problems getting the HAI plug-in going - I just discovered some big bugs that were introduced due to some other changes I was making, and nobody discovered them because they only appear when you are setting up the plug-in initially. I can't imagine knowing about these now how frustrating it must have been for you setting it up - you should have called or emailed me earlier!

    Anyway, I have addressed those bugs and as I said, doing a few new features, so I'll see if I can do something with the guest access. If nothing else, I will disable the page entirely for the guest user.


    Regards,

    Rick Tinker
    HomeSeer Technologies

    Regards,

    Rick Tinker (a.k.a. "Tink")

    Comment


      #3
      Did any of these bugs have to do with the plug-in locking up if it wasn't communicating correctly. I had the plug-in lock up a lot and Homeseer wouldn't even start until I shut the instance of HAI down. I just wanted to make sure you found this problem. I'm running the latest beta on XP Pro. (I would have contacted you sooner but I was experimenting with the wiring to my serial port on HAI so I thought the problems were my fault initially)

      What additions are you working on? What are the future plans if you don't mind sharing?

      Thanks,
      -Shane

      Comment


        #4
        Shane,

        The problem was that the OK button on the interface configuration screen was broken and was not doing anything, and so the plug-in would appear to have been locked up when it really was not. It was a mess and it got through the weeks it was up there as a beta because apparently only people who already had it configured were testing it!

        I am adding support for a button to temporarily disable the plug-in and close the COM port to make George happy. I was also looking into enabling the plug-in to use the HAI as your X-10 interface, but HAI's capabilities in this area are so extremely limited that I am not sure I can pull it off. A bunch of other features are either waiting for HAI to send me the configuration part of the protocol or the DLL for the Ethernet communication. I may try to get some additional X-10/Compose/Leviton dimming capabilities in there for the X-10 units in the system.


        Regards,

        Rick Tinker
        HomeSeer Technologies

        Regards,

        Rick Tinker (a.k.a. "Tink")

        Comment


          #5
          Sounds great. That would be great if you could add those features. If you could enable HAI as an x-10 interface then that would be one less serial port. Please let me know when you have an updated version, I've had some problems changing some configuration options of the plug-in.

          Thanks,
          -Shane

          Comment

          Working...
          X