Announcement

Collapse
No announcement yet.

Trigger Delays

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trigger Delays

    I remember a while back about a discussion on how some HAI actions experience a delay before HomeSeer sees them. I remember it had something to do with the polling nature that HomeSeer must perform to get panel status. I can't find the discussion now. Can someone refresh my memory on which type of HAI events can experience this delay to HomeSeer and which ones don't? I'm triggering a light on a zone "not ready" and sometimes I see a delay, and other times I don't.

    Also, was there any way to reduce the delay? I have the polling interval set to something like 200 ms but sometimes see a delay of 5 to 10 seconds.

    Thamks.

  • #2
    Are you running the latest version? There were polling interval/polling method changes a few builds back to improve this situation, but please run the beta version in the updater as it is the best version regarding polling.

    There should be no delay for items that the panel notifies the plug-in of immediately - e.g. zone changes. Off the top of my head I cannot recall of the zone arming status and latch alarm status are immediate as well, but definitely the basic zone ready/not-ready trigger should always be near instantaneous. The polling rate for that is half a second anyway, not likely to be noticed. I have an event that turns on the garage lights if I open the house-garage door at night, and those lights always turn on by the time I start stepping into the garage!

    The panel arming status (obviously), alarms, unit on/off, and button presses I believe round out the "near instantaneous" category.

    Items that the plug-in does NOT get an immediate notification for that must be polled at the less-frequent rate are everything having to do with thermostats, unit changes other than On/Off (e.g. counter changes or X-10 device bright/dim), and zone analog value.


    So if you are seeing a zone secure/not-ready trigger being delayed, then you are likely having communication problems and I need to know that. If you are seeing delays and are not on the latest beta version, then please upgrade to that and let me know if you still see them.


    Regards,

    Rick Tinker
    HomeSeer Technologies

    Regards,

    Rick Tinker (a.k.a. "Tink")

    Comment


    • #3
      Rick, thanks. I do have the latest version of everything, I think. I have looked in the ini file and in the plug-in configuration and couldn't find any way to change the polling interval, although, as you say, that might not make a difference.

      I should explain that this is going through DooMotion, and that might be causing a delay. Basically I have an event that triggers when the door opens (like you do) and then this sets a virtual device to "on." This virtual device is a DooMotion Motion Detector, which triggers a DooMotion occupancy detector. When the occupancy detector is "on" this turns on the light.

      Let me do some debugging. I'll put some logging in the events to see if the delay is in the HAI plugin or DooMotion. As recommended, I'm controlling the X-10 from HomeSeer directly and not through the HAI panel X-10, so the return path isn't an issue.

      Comment


      • #4
        It does appear that the delay isn't in the HAI plugin, but rather its in DooMotion. I'll move this problem to that forum.

        10/21/2003 6:55:36 AM~!~Event Trigger~!~HAI Zone Triggers Set Garage Motion Virtual M23 On (Garage Motion Detector)
        10/21/2003 6:56:00 AM~!~MOTION~!~>>>>>>>> Motion Detected with Garage Motion Detector - No Motion (00:30)
        10/21/2003 6:56:00 AM~!~Event Trigger~!~Status change trigger (Garage Lights On):Garage Occupancy Sensor M33 On F2 On (Garage Lights)

        Comment

        Working...
        X