Announcement

Collapse
No announcement yet.

RC-122, anyone got one working?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • RC-122, anyone got one working?

    Has anyone here got a RC122 model to work? I was able to get it working with the HAI PCSTAT program, I actually had to place a supplemental 12v power supply across the yellow and black wires. But I am unable to get any response at all in HomeSeer.

    I have uncommented lines in the thermostat script and I can see data going back and forth, but yet nothing ever shows up on the screen.
    Here is an example from my log:
    <pre class="ip-ubbcode-code-pre">
    11/7/2003 8:18:54 AM~!~rc100~!~In GetTemp
    11/7/2003 8:18:54 AM~!~rc100 SendChar~!~sending: 1
    11/7/2003 8:18:54 AM~!~rc100 SendChar~!~sending: 2
    11/7/2003 8:18:54 AM~!~rc100 SendChar~!~sending: 3
    11/7/2003 8:18:54 AM~!~rc100 getdata~!~---------------
    11/7/2003 8:18:54 AM~!~rc100 GetChar~!~New buffer length: 1
    11/7/2003 8:18:54 AM~!~rc100 getdata~!~ra 0
    11/7/2003 8:18:54 AM~!~rc100 GetChar~!~New buffer length: 1
    11/7/2003 8:18:54 AM~!~rc100 getdata~!~dlmt 129
    11/7/2003 8:18:54 AM~!~rc100 getdata~!~mtype 1 leng 8
    11/7/2003 8:18:54 AM~!~rc100 GetChar~!~New buffer length: 1
    11/7/2003 8:18:54 AM~!~rc100 getdata~!~databuf (d) 0 99
    11/7/2003 8:18:54 AM~!~rc100 GetChar~!~New buffer length: 1
    11/7/2003 8:18:54 AM~!~rc100 getdata~!~databuf (d) 1 139
    11/7/2003 8:18:54 AM~!~rc100 GetChar~!~New buffer length: 1
    11/7/2003 8:18:54 AM~!~rc100 getdata~!~databuf (d) 2 122
    11/7/2003 8:18:54 AM~!~rc100 GetChar~!~New buffer length: 1
    11/7/2003 8:18:54 AM~!~rc100 getdata~!~databuf (d) 3 3
    11/7/2003 8:18:54 AM~!~rc100 GetChar~!~New buffer length: 1
    11/7/2003 8:18:54 AM~!~rc100 getdata~!~databuf (d) 4 1
    11/7/2003 8:18:54 AM~!~rc100 GetChar~!~New buffer length: 1
    11/7/2003 8:18:54 AM~!~rc100 getdata~!~databuf (d) 5 0
    11/7/2003 8:18:54 AM~!~rc100 GetChar~!~New buffer length: 1
    11/7/2003 8:18:54 AM~!~rc100 getdata~!~databuf (d) 6 120
    11/7/2003 8:18:54 AM~!~rc100 GetChar~!~New buffer length: 1
    11/7/2003 8:18:54 AM~!~rc100 getdata~!~databuf (d) 7 101
    11/7/2003 8:18:56 AM~!~rc100 GetChar~!~timeout: 29934 29936
    11/7/2003 8:18:56 AM~!~rc100 SendChar~!~sending: 1
    11/7/2003 8:18:56 AM~!~rc100 SendChar~!~sending: 2
    11/7/2003 8:18:56 AM~!~rc100 SendChar~!~sending: 3
    11/7/2003 8:18:56 AM~!~rc100 getdata~!~---------------

    </pre>

    I am at my wits end... the only reason I jumped into this home automation was to get my thermostats automated and now I am stuck.

    Scott

  • #2
    ... I finally got mine working. I am not sure exactly what I did.

    I was able to get one reliably working with HAI's PCSTAT program. I then decided to permanently install the all the wiring.

    I then played around with HomeSeer still no response. I then used PCSTAT to download and upload program and config settings to both thermostats.

    I then went back to HomeSeer and every works just fine (except for the random timeouts)

    I am totally puzzled but extremely happy...

    Scott

    Comment

    Working...
    X