Announcement

Collapse
No announcement yet.

RC Thermostats

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • RC Thermostats

    I am pre wiring my house with the intention of using the HAI RC thermostats my question is how is the device wired. I have run a cat 5 cable to the location of the Thermostat it sticks out the wall beside the AC cable that the AC company installed from the unit. Do I need to also run another Cat 5 cable from the Unit it self back to the Controller or does the wall unit connect both Serial and unit cables directly to it.

  • #2
    All of the HVAC wiring should be normal and done by an HVAC contractor. The only other wire you need then is your CAT-5 (3-4 wires is really all you need) from the thermostat wall unit to your HomeSeer PC or HAI/OnQ panel (depends on which one you are going to connect it to).


    Regards,

    Rick Tinker
    HomeSeer Technologies

    Regards,

    Rick Tinker (a.k.a. "Tink")

    Comment


    • #3
      one more thing if i want to connect it to a HS pc does it connect to the RS232 port on the pc and if so do i need a seperate RS232 serial port for each thermostat. I will have three as my house, it has 3 HVAC systems. and does HS support the RC units connected in this way or do i need an Omni controler.

      Comment


      • #4
        Yes, HomeSeer supports connecting the thermostats this way. The RC thermostats use a modified RS-232 protocol, so yes you connect all three thermostats to a single serial port on the PC. You just have to remember to set the address on each thermostat so that you have addresses 1, 2, and 3.


        Regards,

        Rick Tinker
        HomeSeer Technologies

        Regards,

        Rick Tinker (a.k.a. "Tink")

        Comment


        • #5
          Is this in the installation guide anywhere? I don't see anything labelled serial port? It shows how to wire up to a relay and to an HAI unit- but not sure about the serial.

          Thanks,
          Mike
          HS3 Pro Edition 3.0.0.435 (Windows Server 8.1 on ESXi box)

          Plug-Ins Enabled:
          Z-Wave:,RaspberryIO:,AirplaySpeak:,Ecobee:,
          weatherXML:,JowiHue:,APCUPSD:,PHLocation:,Chromecast:,EasyTr igger:

          Comment


          • #6
            Here is a manual which shows how to wire to your PC, assuming the attachment works. If not, give me your email and I will send it to you.

            The PC connector is the same as the connector to the Omni.
            Attached Files

            Comment


            • #7
              Ok-
              Well that was easy. I made the cable- now I have to figure out if it works.

              Do you use HAI software to do this or do you go for broke with the plugin?

              Mike
              HS3 Pro Edition 3.0.0.435 (Windows Server 8.1 on ESXi box)

              Plug-Ins Enabled:
              Z-Wave:,RaspberryIO:,AirplaySpeak:,Ecobee:,
              weatherXML:,JowiHue:,APCUPSD:,PHLocation:,Chromecast:,EasyTr igger:

              Comment


              • #8
                You only get the plug-in if you have an HAI panel. The thermostat can only work through the plug-in with an HAI panel. It doesn't sound like you have a panel so will will want to go with the script-based thermostat control. Soon, there is supposed to be a thermostat plug-in.

                -Shane

                Comment


                • #9
                  So I installed my RC90 and tried the RC80 and RC100 script- they seem to be almost identical minus one case statement.

                  I editted the port on the script to be 2. For some odd reason or another- the script runs this GetIOMISCPort command and that seems to change my comm port to one before it opens it. So the script opens the wrong port (one-which I use for something else). I forced the script to port 2 by changing the hs.OpenCommPort line and just shove a 2 in there and it doesn't complain about it- but the plugin doesn't seem to work. I think the port number must be calculated elsewhere. I do get timeouts like everyone else - like 84245 84261.

                  Anybody know offhand what I could be doing wrong? I will try this other script (multistat) and see how it goes....
                  HS3 Pro Edition 3.0.0.435 (Windows Server 8.1 on ESXi box)

                  Plug-Ins Enabled:
                  Z-Wave:,RaspberryIO:,AirplaySpeak:,Ecobee:,
                  weatherXML:,JowiHue:,APCUPSD:,PHLocation:,Chromecast:,EasyTr igger:

                  Comment


                  • #10
                    I did set the thermostat for 300 baud...
                    HS3 Pro Edition 3.0.0.435 (Windows Server 8.1 on ESXi box)

                    Plug-Ins Enabled:
                    Z-Wave:,RaspberryIO:,AirplaySpeak:,Ecobee:,
                    weatherXML:,JowiHue:,APCUPSD:,PHLocation:,Chromecast:,EasyTr igger:

                    Comment


                    • #11
                      Did you program the thermostat for Serial protocol? It may be in Omni protocol mode. Also, make sure of the thermostat's address setting - needs to match the address in the device/script.


                      Regards,

                      Rick Tinker
                      HomeSeer Technologies

                      Regards,

                      Rick Tinker (a.k.a. "Tink")

                      Comment


                      • #12
                        I think so. The first field I can program is address- so I left that alone at 1. The second field in comm mode- that I set to 0 which is "300 RS-232" which is serial.

                        I am going to guess my wiring, but why does the script try to open a different port?
                        HS3 Pro Edition 3.0.0.435 (Windows Server 8.1 on ESXi box)

                        Plug-Ins Enabled:
                        Z-Wave:,RaspberryIO:,AirplaySpeak:,Ecobee:,
                        weatherXML:,JowiHue:,APCUPSD:,PHLocation:,Chromecast:,EasyTr igger:

                        Comment


                        • #13
                          go to device properties select the thermostat there is a field at the bottom to put the com port you want to using.

                          Comment


                          • #14
                            I am not seeing that... maybe I am doing something wrong here- my order seems backward from yours... I select the thermostat device, goto device properties.. Name "downstairs thermostat", location "living room", device type "RC90". Under device types, I set RC90 to use therostat script RC100. I uncommented out the port line in the script to initialize to port two.

                            I don't see anything under the device property denoting port.

                            Mike
                            HS3 Pro Edition 3.0.0.435 (Windows Server 8.1 on ESXi box)

                            Plug-Ins Enabled:
                            Z-Wave:,RaspberryIO:,AirplaySpeak:,Ecobee:,
                            weatherXML:,JowiHue:,APCUPSD:,PHLocation:,Chromecast:,EasyTr igger:

                            Comment


                            • #15
                              Go to the homeseer windows screen. Not IE. You have on the Left side "Devices" "Events "Log". Click Devices. Double click on your Thermostat. When the box appears re select device type and select the same thermostat you now have. When it comes up at the bottom you will be able to put the com port in.

                              Comment

                              Working...
                              X