No announcement yet.

JDS for HomeSeer 2.1 BETA

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

    Digital Inputs Not Responding

    Installed the latest update suggested to cure the timer problem. This jhas worked fine with respect to the timer issues I had, but now my digital inputs do not respond in HS.

    They worked fine just before the 2.1.2464.19627 version, but have not responded since then.

    I noticed another thread on this board that implies that the same thing might have happened to the security links following this update as well. I don't use these, so don't know whether they are in fact "broken" on mine or not.


      I noticed an entry in my Stargate Message log (from WinEVM) such as:

      10/03,16:29:06,EXT Reset

      This corresponded to a soft reboot of the Stargate for an unknown reason. I have not seen this happen before. It happened twice in the past hour.

      Is there any code in the Homeseer plug-in to "reset" the Stargate? This would be more than simply starting and stopping the schedule. The command to reboot the stargate is being issued somewhere?

      Does anybody else see this occurring in their SG message log?

      Oh, and while I'm mentioning the message log, I see that the message log read button doesn't work in the "Stargate CONTROL" page in Homeseer. I have WinEVM running at the same time (using Serial Splitter) and I see the message log appear there when I try to get it in Homeseer. So the command is being sent, but the read is not getting captured by the plug-in.



        I switched to com port 5 today and i no longer get the

        9/29/2006 9:57:46 PM ~!~JDS StarGate~!~Error in CommThreadProc:, Safe handle has been closed

        message. hope that helps.


          I notice that the "SET TIME" button appears to set the Stargate too early by one minute and one second.


            Hi Gang-

            There is a new build posted to the updater. I suppose we could call this one "RC1", but I wont pull a Microsoft here

            Please give this a try. All builds in threads have been removed, so please get the latest out of the updater.

            • Made 8CUR more reliable
            • More fixes to Timers
            • Cleaned up debug logging
            • Various other fixes detailed in threads
            This is version 2.1.2476.25883
            -RJ (HomeSeer Tech)


              RJ, Thank you for the new build. I posted some comments in a new thread about logs, but I had some comments on this build:

              1. I disabled TIMER DISPLAY to eliminate the log entries, but it keeps doing it.

              2. When I go to the Stargate Control page, I see:
              when i went to the stargate control panel in Homeseer: (what is this command?)


              What is this supposed to be? ##4 is a response meaning "invalid command"
              Is this something to do with the phone stuff?

              3. I notice that my timers expire and are left with a value of -1.

              4.The message log button still doesn't work.
              I monitored the serial port and saw the following:

              ##%15 sent by Homeseer
              ##0 received
              - - - contents of the message log received- - -
              ##0 received

              But the window showed nothing - perhaps because you stopped reading the data after the first ##0?

              when i requested the system info, which seems to ack only at the end, this worked:


              FW Ver 4.00.0 Build 0.00.5

              .Sched Name: 20061012

              .Stat: running

              .10/12/2006 21:24:18

              .376 ms Cycle time

              .Sunrise: 6:50 Sunset: 18:19

              .Lat: 33, Lon: 117

              .DST: Enabled [Active]

              .Mem Use = 53%

              .Refresh value: 15

              .Security seed: 15

              .Modem Answer on Ring: 0

              .X10:AC Freq 60 Hz 1 Phase

              .IO Status

              . 1111111

              . 12345678 90123456

              . -------- --------

              .DI 01010000 10000000

              .Relay 00000000


              .Analog 1 2 3 4 5 6 7 8

              . 004 001 008 008 000 058 000 075


              Last edited by timlacey; October 13, 2006, 01:25 AM. Reason: adding another comment


                I am also having a problem getting my SG to communicate with HS. I get the error "Error in global Init/Comms: Unknown hardware: #"

                I conenct to SG on Comm3 using a Keyspan USB to serial connector, if that makes a difference. It seems that the connection to SG is messing up many things--many events based on time of day (e.g. turn lights on and off at dusk) aren't happening, but manual events do work.
                Thanks for any help.


                  Be Sure to Use the Most Recent Plugin

                  The latest version is now available through the Updater, full featured, and a real nice contribution by Agent J. What version are you using?


                    Also, try a real COM port and make sure the USB adapter is not the issue. Sometimes those USB adapters don't operate properly.
                    💁‍♂️ Support & Customer Service 🙋‍♂️ Sales Questions 🛒 Shop HomeSeer Products