Announcement

Collapse
No announcement yet.

Flags resetting on import?

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Flags resetting on import?

    I don't know if this is a SG import anomaly or a "me" problem. I have tried to kick off events in HS using a change in a SG flag state. Problem is the event kicks off even when the flag state doesn't change and does so periodically, although not every 10 seconds(import frequency). Does the import of device states/values "erase" the existing states/values in HS on import and then rewrite them, causing HS to "determine" that they have changed?

    I have had to resort to using variables and DeviceValueByName scripting to get around this issue. I have SG change the variable value, wait 11 seconds and then change the value back to 0 to insure that HS doesn't keep seeing the kick-off value.

    Can anyone suggest what the problem may be?

    Dennis

    #2
    Hi Dennis:

    This is probably just a misconfigured event. There are two types of triggers, "Changed to" and "Set to." You want "Changed to," which only triggers when the value changes, i.e., on to off, not on to on. Set to will trigger whenever the flag is set, which would be whenever the flag is polled.
    -RJ (HomeSeer Tech)

    Comment


      #3
      Thanks

      Thanks RJ.

      I'll make that change this week end. You've done a great job with the program.

      Dennis

      Comment


        #4
        I have not had any trouble with SG flag state being automatically registered by HS. Have you tried it without polling the flags?
        Mike____________________________________________________________ __________________
        HS3 Pro Edition 3.0.0.548, NUC i3

        HW: Stargate | NX8e | CAV6.6 | Squeezebox | PCS | WGL 800RF | RFXCOM | Vantage Pro | Green-Eye | Edgeport/8 | Way2Call | Ecobee3 | EtherRain | Ubiquiti

        Comment

        Working...
        X