Announcement

Collapse
No announcement yet.

Error in HandleRelayEvent

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Error in HandleRelayEvent

    RJ,
    One other thing I could use your imput on. I keep getting the following error message in my HS log:

    JDS StarGate - Error in HandleRelayEvent: Object reference not set to an instance of an object.

    Can you give me an idea of what to look for to fix this problem? I have tried to no avail. It doesn't happen every polling interval, nor can I associate it with a particular event firing.

    Dennis

    #2
    Hi Dennis-

    If you can enable debug on the plugin (Function and Com), then send me a log segment where the problem occurs, I should be able to figure this out.
    -RJ (HomeSeer Tech)

    Comment


      #3
      Miracle on 9th Street

      RJ,
      Maybe it's a Christmas miracle or perhaps my tinkering (no pun) solved the problem, but I haven't seen the error in quite a while. It may have been due to several duplicate events that appeared on an import, which I deleted. Now the problem is that HS "encounters a fatal error and needs to shut down" on a daily basis. I don't know if this is SG related or not. I'll keep you posted.

      Dennis

      Comment


        #4
        HI Dennis-

        Glad to hear all is well. Just to follow up a bit: This is definitely Stargate related, so if it does appear again it is a problem with the plugin, not HomeSeer. If you can reproduce the problem with a specific series of events (Changing a relay, from HomeSeer or Stargate, etc.), that would be particularly helpful. If not, a debug log statement of the problem would be sufficient.
        -RJ (HomeSeer Tech)

        Comment


          #5
          Originally posted by RJ View Post
          HI Dennis-

          Glad to hear all is well. Just to follow up a bit: This is definitely Stargate related, so if it does appear again it is a problem with the plugin, not HomeSeer. If you can reproduce the problem with a specific series of events (Changing a relay, from HomeSeer or Stargate, etc.), that would be particularly helpful. If not, a debug log statement of the problem would be sufficient.
          I was something similar for a while, but it just went away.

          12/30/2006 6:25:19 PM ~!~JDS StarGate~!~Error in HandleTimerEvent: Method not found: 'System.String Scheduler.hsapplication.AddAction(Int32, Scheduler.Classes.action_type_value, System.Object, System.Object, System.Object, System.Object, System.Object)'.


          Matt

          Comment


            #6
            Hi Matt-

            This is due to a difference in how HomeSeer 2.1 and 2.2 handle the AddAction function. If you need timers to work, you also need at least HomeSeer 2.1.122.

            http://board.homeseer.com/showthread.php?t=115864

            This thread discusses the change here slightly. It is a bit further down, but explains the reasoning.
            -RJ (HomeSeer Tech)

            Comment


              #7
              Variable Duplication, etc.

              RJ,
              A new problem has developed. I'm at HS 2.1.162.0 & SG 2.1.2548.21307. The plug in duplicates some variables on import. I delete the variable, import and I get two of the newly created variables, exact copies. A check of SG shows only one instance of each variable with a normal value of 0. On import I not only get two of each previously deleted variable, but the value of each is 100. Also, the value cannot be set to 0 or decremented/incremented. And, the "Type" appears as "SG Varaible", yet the plug-in assigns an X10 code to the variables instead of an \n. I can reset,increment or decrement other SG variables in HS.

              Any ideas?

              Dennis

              Comment


                #8
                Hi Dennis-

                What is the number of these Variables in HomeSeer and Stargate? Their HomeSeer code(A1, etc.) and Stargate index(1 to 255) will help me figure out what is going on.
                -RJ (HomeSeer Tech)

                Comment


                  #9
                  Duplicate Variables

                  I am seeing the exaxt same thing. I had to delete BOTH variables, stop Home Seer, restart Home Seer, and then reimport and everything was ok.

                  Comment


                    #10
                    Number of Variables

                    RJ,
                    In reply, I have 99 variables listed in HS: \1-\11, \14-\81, \83-\96 (93variables), plus 6 others listed as Z2(Interface Variable), A3(Interface Variable), A4-A5(SG Variable) and A7-A8(SG Variable). These last six are the problem variables.

                    In SG I have 1-11, 14-81, 83-96, 98-101, 103-104. The 98-104 variables are the problem variables.

                    Also, I on my last try at deleting then re-importing the problem variables, I got a Log message for each problem variable (6) stating "DeviceClass error for [variable], invalid housecode. Reverting to the previous value."

                    Dennis

                    Comment


                      #11
                      Log Clip

                      RJ,
                      A few posts back I mentioned that I was having a problem with a HS variable causing an event to fire even though the variable in SG did not change. I made sure that the event was configured to trigger on a "Changed to", but the event still triggers. The variable in SG did not change, but the event triggered. I was able to capture some debug info in the log, see attached. Note that there is no indication of the variable "JDS Home/Away Dennis Home" status changing. I ran the log from ##%20 to ##%20 preceeding the event firing to the same after the evnt firing.

                      I hope this sheads some light on this most vexing problem.

                      Dennis
                      Attached Files

                      Comment


                        #12
                        Rj

                        RJ?

                        You out there? Did you get a chance to review my post?

                        Dennis

                        Comment


                          #13
                          Sorry Dennis,

                          I think I lost this post while browsing the boards. I will take a look at this today.
                          -RJ (HomeSeer Tech)

                          Comment


                            #14
                            Hi Dennis-

                            EDIT: Hold the phone, I am working on a fix for this now. Should be posted here shortly.

                            EDITv2: OK, I think I have a fix for this. Can you give the attached build a try?

                            EDITv3: Removed old build, see the updater.
                            Last edited by RJ; February 8, 2007, 05:43 PM.
                            -RJ (HomeSeer Tech)

                            Comment


                              #15
                              Rj

                              Rj,
                              Sorry, I didn't mean to sound bitchy or pushy....my wife is a little over-anxious to get the SG LCD back working with HS so she can use it to play her playlists via media player.

                              I'll give the file a spin and let you know the results.

                              Thanks.

                              Dennis

                              Comment

                              Working...
                              X