No announcement yet.

A Tweak for IR Expander support

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

    A Tweak for IR Expander support

    I wrote this note to RJ back in October, but just found it in my drafts folder, so I figured I'd send it. The IR problem I had was very infrequent and may have been related to other problems I was having, but it was clear that Homeseer was ignoring the problem by not recognizing the ack response for a failed IR command.

    Does anyone else have problems sending IR from Homeseer (i.e. not 100% reliable?). I don't use IR much from Homeseer so this isn't a big concern of mine. Just some thoughts I'd worked through last year that I figured I'd share.

    I wanted to let you know that I have seen ##1 messages returned from IR commands sent. Those commands, sent by Homeseer, had not worked.

    I sent RCS an e-mail to ask them about this. I am pretty sure that ##1 indicates bus fault, and that a reset command like ##%3100 would be required to reset the bus. I wanted them to tell me the best approach to reset the bus

    For now, you may want to log the ##1 ACK as a "IR Expander Bus Fault Error" or something, so it is clear that the IR commands did not get sent properly.

    The proper ack to receive from a successful IR command is ##0

    My note to RCS follows: (they never sent any response to this, so ??)
    Yesterday I was testing IR commands with Homeseer and Stargate, such as the following:

    At a point, though, I was getting the ack ##1, which I assume to indicate "bus fault".

    If a bus fault is detected, is the best remedy to issue a net reset command "##%3100" or to disable and re-enable the expansion bus (##%3700 and ##%3701) or to wait? I could also see using the ##%38 command to verify the bus state?

    I would like to tell the coders at Homeseer what they should do in the event of a bus fault reported.

    I am inclined to recommend that Homeseer:
    send the IR command, such as ##%286c0685f501010100
    if the ack is not ##0, send the net reset command and make an entry in the homeseer log
    re-try the IR command, such as ##%286c0685f501010100
    if the ack is still not ##0, then report an error in the Homeseer log and give up.

    Right now, Homeseer simply sends the IR command and waits for any ack.
    The protocol docs do not include the IR send command, so that's why I'm asking you.

    I don't use IR much, but when I do I always have SG handle it. I've not seen the problem you describe, but may not know where or how to look for it. I simply learned the IR commands into the expander and then reference the one I want to send in SG. What is it that you are doing?
    Mike____________________________________________________________ __________________
    HS3 Pro Edition, NUC i3

    HW: Stargate | NX8e | CAV6.6 | Squeezebox | PCS | WGL 800RF | RFXCOM | Vantage Pro | Green-Eye | Edgeport/8 | Way2Call | Ecobee3 | EtherRain | Ubiquiti