Announcement

Collapse
No announcement yet.

Fresh Start

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Greg,
    Glad to hear things are working better.
    Originally posted by noopara View Post
    It sure would be nice if the Type designation of Flag was showing instead on Unknown. Is this what everyone sees for flags?
    Where are you referring to? Is this on the Status page?

    Also, why doesn't the status page automatically reflect the status change of a flag instead of having to manually refresh the page? Is this what you all see too?
    There is an entry on the Web Server setup page to designate the auto refresh rate. It's set to zero - no refresh - by default. You can try setting it to refresh frequently and see what impact it has on your network and server.
    Mike____________________________________________________________ __________________
    HS3 Pro Edition 3.0.0.548, NUC i3

    HW: Stargate | NX8e | CAV6.6 | Squeezebox | PCS | WGL 800RF | RFXCOM | Vantage Pro | Green-Eye | Edgeport/8 | Way2Call | Ecobee3 | EtherRain | Ubiquiti

    Comment


      #17
      Mike,

      Yes, I am referring to the Status page.

      This page has headings for Status, Location 2, Location, Name, Code, Type, Last Chg, On-Off.

      After spending a little more time with this, I think I understand what is going on. Initiating a change from within HS will cause the status shown in the Status column to toggle in real time. However, if the change comes from SG, it does not show until you refresh the page. This is true for all device types.

      On my Status page I have no entries for Location 2. Does anyone know what field in WinEvm this is? It might come in handy.

      Under Code for each device is a unique id. x10 devices all start with an alpha character (house code) and then flags start with a $, digital with a [, security with a (, time label with a ', and variable with a #.

      Under Type are designations such as JDS Appliance, JDS Control, JDS Lamp for x10 devices and JDS Unknown for Flags. All other devices have a designation such as SG Digital, SG Relay, SG Security, etc etc.

      The On-Off column contains on-off buttons for x10, relays and flag devices. Clicking on these changes the state of each device and the change is reflected in the Status column even for flags.

      I am wondering if I still have a problem with my device import since the flags are showing up as JDS Unknown in the Type column. I am beginning to think that this is just a minor bug in the code. I can live with it if that is all it is. If it is a bug, everyone should be seeing the same thing.

      -- greg

      Comment


        #18
        Originally posted by noopara View Post
        On my Status page I have no entries for Location 2. Does anyone know what field in WinEvm this is? It might come in handy.
        I don't believe there is any SG equivalent. I've input entries from HS and they are not disturbed when I do a re-import from SG.
        Under Type are designations such as JDS Appliance, JDS Control, JDS Lamp for x10 devices and JDS Unknown for Flags. All other devices have a designation such as SG Digital, SG Relay, SG Security, etc etc.

        I am wondering if I still have a problem with my device import since the flags are showing up as JDS Unknown in the Type column. I am beginning to think that this is just a minor bug in the code. I can live with it if that is all it is. If it is a bug, everyone should be seeing the same thing.
        Hmmm. I agree, there is something not quite right yet. My flags are all labeled as "SG Flag". On the other hand, as you note, it may not be a big deal, but I'd pay attention for problems. You could also delete all your flags and import them again to see if that makes a difference. Does you JDS.ini file have entries that look like: "gFlagHC =$" / "gFlagHC1=" / "gFlagHC2=" on three separate lines?
        Mike____________________________________________________________ __________________
        HS3 Pro Edition 3.0.0.548, NUC i3

        HW: Stargate | NX8e | CAV6.6 | Squeezebox | PCS | WGL 800RF | RFXCOM | Vantage Pro | Green-Eye | Edgeport/8 | Way2Call | Ecobee3 | EtherRain | Ubiquiti

        Comment


          #19
          Mike,

          I do have the entries in the jds.ini file.

          I'm going to move on from here. Maybe some other symptom will show up and lead to an answer regarding the flag type designation question.

          Thanks for the help.

          -- greg

          Comment


            #20
            Try re-importing all of your flags and nothing else and select to over write existing devices to try and clean up your flag device type. All of my SG flags are listed as SG Flag in the HS Status page.


            On my Status page I have no entries for Location 2. Does anyone know what field in WinEvm this is? It might come in handy.
            You can use the two location fields to build some type of organizational hierarchy. Location 1 does come from SG so you are stuck with that but location 2 is added/edited from the device pages of HS.

            I do this:

            Some device like a security device.

            Location 1: LivingRoomWindow
            Location 2: Security System

            Another:

            Location 1: FrontPorchLight
            Location 2: Outside Lights

            Cool huh?

            Comment


              #21
              KLS,

              Thanks for the suggestion. I tried re-importing only flags with over-writing checked and it did not change the type designation for flags. They still show as JDS Unknown. I did it several times and each time the HS log shows: Import of 44 devices completed, 0 devices created, 44 devices updated.

              I also deleted all the flags and then re-imported them and the HS log message changed to Import of 44 devices completed, 44 devices created, 0 devices updated - the type designation still shows JDS Unknown. The flags function going both ways, so the type designation problem doesn't seem to be causing any problem as far as I can tell. I guess it ain't broke - sort of?

              Thanks for the tip on the use of Location 2. I shall follow your lead and do something similar. Keeping it all organized is always a challenge.

              -- greg

              Comment

              Working...
              X