Announcement

Collapse
No announcement yet.

Caddx to SG or HS

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Caddx to SG or HS

    If you have a caddx alarm, are you opting to hook it to SG or directly to HS via the free jvcaddx plugin?

    What are the pros and cons going with the plugin?

    Tim
    -Tim

    HSPro - 3.XXX - Dell mini W7 x32
    Way2 Call
    Elk M1 Gold
    UPB HAI switches
    HAI RC2000 Thermostat

    #2
    I'd love to hear from any Stargate user who is NOT using the Stargate for CADDX, as I've considered using the Homeseer plug-in also.

    Since I use Insteon controlled through Homeseer and the ISY, having the CADDX in Homeseer might speed up my motion detection and lighting routines, rather than havign to go through the Stargate.

    That said, the Stargate has some mission critical functions that require the security sensors to work, and if Homeseer were down, I'd lose that. However, I think most of the critical inputs are on DIs, so they'd be OK still. Hmm. . . . like I said, I'm considering the plug-in for long-term. .

    But I use the CADDX with Stargate right now and it works well.

    Tim

    Comment


      #3
      Since I started HA using SG alone and already had the security system interfaced to it, I've left it that way. As Tim says, it works well, and I have not seen any reason to change it.

      If I were just introducing the NetworX box, I'd probably try the HS plug-in first and use that unless I was not satisfied for some reason.
      Mike____________________________________________________________ __________________
      HS3 Pro Edition 3.0.0.548, NUC i3

      HW: Stargate | NX8e | CAV6.6 | Squeezebox | PCS | WGL 800RF | RFXCOM | Vantage Pro | Green-Eye | Edgeport/8 | Way2Call | Ecobee3 | EtherRain | Ubiquiti

      Comment


        #4
        I'm just asking because I am having lots of trouble trying to integrate caddx via SG.

        I made two variables one called hscaddxrequest and one called caddxstatus.

        HS controls the hscaddxrequest variable and SG controls the caddxstatus one.

        When HS wants to disarm alarm it sets the hscaddxrequest variable and SG looks for the change and acts on it.

        In turn SG sets the caddxstatus variable based on the caddx mode and HS can act on that.

        As simple as this is you would think it would work reliable and it does not. Another issue I have is when I run the SG event to load the alarm user_VAR upon a disarm, the alarm actually rearms itself.

        So, I'm thinking of going direct to HS to see how that works.
        -Tim

        HSPro - 3.XXX - Dell mini W7 x32
        Way2 Call
        Elk M1 Gold
        UPB HAI switches
        HAI RC2000 Thermostat

        Comment


          #5
          Tim-

          When you say your variable scheme doesn't work reliably, what exactly happens (or doesn't happen)?

          I am watching this thread with interest. I have been using SG+Caddx for many years. Works great 99.9% of the time, but that 0.1% is very annoying.

          Specifically, SG occasionally "sees" false and phantom changes in Caddx zone status or alarms. For example, on more than one occasion, SG has run events that are only supposed to be triggered by an alarm - but Caddx had no alarm. Scares the crap out of you at 2:30 am. I'm guessing it is a serial comm problem between SG and Caddx, but I can't see anything wrong. I wonder if I might see the same 0.1% behavior with Caddx+HS. Anybody else see this with either setup?

          And as the other Tim mentioned, I consider my alarm system to be mission critical. I don't want to take the risk that my alarm events won't occur because HS crashed, or even slowed because CPU usage went sky-high. So I live with the 0.1% error with SG+Caddx.

          Mark
          Mark

          Comment


            #6
            A lot of times it just does not respond to it. I have an event in the morning that changes the hs request variable to disarm the alarm it does not work.

            Another biggie for me is that I have an event in SG that loads the user_VAR with the last code in the alarm and it causes the alarm to either turn itself off or right back on after the code is entered.

            Tonight I wired it to HS and I'm going to play with the plug in.
            -Tim

            HSPro - 3.XXX - Dell mini W7 x32
            Way2 Call
            Elk M1 Gold
            UPB HAI switches
            HAI RC2000 Thermostat

            Comment


              #7
              Originally posted by email68 View Post
              A lot of times it just does not respond to it. I have an event in the morning that changes the hs request variable to disarm the alarm it does not work.

              Another biggie for me is that I have an event in SG that loads the user_VAR with the last code in the alarm and it causes the alarm to either turn itself off or right back on after the code is entered.

              Tonight I wired it to HS and I'm going to play with the plug in.
              The SG forum on Yahoo also has reports of people for whom the Caddx panel rearms when SG loads its temporary variable with the ID of the user who disarmed it. It seems to happen consistently to some users and not at all to others.

              When you set a device in HS to signal SG to disarm the alarm panel, can you confirm that SG sees the change and does not act as you expect? Or does SG not see the change? My guess is the latter. There is now a warning in the SG plug-in help file (in bold red) that the scripting functions SetDeviceStatus and SetDeviceValue do not work with devices created by importing them from SG. If that is how you are trying to communicate, that may be the problem. If you use ExecX10 instead, the actions may work.
              Mike____________________________________________________________ __________________
              HS3 Pro Edition 3.0.0.548, NUC i3

              HW: Stargate | NX8e | CAV6.6 | Squeezebox | PCS | WGL 800RF | RFXCOM | Vantage Pro | Green-Eye | Edgeport/8 | Way2Call | Ecobee3 | EtherRain | Ubiquiti

              Comment


                #8
                Mike

                I don't use scripting functions yet so I don't know if that applies. I created the variables in SG and had HS import them.

                I've been the one on the yahoo list primarily asking about this problem so it was me you were reading about. Although there was one other one too. I sent all my info to Jeff@JDS and he could not find a problem either. The disarm/rearm problem happened with HS not running.

                Last night I got the jvcaddx plug in running. I think its a lot easier to work with than passing variables back and forth. So I'm going to go this route for now and see how it works.
                -Tim

                HSPro - 3.XXX - Dell mini W7 x32
                Way2 Call
                Elk M1 Gold
                UPB HAI switches
                HAI RC2000 Thermostat

                Comment


                  #9
                  Originally posted by email68 View Post
                  Mike

                  I don't use scripting functions yet so I don't know if that applies. I created the variables in SG and had HS import them.

                  I've been the one on the yahoo list primarily asking about this problem so it was me you were reading about. Although there was one other one too. I sent all my info to Jeff@JDS and he could not find a problem either. The disarm/rearm problem happened with HS not running.

                  Last night I got the jvcaddx plug in running. I think its a lot easier to work with than passing variables back and forth. So I'm going to go this route for now and see how it works.
                  Did anyone find the solution to why the caddax will rearm after a disarm from the caddax panel?? I have the same issue intermittently if stargate is running and I disarm from the caddax. Does not happen from the Stargate panel.

                  Comment

                  Working...
                  X