Announcement

Collapse
No announcement yet.

Homeseer not polling

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Homeseer not polling

    I just installed Homeseer for use with my JDS Stargate system. I don't know if it's just me but I cannot get the polling from the status page to work. This is what I have come across. On the status web page I can click ON a device and the light will light. If I turn the light on manually at the source, it never lights up on the status page. Turning the light ON from HSTouch, turns the light on but not on the status page.

    I tried this with polling on and off. Does anyone know anyhting I could try to get this to work correctly?

    #2
    A couple of questions, What interface are you connecting to between Stargate and Homeseer? Mine is in Serial for instance.
    I assume you are running the Stargate plugin and have imported your devices fron the Stargate.
    In my case the Stargate has the X10 connection so I had to tell Homeseer to use Stargate for that.
    Don't know if maybe these may jog some ideas but maybe.

    Also maybe someone else has some ideas.

    Comment


      #3
      I'm using the serial interface. Yes I am running the latest STargate plugin and I have imported my devices. Not sure what you mean by 'tell Homeseer to use Stargate for that'. I'm guessing I did that because it works manually from the status page. Maybe I need to reboot Stargate?

      Comment


        #4
        On mine if I turn X10 things on and off with Homeseer it shows on the status page and I am pretty sure for HSTouch also. I'll have to check that. If I manually turn on an X10 device I don't know if it will change or not as I never tried that. All my X10 actions are controlled by Homeseer by events. For instance I have an X10 wireloess remote on the bed post to turn on the vanity lights. The remote sends the signal to a W800 receiver that gives it to Homeseer, when Homeseer sees that house and unit code with an action it runs a script to turn on or off the vanity lights on a different code.

        Actually I do have a plugin remote in the garage to turn on the AC and compressor out there. I'll have to look at that and see if the status shows when I do that.

        The place I was refering to was on the setup page under Interfaces, X10, selecting Stargate and under polling interval under Stargate configuration. As you already have that it must be something else.

        Comment


          #5
          Originally posted by jweiss View Post
          I just installed Homeseer for use with my JDS Stargate system. I don't know if it's just me but I cannot get the polling from the status page to work. This is what I have come across. On the status web page I can click ON a device and the light will light. If I turn the light on manually at the source, it never lights up on the status page. Turning the light ON from HSTouch, turns the light on but not on the status page.

          I tried this with polling on and off. Does anyone know anyhting I could try to get this to work correctly?
          I would recommend that you leave polling off. The most effective way to make HS aware of changes is with the built-in callback function. In my experience, polling only confuses things.

          As far as manual actuation of X10 devices, it is rare to find an X10 switch that reports its status when activated manually, so unless you know for sure that your switch reports, then I wouldn't expect HS to be aware of its manual change. For instance: If you look at the HS log when you actuate the light manually, do you see any message that it changed state? Can WinEVM see a manual change in the light?

          As far as HSTouch is concerned, I would expect that the HS Status should synchronize with changes made there. Again, what do you see in the HS log when you change the light's state with HSTouch?

          I doubt that restarting SG will help, but it's easy to do and can't hurt. Restarting HS is more likely to fix a problem with the plug-in communication, so I'd definitely recommend trying that if you haven't.

          Do you have an X10 transmitter? If you do, what does HS show when you use it to turn a light on or off?
          Mike____________________________________________________________ __________________
          HS3 Pro Edition 3.0.0.548, NUC i3

          HW: Stargate | NX8e | CAV6.6 | Squeezebox | PCS | WGL 800RF | RFXCOM | Vantage Pro | Green-Eye | Edgeport/8 | Way2Call | Ecobee3 | EtherRain | Ubiquiti

          Comment


            #6
            I'm at work right now so I can't try these things until I get home. I'm not so concerened about the manual reproting as I am about HSTouch. I would like to know more about this built-in callback. Where is it located?

            I will try checking the logs and the transmitter tonight.

            Comment


              #7
              Based on my (weak) understanding, the callback is a core function of HS that is implemented by many plug-ins, including the SG plug-in. It provides nearly instantaneous response to changes in device states, and avoids the overhead of having every plug-in continually polling devices. (I'm sure there's a better explanation. If you pose the question in the general forum you'll probably get a response from someone who is more familiar with how it works.)
              Mike____________________________________________________________ __________________
              HS3 Pro Edition 3.0.0.548, NUC i3

              HW: Stargate | NX8e | CAV6.6 | Squeezebox | PCS | WGL 800RF | RFXCOM | Vantage Pro | Green-Eye | Edgeport/8 | Way2Call | Ecobee3 | EtherRain | Ubiquiti

              Comment

              Working...
              X