Announcement

Collapse
No announcement yet.

Z-Wave Thermostat plugin.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Hi Guys-

    Wow you post fast! The correct syntax is:

    hs.plugin("ZWave Thermostats").GetTemp([Thermostat ID],[Sensor ID])

    For the purposes of this plugin, the Thermostat ID is the HomeSeer DeviceCode number assiged to the thermostat device. The sensor ID will always be 1, as there are no ZWave Thermostats that support sensors. It is an optional parameter, so you could leave it out if you want to:

    hs.plugin("ZWave Thermostats").GetTemp([Thermostat ID])

    This will work just as well. If you are still seeing the Object Reference errors, be sure that you have the latest version from the updater. This was an issue in older builds, but it should be resolved in the latest (1.0.2407.something I think...)
    -RJ (HomeSeer Tech)

    Comment


    • #17
      I'm running version 1.0.2407.15582

      And I'm still getting the Object reference not set to an instance of an object. Errors.

      8/8/2006 10:48:04 AM - ZWave Thermosta - Error in HSPI.GetTemp, Object reference not set to an instance of an object.


      I'm also still seeing
      8/8/2006 1:41:44 AM - ZWave Thermosta - Staus Error: Error sending setpoint command (C<2><8>), return was ERROR

      and

      8/8/2006 1:41:44 AM - ZWave Thermosta - Staus Error: Error sending setpoint command (C<2><8>), return was ERROR

      At none of these times I was doing anything with the thermostat.
      Joe (zimmer62)

      BLSecurtiy, AC-RF2, RCS Serial Thermostats, RFXCOM SMarthome SwitchLinc, mcsXap, Global Cache GC100, SqueezeBox, TWA_ONKYOINTEGRA, BLLogMonitor, BLPlugins, BLRadar, BLSpeech, BLZLog.aspx, HSTouch (Windows, iPhone, iPod), USB Mimo touchscreens, VMWare Server, Vortexbox, Windows Home Server, MyMovies, Windows Media Center, X10, ZWave, and much much much more.

      Comment


      • #18
        Hi Joe-

        Can you paste your startup log into this thread so I can look at it? It seems like the thermostat is not being created successfully.
        -RJ (HomeSeer Tech)

        Comment


        • #19
          I am also seeing the same thing here as well.

          Thanks

          Thom


          Originally posted by zimmer62
          I'm running version 1.0.2407.15582

          And I'm still getting the Object reference not set to an instance of an object. Errors.

          8/8/2006 10:48:04 AM - ZWave Thermosta - Error in HSPI.GetTemp, Object reference not set to an instance of an object.


          I'm also still seeing
          8/8/2006 1:41:44 AM - ZWave Thermosta - Staus Error: Error sending setpoint command (C<2><8>), return was ERROR

          and

          8/8/2006 1:41:44 AM - ZWave Thermosta - Staus Error: Error sending setpoint command (C<2><8>), return was ERROR

          At none of these times I was doing anything with the thermostat.

          Comment


          • #20
            My startup log
            Attached Files
            Joe (zimmer62)

            BLSecurtiy, AC-RF2, RCS Serial Thermostats, RFXCOM SMarthome SwitchLinc, mcsXap, Global Cache GC100, SqueezeBox, TWA_ONKYOINTEGRA, BLLogMonitor, BLPlugins, BLRadar, BLSpeech, BLZLog.aspx, HSTouch (Windows, iPhone, iPod), USB Mimo touchscreens, VMWare Server, Vortexbox, Windows Home Server, MyMovies, Windows Media Center, X10, ZWave, and much much much more.

            Comment


            • #21
              after the restart I just did, now I get this when running this script
              PHP Code:
              Sub Main(parm as object)
              Dim rval as String 
              rval 
              hs.plugin("ZWave Thermostats").GetTemp(71)
              hs.speak("Thermostat temperature is " rval)
              End Sub 
              8/8/2006 3:37:14 PM - Info - Speak ():Thermostat temperature is 0
              8/8/2006 3:37:14 PM - ZWave Thermosta - Error in HSPI.GetTemp, Object reference not set to an instance of an object.
              8/8/2006 3:37:14 PM - Info - Running script in background: thermostat_change.vb
              8/8/2006 3:37:14 PM - Warning - Only events with 'WAIT' actions can be cancelled.
              8/8/2006 3:37:14 PM - Warning - Event could not be cancelled, it was not found.
              Joe (zimmer62)

              BLSecurtiy, AC-RF2, RCS Serial Thermostats, RFXCOM SMarthome SwitchLinc, mcsXap, Global Cache GC100, SqueezeBox, TWA_ONKYOINTEGRA, BLLogMonitor, BLPlugins, BLRadar, BLSpeech, BLZLog.aspx, HSTouch (Windows, iPhone, iPod), USB Mimo touchscreens, VMWare Server, Vortexbox, Windows Home Server, MyMovies, Windows Media Center, X10, ZWave, and much much much more.

              Comment


              • #22
                Hi Joe-

                The script may need to be written as:

                Code:
                Sub Main()
                 
                Dim pi
                Dim rval
                 
                pi = hs.plugin("ZWave Thermostats")
                rval = pi.GetTemp(7,1)
                End Sub
                -RJ (HomeSeer Tech)

                Comment


                • #23
                  still 0
                  Joe (zimmer62)

                  BLSecurtiy, AC-RF2, RCS Serial Thermostats, RFXCOM SMarthome SwitchLinc, mcsXap, Global Cache GC100, SqueezeBox, TWA_ONKYOINTEGRA, BLLogMonitor, BLPlugins, BLRadar, BLSpeech, BLZLog.aspx, HSTouch (Windows, iPhone, iPod), USB Mimo touchscreens, VMWare Server, Vortexbox, Windows Home Server, MyMovies, Windows Media Center, X10, ZWave, and much much much more.

                  Comment


                  • #24
                    Hi Joe-

                    Can you send me your ZWave.cfg file from your HomeSeer Config folder? I think the ID may be set incorrectly, and I can look at this file to figure that out. My email is rj [at] homeseer.com

                    Thanks.
                    -RJ (HomeSeer Tech)

                    Comment


                    • #25
                      sent.
                      Joe (zimmer62)

                      BLSecurtiy, AC-RF2, RCS Serial Thermostats, RFXCOM SMarthome SwitchLinc, mcsXap, Global Cache GC100, SqueezeBox, TWA_ONKYOINTEGRA, BLLogMonitor, BLPlugins, BLRadar, BLSpeech, BLZLog.aspx, HSTouch (Windows, iPhone, iPod), USB Mimo touchscreens, VMWare Server, Vortexbox, Windows Home Server, MyMovies, Windows Media Center, X10, ZWave, and much much much more.

                      Comment


                      • #26
                        Hi Joe-

                        Your thermostat is at index 3. The call should be:
                        GetTemp(3, 1)

                        I think what happened here is you were using the Z-Wave ID (which is 7) as opposed to the Thermostat Device Code (which should be 3). If the thermostat is not "q3" in HomeSeer (assuming "q" is your Z-Wave House Code), then there is a problem here, but I think this is what is going on.
                        -RJ (HomeSeer Tech)

                        Comment


                        • #27
                          Yup, that was it.

                          I guess I really misunderstood the device code concept, It wasn't asking for Q3, it was asking for just a number, and all I could find was that it was at zwave 7

                          I'm pretty new to the zwave devices, and I guess I made a a$$ume of myself.

                          Thanks for your help!!
                          Joe (zimmer62)

                          BLSecurtiy, AC-RF2, RCS Serial Thermostats, RFXCOM SMarthome SwitchLinc, mcsXap, Global Cache GC100, SqueezeBox, TWA_ONKYOINTEGRA, BLLogMonitor, BLPlugins, BLRadar, BLSpeech, BLZLog.aspx, HSTouch (Windows, iPhone, iPod), USB Mimo touchscreens, VMWare Server, Vortexbox, Windows Home Server, MyMovies, Windows Media Center, X10, ZWave, and much much much more.

                          Comment


                          • #28
                            No problem Joe, I need to update the docs on this anyway!
                            -RJ (HomeSeer Tech)

                            Comment


                            • #29
                              Z-Wave Termostat Plugin

                              I am seeing this same thing in trying to use this is a script also. I am using version 1.0.2419.1539 of the plugin. Attached is a copy of my ZWave.cfg.

                              It would also be nice if the plugin created HS devices for temp, setpoints, mode and fan so that I can pass these to mainlobby. I guess I will setup a script to poll these and then create devices.
                              Attached Files

                              Comment


                              • #30
                                hi,

                                i am having an issue speaking the temp as in a post that you helped someone else in. i have a zwave thermostat plugin for my trane stat...i also see a zwave thermostat temperature sensor in my status devices. i entered the number that is represented in my device as Qx for both the stat and the temp sensor but no luck...i do not have a zwave config file either...how can i confirm my device number?

                                does the gettemp get the value in the device? my stat has a value = 0 while my temp sensor has value = 7100 for 71 degrees...so i would think i would need to get that value?

                                thanks,

                                Comment

                                Working...
                                X