Announcement

Collapse
No announcement yet.

Setting Run Mode to "Hold"

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Setting Run Mode to "Hold"

    Hello All,

    I have a Trane Z-Wave thermostat which has a run mode of Hold. When set to this mode, the thermostat will keep the current temperature (e.g. it overrides the setback schedule programmed into the thermostat). I would like to be able to change the run mode to Hold using an HomeSeer event. However, Hold is not an option in the drop down list when setting up the event. Is it possible to change the run mode to hold from a script?



    Thank you,
    Michael


  • #2
    I have the WDTC-20 thermostats and they do not support Hold. So, to make sure yours supports Hold via the API, go to Tools -> Control Panel and run this immediate script command:

    PHP Code:
    hs.writelog("debug","supports Hold=" hs.Plugin("ZWave Thermostats").supportsHold(1,1)) 
    You might have to change the parms for the thermostat number and temperature sensor. Check your HS log and see if it says True.

    If so, then you should be able to run something along the lines of:

    PHP Code:
    hs.Plugin("ZWave Thermostats").CmdSetHold(1,1,1
    The 3 parms for CmdSetHold are: Thermostat number,Mode,Temp Sensor.

    Let us know if that works for you. If the immediate script commands work, then you should be able to create an event that runs that one-liner to set the hold.
    HS3Pro Running on a Raspberry Pi3
    64 Z-Wave Nodes, 168 Events, 280 Devices
    UPB modules via OMNI plugin/panel
    Plugins: Z-Wave, BLRF, OMNI, HSTouch, weatherXML, EasyTrigger
    HSTouch Clients: 3 Android, 1 Joggler

    Comment


    • #3
      Thanks for the quick reply. I will give it a try this weekend and let you know how I made out.

      Michael

      Comment


      • #4
        When I try to set the hold mode in a script, I get the following in the log:

        ZWave Thermostats, Hold mode is not supported.

        Do you have any other suggestions to try?

        Thanks,
        Michael

        Comment


        • #5
          Originally posted by mlucas View Post
          When I try to set the hold mode in a script, I get the following in the log:

          ZWave Thermostats, Hold mode is not supported.

          Do you have any other suggestions to try?

          Thanks,
          Michael
          Is this the results of the script previously posted? Why not use HomeSeer to schedule your stat rather than the schedule within the stat?
          -Rupp
          sigpic

          Comment


          • #6
            Several moths ago I corresponded with RCS Tech support about this issue and they said that it was a function of the Z-wave specifications not supporting this capability.

            I do not know if the latest Z-wave capabilities have added this function. I just sent another email to the RCS folks asking them about this and will post the answer back here.

            I noticed that on the RCS website there is a TW43 that appear to be the same as the TZ43 EXCEPT it uses WiFi rather than Z-wave. I have not seen anyone mention that device here and that model is not in the HS Store. But it would be great if a supplementary plug-in could be created to support that device (and hopefully allow the Run/Hold to be implemented).

            Rupp, in answer to your question one of the key tenets of my approach to Home Automation was to try to have the source device do its thing as much as possible and let HS control as desired. For this reason I specifically selected the TZ43 for its independent scheduling capability. That way I do not have to create a bunch of events to control the NORMAL thermostat scheduling.

            Regards,
            Vector

            Comment


            • #7
              would be nice to set thermostat on hold

              was playing around with the thermostat and it would be nice to override the schedule for lets say a vacation setting. All I would come up with is running a event that gets triggered when thermostat rises/lowers temp and than sets it back to requested temp, a little complicated but should work.

              Comment


              • #8
                After a couple of back and forth emails with RCS Tech Support, they told me that:
                1. 1. The TZ43 DOES support the Z-Wave Command Class that incorporates RUN/HOLD.
                2. The minimum version info is:
                Firmware Ver 1.00.10
                Z-Wave Ver 2.0.9

                My TZ43's meet this: They are 1.00.11 and 2.0.9, but I still do not have any Run/Hold Controls on the "Plug-in" page. I also tried the script posted above by RMASONJR and got a FALSE return value in the log - not sure what this implies, since per RCS info, my thermostats Do support the command. I would really appreciate it if Rich or Rick could figure out how to add that functionality, as it greatly enhances the usability of the thermostat.


                A few other points:
                1. RCS also told me that the TIME command (whatever that is).
                2. RCS (in a prior discussion) told me that the Trane thermostats are a FIXED firmware level and cannot (or will not - not sure which) be upgraded. I cannot say whether the Trane units meet the above firmware requirements as I do not have one.
                3. Per the RCS website, there is also a TW43, which appears exactly the same but operates over Wi-Fi (and is iPhone compatible). I do not know if HomeSeer plans to support that device, or if someone else could write a plug-in. This would seem to be a great way to get wireless control for those that are not investing in Z-wave.
                Regards,
                Vector
                Last edited by Vector; March 25th, 2010, 11:46 PM.

                Comment


                • #9
                  My trane claims to support the following (from the Z-Wave Node Who Am I screen)

                  THERMOSTAT MODE, THERMOSTAT OPERATING STATE, THERMOSTAT SETPOINT, THERMOSTAT FAN MODE, THERMOSTAT FAN STATE, CONFIGURATION, SENSOR MULTILEVEL, VERSION, CLOCK, MANUFACTURER SPECIFIC, LOCK, ASSOCIATION
                  I'm not sure which firmware it supports, tho it does say Lib 2.64, and App 20.9 on that same screen, but that doesn't sound right - I will have to go to the physical stat and check.


                  G

                  Comment


                  • #10
                    My firmware is 1.00.13, with ZWave 2.00.9 - yet, I have no options for setting mode within the ZWave Thermostat plugin. Is it possible this just isn't an option within the plugin? (Sorry, don't know enough about scripting to confirm the above immediate-script - not sure where to place it to run it).

                    Comment


                    • #11
                      I haven't been able to figure out how to take the thermostat out of "Hold" mode. However, I have figured out how to change it from Run to ESM and back. Simply go to the control section of HomeSeer, select the thermostat turn it "On" for Run, and "Off" for ESM (do not use the thermostat plugin to do this - just a direct on/off z-wave command).

                      Here's hoping this can be added to the Thermostat Plugin.

                      Comment


                      • #12
                        Further exploration on this topic - Sending an "ON" command to the Trane thermostat takes it out of ESM and puts it into either Run or Hold depending on what mode had been previously used. "Off" consistently puts it into ESM.

                        Still no clue how to change from Run to Hold (or vice versa).

                        Anyone else had any luck??

                        Comment


                        • #13
                          How to you send the "on" and "off" command to the thermostat in an event? The thermostats don't show up as devices when I try a Device Action and there is no "on/off" option when I select ZWave Thermostats Actions. I'm trying to get the thermostats to enter ESM when I put the house into "Away" mode via a virtual device. Any help would be appreciated.

                          Comment


                          • #14
                            Originally posted by travis010 View Post
                            How to you send the "on" and "off" command to the thermostat in an event? The thermostats don't show up as devices when I try a Device Action and there is no "on/off" option when I select ZWave Thermostats Actions. I'm trying to get the thermostats to enter ESM when I put the house into "Away" mode via a virtual device. Any help would be appreciated.
                            No movement on the feature request I submitted either.

                            Comment


                            • #15
                              I would also really like to see some info on this as well. My TZ43 supports RUN/HOLD/AWAY. And being able to by-pass the schedule while away for days would be very beneficial. However, I see nothing in the homeseer interface allowing me to see the RUN/HOLD/AWAY status (or set it). I am also using HSTouch to control the thermostat, but that RCS Thermostat Element does not show any RUN/HOLD/AWAY setting control.

                              TZ43
                              ZVER: 02.00.9
                              Ver: 01.00.31

                              Brian

                              Comment

                              Working...
                              X